View Full Version : mysql password during installation

21st September 2005, 12:59
hi guys
my first installation of ispconfig failed however the /home/admispconfig is exist which seems to be incompleted, at least its missing spamassasin,

anyhow I tried to re-install the ispconfig and it doesn't ask the mysql password second time as I can't re-enter the installaiton will lead to failure as below.

I'm a total newbie in linux enviroment so may be something very simple for you.


########## INSTALLATION ##########

Preparing files. Please wait a moment...
cp: cannot stat `/home/admispconfig/ispconfig/lib/config.inc.php': No such file or directory
cp: cannot stat `/home/admispconfig/ispconfig/users': No such file or directory
cp: cannot stat `/home/admispconfig/ispconfig/adminmail.txt': No such file or directory
All prerequisites are fulfilled.
Here we go...

Warning: main(config.inc.php): failed to open stream: No such file or directory in /home/mohd/install_ispconfig/install.php on line 624

Warning: main(): Failed opening 'config.inc.php' for inclusion (include_path='.:/root/ispconfig/php/lib/php') in /home/mohd/install_ispconfig/install.php on line 624

Warning: mysql_connect(): Access denied for user 'root'@'localhost' (using password: NO) in /home/mohd/install_ispconfig/install.php on line 634
Could not connect to db
Restarting some services...
httpd not running, trying to start
(98)Address already in use: make_sock: could not bind to address [::]:80
no listening sockets available, shutting down
Unable to open logs
./setup2: line 883: [: ==: unary operator expected
./setup2: line 901: /etc/rc.d/init.d/ispconfig_server: No such file or directory
Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.

[root@host install_ispconfig]#

21st September 2005, 13:07
Before you can reinstall ISPConfig, you must delete the failed installation parts.

rm -rf /root/ispconfig
rm -rf /home/admispconfig

The unpack the installer tar.gz file again and run the setup script.

21st September 2005, 13:10
thanks dude,
will do now.

21st September 2005, 19:47
I had a similar problem, and re-installing did not help. In the end i had to temporarily set the mysql root users password to an empty string. Then i started the install from scratch again and it worked fine.

FYI, the neccessary SQL on my Debian/sarge box was:

update user set password='' where user='root' and host='localhost';
flush privileges;

I would recommend setting this back to a sane and secure value afterwards. You'll also need to edit the ispconfig files to reflect this change.

21st September 2005, 19:52
thanks dude
the issue was solved after deleting those two folder, ispconfig is runing now :)