PDA

View Full Version : yum install httpd problem


dannypb
26th October 2011, 17:09
I am trying to setup an ispconfig web server on RHEL 6.1 using your guide at:

http://www.howtoforge.com/perfect-server-centos-6.0-x86_64-ispconfig-3-p3

Everything was going fine until I attempted to install yum-priorities and httpd and some other packages. The error I get is:

yum install httpd
Loaded plugins: product-id, subscription-manager
Updating Red Hat repositories.
Setting up Install Process
No package httpd available.
Error: Nothing to do

The package repositories in /etc/yum.repos.d/epel.repo do not have an httpd package listed in them. What am I missing? Which package repository should I add for this? I am so new to yum, we are migrating from our old suse servers and I haven't used yum before, but it seems simple.

dannypb
26th October 2011, 17:25
oh and this might help, the contents for my /etc/yum.repos.d/epel.repo file. I did try commenting out the mirror and useing the base, but that didnt work either.

[epel]
name=Extra Packages for Enterprise Linux 6 - $basearch
#baseurl=http://download.fedoraproject.org/pub/epel/6/$basearch
#mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-6&arch=$basearch
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-6&arch=$basearch
failovermethod=priority
enabled=1
priority=10
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6

[epel-debuginfo]
name=Extra Packages for Enterprise Linux 6 - $basearch - Debug
#baseurl=http://download.fedoraproject.org/pub/epel/6/$basearch/debug
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-debug-6&arch=$basearch
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6
gpgcheck=1

[epel-source]
name=Extra Packages for Enterprise Linux 6 - $basearch - Source
#baseurl=http://download.fedoraproject.org/pub/epel/6/SRPMS
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-source-6&arch=$basearch
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6
gpgcheck=1

falko
27th October 2011, 16:32
Please check the CentOS repo files. Did you maybe disable the CentOS repo?

dannypb
27th October 2011, 16:57
Thanx Falko,

I feel like I'm talking to a celebrity :)

yum on RHEL didn't seem to like the CentOS repository. Although I forget the error. I think it may have something to do with RHEL wanting to keep their stuff on a dvd, and not available on the internet, but the CentOS repository seemed to be incompatible with RHEL. I was able to get the files I needed by manually installing them from dvd.

I read where someone was able to get ispConfig 2 and 3 working with RHEL, but they kept the default RHEL libraries it looked like. My boss is breathing down my neck about this, so I'm going with webmin. It seems to work well so far with RHEL 6 with some additional packages.

Thanx for your help again. I primarily a programmer and not a system admin, but I prefer to use unix. If I let the server team build my servers, they will only do winblows :( so I gotta get this up and it looks good so far. I might revisit ispConfig later. In retrospect I shoulda gone with CentOS, but work wanted support.

nbhadauria
2nd November 2011, 12:01
it might be late ..

but you can use the RHEL dvd as yum repository, and if you want i can help you with this.

dannypb
9th August 2012, 22:10
I went back to the RHEL server again, and found out what my issue was. RHEL users will need to go to the RHN website and go to their server.

https://access.redhat.com/subscriptions/rhntransition/

Mouse over subscriptions, click overview.
I had to click the number in the classic column to see the actual server list.
I then clicked the server name in the system column
Then click the software tab
then click the software channels sub tab
find and check the RHEL Server Optional option
click the change subscription button on the bottom

Then all your updates should work fine. I successfully used these instructions after making that RHEL update:

http://www.howtoforge.com/perfect-server-centos-6.1-x86_64-with-apache2-ispconfig-3

I hope this helps someone.... and TY nbhadauria for your offer.