PDA

View Full Version : Shout Out


linutzy
10th September 2005, 07:34
A shout out goes to the developers here. I finally see the error of my ways during the install and now I have the beginnings of a server.

The one thing that still eludes me is figuring out why I have this error when I try to login to http://domain.net:81/mailuser/login/index.php

and get this error:

Error: User error: Unknown AUTHORIZATION state command

linutzy
10th September 2005, 19:26
If you get still the same error when logging in as mailuser:

1) have you created a new client?
2) have you created a new website, where mailuser login is activated?
3) have you created a new mailuser?


Yes to all three and the output looks like this when I change the debug mode to var $debug=1 in

/home/admispconfig/ispconfig/web/mailuser/lib/classes/pop3.inc.php

Connecting to localhost ... < +OK POP3 localhost.localdomain v2003.83 server ready > USER web1_user0 < -ERR Unknown AUTHORIZATION state command Closing connection.


Sorry to start a new thread with this.

till
11th September 2005, 13:06
If you get still the same error when logging in as mailuser:

1) have you created a new client?
2) have you created a new website, where mailuser login is activated?
3) have you created a new mailuser?


Yes to all three and the output looks like this when I change the debug mode to var $debug=1 in

/home/admispconfig/ispconfig/web/mailuser/lib/classes/pop3.inc.php

Connecting to localhost ... < +OK POP3 localhost.localdomain v2003.83 server ready > USER web1_user0 < -ERR Unknown AUTHORIZATION state command Closing connection.


Sorry to start a new thread with this.

I dont think there is an easy solution for this problem. It ssems that your POP3 deamon does not support this type of authorization, but I've never seen this problem before with ISPConfig.

Till

linutzy
11th September 2005, 17:57
Did I do something wrong during the install.
When you say pop3 deamon what should I be looking at.
How can I be the only one with the issue and how does the error generate and why?

I'm gonna at least give it a try.

What I have above is the full error unmodified. Should localhost.localdomain actually have a real value like mail.cnn.com?


NOTE: It's interesting, during the setup at falkotimme.com Unless I did it twice wrong there was a line in /etc/postfix/main.cf that I had to add in manually and that was:

smtpd_sasl_local_domain = $myhostname

I doubt it is related but the $myhostname I had to edit with VIM.

falko
11th September 2005, 19:28
Which POP3 daemon did you install? ipopd or courier-pop?

linutzy
11th September 2005, 19:57
I did not do the following since the "note" at the bottom says I do not need to if I have ISPconfig installed. I assume that since I have ISPconfig installed I can pass doing the Courier-IMAP/Courier-POP3 apt-get correct? (also I want to use mailder and have it checked in ispconfig)


Courier-IMAP/Courier-POP3

If you want to use a POP3/IMAP daemon that has Maildir support (if you do not want to use the traditional Unix mailbox format) you can install Courier-IMAP/Courier-IMAP-SSL (for IMAPs on port 993) and Courier-POP3/Courier-POP3-SSL (for POP3s on port 995). Otherwise you can proceed with the Apache configuration.

apt-get install courier-imap courier-imap-ssl courier-pop courier-pop-ssl

<- No


ipopd and UW-IMAP will then be replaced.

Then configure Postfix to deliver emails to a user's Maildir*:

postconf -e 'home_mailbox = Maildir/'
postconf -e 'mailbox_command ='
/etc/init.d/postfix restart

*Please note: You do not have to do this if you intend to use ISPConfig on your system as ISPConfig does the necessary configuration using procmail recipes. But please go sure to enable Maildir under Management -> Settings -EMail in the ISPConfig web interface.

falko
11th September 2005, 20:32
If you want to use Maildir then you have to use courier-pop!
*Please note: You do not have to do this if you intend to use ISPConfig on your system as ISPConfig does the necessary configuration using procmail recipes. But please go sure to enable Maildir under Management -> Settings -EMail in the ISPConfig web interface.

This note is related only to the last step:
Then configure Postfix to deliver emails to a user's Maildir*:

postconf -e 'home_mailbox = Maildir/'
postconf -e 'mailbox_command ='
/etc/init.d/postfix restart
So please do the following in order to install courier-imap and courier-pop:
apt-get install courier-imap courier-imap-ssl courier-pop courier-pop-ssl

linutzy
11th September 2005, 20:57
That seems to have gotten rid of that error now I have this:

Connecting to localhost ... < +OK Hello there. > USER web4_gene0 < +OK Password required. > PASS XXXXXX < -ERR Maildir invalid (no 'cur' directory) Closing connection

falko
11th September 2005, 21:11
That's normal. The necessary directories are created automagically when the first email arrives in that mailbox, so try to send a test mail to that mailbox, and try to get the email afterwards with POP3. :)

linutzy
11th September 2005, 21:17
Connecting to localhost ... < +OK Hello there. > USER web1_marko0 < +OK Password required. > PASS XXXXXXX < +OK logged in. Closing connection.
Warning: Cannot modify header information - headers already sent by (output started at /home/admispconfig/ispconfig/web/mailuser/lib/classes/pop3.inc.php:52) in /home/admispconfig/ispconfig/web/mailuser/login/index.php on line 66


Before I'm done with this forum you guys will have the biggest FAQ on the planet :-)

By the way I just did a quick test and it works, thanks for all your help FT.


Also I just figured out I need to return the previous variable back to 0 and not 1, the above error is gone now.