PDA

View Full Version : Web-FTP: cannot connect to server localhost


schmidtedv
15th June 2006, 13:35
Well, my Problem is a bit confusing, FTP works fine but Web-FTP get's me the message, that it could not connect to localhost...might there be some wrong permissions on folders or any idea?

PS: Falko, I'm correcting / re-translate the german lang-files at the moment, but, there seem to be some variables not catched up by the lang-files (example 'create DNS MX' will not become 'DNS MX anlegen') ...even with the DEV-files it's not getting changed.

till
15th June 2006, 15:15
Well, my Problem is a bit confusing, FTP works fine but Web-FTP get's me the message, that it could not connect to localhost...might there be some wrong permissions on folders or any idea?

Thsts not a permission problem, as WebFTP connects trugh your FTP server like any other FTP client.

Please check that your FTP daemon listens on all interfaces incl. localhost and that your /etc/hosts file has a correct line pointing localhost to 127.0.0.1

PS: Falko, I'm correcting / re-translate the german lang-files at the moment, but, there seem to be some variables not catched up by the lang-files (example 'create DNS MX' will not become 'DNS MX anlegen') ...even with the DEV-files it's not getting changed.

If a line is missing in the german anguage file, please check the english language files if the line is there. Then copy the line to the german language file and translate it.

The english .lng files are the master files and it might be that there are some lines missing in the other languages.

schmidtedv
15th June 2006, 15:21
Hosts is ok, bot how can I figure out, if proftpd (standalone) is also listening for connections on localhost?

-lng-files I will check then with the english ones, thx-

till
15th June 2006, 15:23
if proftpd (standalone) is also listening for connections on localhost?

netstat -tap

schmidtedv
15th June 2006, 15:25
hm, well, I'm not shure...

Aktive Internetverbindungen (Server und stehende Verbindungen)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 localhost:mysql *:* LISTEN 2073/mysqld
tcp 0 0 *:81 *:* LISTEN 2283/ispconfig_http
tcp 0 0 *:ftp *:* LISTEN 2452/proftpd: (acce
tcp 0 0 xx-16-250-xxx.in:domain *:* LISTEN 2439/named
tcp 0 0 xx-16-250-xxx.in:domain *:* LISTEN 2439/named
tcp 0 0 xx-16-251-xx.int:domain *:* LISTEN 2439/named
tcp 0 0 localhost:domain *:* LISTEN 2439/named
tcp 0 0 *:smtp *:* LISTEN 7167/master
tcp 0 0 localhost:953 *:* LISTEN 2439/named
tcp6 0 0 *:imaps *:* LISTEN 1990/couriertcpd
tcp6 0 0 *:pop3s *:* LISTEN 2011/couriertcpd
tcp6 0 0 *:pop3 *:* LISTEN 1998/couriertcpd
tcp6 0 0 *:imap2 *:* LISTEN 1977/couriertcpd
tcp6 0 0 *:www *:* LISTEN 2313/apache2
tcp6 0 0 *:ssh *:* LISTEN 2228/sshd
tcp6 0 0 *:smtp *:* LISTEN 7167/master
tcp6 0 0 localhost:953 *:* LISTEN 2439/named
tcp6 0 0 *:https *:* LISTEN 2313/apache2
tcp6 0 0 xx-16-251-xx.intern:ssh p549FA684.dip0.t-:61883 VERBUNDEN 8476/sshd: root@not
tcp6 0 0 xx-16-251-xx.intern:ssh p549FA684.dip0.t-:61884 VERBUNDEN 8502/sshd: root@not
tcp6 0 0 xx-16-251-xx.intern:ssh p549FA684.dip0.t-:62608 VERBUNDEN 9449/sshd: root@not
tcp6 0 0 xx-16-251-xx.intern:ssh p549FA684.dip0.t-:62006 VERBUNDEN 8722/sshd: root@not
tcp6 0 1436 xx-16-251-xx.intern:ssh p549FA684.dip0.t-:62670 VERBUNDEN 9533/0
tcp6 0 0 xx-16-251-xx.intern:ssh p549FA684.dip0.t-:62054 VERBUNDEN 8867/sshd: root@not

till
15th June 2006, 15:29
tcp 0 0 *:ftp *:* LISTEN

FTP listens on all Interfaces. Can you plase try to connect to the FTP account on localhost with a commandline FTP client like ncftp. Did you get an error?

schmidtedv
15th June 2006, 15:31
well, I have winSCP and Putty here on my XP...and can connect via IE 6...maybe put something like: proftpd: localhost : ALLOW in my hosts.allow?

till
15th June 2006, 15:38
well, I have winSCP and Putty here on my XP...and can connect via IE 6...maybe put something like: proftpd: localhost : ALLOW in my hosts.allow?

You can not test this from your wiXP client!

Login to your server with putty from WinXP and then open a commandline FTP client and try to connect to your FTP server on localhost.

schmidtedv
15th June 2006, 15:45
...connection with ncftp and one of the users over localhost works!

falko
15th June 2006, 16:23
Which distribution do you use?

schmidtedv
15th June 2006, 16:28
debian 3.1 (your guide, but with a ground-config-image from netdirect dedicated-server) and ISP 2.3

Everything went fine, no errors in log, well, but web-ftp is not possible. Something else that could be responsible?

falko
15th June 2006, 16:38
What's in /etc/hosts? What's the output of iptables -L?
Did you change anything in the ISPConfig sources or something similar? Is maybe the ISPConfig web interface running with PHP Safe Mode enabled or something like that?

schmidtedv
15th June 2006, 17:17
Chain INPUT (policy ACCEPT)
target prot opt source destination
Chain FORWARD (policy ACCEPT)
target prot opt source destination
Chain OUTPUT (policy ACCEPT)
target prot opt source destination



### etherconf DEBCONF AREA. DO NOT EDIT THIS AREA OR INSERT TEXT BEFORE IT.
127.0.0.1 localhost
::1 localhost ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
...


pftpd.conf


ServerName "FTP"
ServerType standalone
ServerIdent on "FTP-Server bereit..."
DeferWelcome off
Port 21
Umask 022
DefaultRoot ~
MultilineRFC2228 on
DefaultServer on
ShowSymlinks on
TimeoutNoTransfer 600
TimeoutStalled 600
TimeoutIdle 1200
DisplayLogin welcome.msg
DisplayFirstChdir .message
ListOptions "-l"
DenyFilter \*.*/
IdentLookups off
MaxInstances 30
User nobody
Group nogroup
AllowOverwrite on
Include /etc/proftpd_ispconfig.conf


Wie kontrolliere ich den Save Mode?

till
15th June 2006, 17:22
Wie kontrolliere ich den Save Mode?

If you dont changed the ohp.ini in /root/ispconfig/php/ then safemode is off.

falko
15th June 2006, 17:55
Please change
127.0.0.1 localhost
to
127.0.0.1 localhost.localdomain localhost

schmidtedv
15th June 2006, 21:46
same issue with that...maybe I use too long passwords or something else stupid that doesn't let me in?

I will (if that's ok) put some logs etc. as attachment (postfix puts out something I'm not shure, if it's an error, like "terminating on signal 15")

Actually, folder "/home/ftp" has user:group = ftp:nogroup, should that maybe nouser:nogroup?

EDIT: A hint for local-host-names..I added the 2 domains at the bottom, because I have these as reverse DNS for my other 2 IP's....is that ok?

EDIT: Attachments deleted! Case fixed!

schmidtedv
15th June 2006, 21:50
...this post only for the rest of files

EDIT: and a question...can I stop pftpd sending error-message to root, if it detects, that ftp server isn't running? this seems to be just because i configured it to be "standalone", am I right? but now i get every 30 minutes the error-mail without having a real error...

EDIT: Attachments deleted! Case fixed!

falko
16th June 2006, 03:18
EDIT: and a question...can I stop pftpd sending error-message to root, if it detects, that ftp server isn't running? this seems to be just because i configured it to be "standalone", am I right? but now i get every 30 minutes the error-mail without having a real error...
This message is sent to you by ISPConfig, not Proftpd.
You can change this behaviour under Management -> Server -> Services -> Monitoring. :)

schmidtedv
16th June 2006, 08:50
So, for this issue I would just add a rule for port 21 not to monitor ftp-server...right? THX, that's easy :-)

Any idea for some of the other stuff? Seems that the only file getting viewed is ftpuser, LOL :-)

EDIT: PS: Would there be something I might have to change in the standard Firewall-Rules, if turned On, so that Outlook with Imap-Account will not bring up an error, or shouldn't this have happened in a normal configuration?

If the monitoring actually is a feature that sends mail to root, then why is aliases originally not edited for ISPConfig-Admin to receive the mails? I put mailadress manually in there for all system-messages...but I didn'T know, that ISPConfig uses this entrances too; so otherwise I wouldn't have gotten any warning-mail...correct...?

The warning is not sended to an real mailaccount without editing aliases (because there it get's to user root), just to explain,!

falko
16th June 2006, 18:42
EDIT: PS: Would there be something I might have to change in the standard Firewall-Rules, if turned On, so that Outlook with Imap-Account will not bring up an error, or shouldn't this have happened in a normal configuration?You must open port 143 in your firewall (and 995 if you want to use IMAPs).

If the monitoring actually is a feature that sends mail to root, then why is aliases originally not edited for ISPConfig-Admin to receive the mails? I put mailadress manually in there for all system-messages...but I didn'T know, that ISPConfig uses this entrances too; so otherwise I wouldn't have gotten any warning-mail...correct...?You can set the admin email address under Management -> Server -> Settings. The default address is root@localhost.

schmidtedv
16th June 2006, 20:40
Well, I know about the Admin-Mail in ICPConfig, but I didn't get emails that might be send by catching aliases, that's how it seemed for me...however, if I have the Admin-Mail I should switch back to "root" in aliases and it should work getting the error-messages to my ISP Admin-Mail?


...

falko
17th June 2006, 13:55
I'm not quite sure I understand what you mean? :confused:
Just replace root@localhost with your real email address, and you should receive the emails there.

schmidtedv
17th June 2006, 21:12
...might be, that I didn't look into the Admin-Mail-Account before, but for me it looked like getting the first FTP-Error-Message After I changed ALIASES....but maybe I just didn't log into RounCube before that...have to look that over :-)

schmidtedv
20th June 2006, 15:30
ok, there u go...finally I got it all running!

I did some significant steps wrong by the Howto-Installation becaouse of my Preinstalled Debian 3.1-Image.

I, important in this case, forgot to add the user admin...that's why ISPConfig could not authenticate (?) with Web-FTP-Login!?

A new and more exact install (adding user etc. like it would have been a fresh install) got rid of these errors now :-)

Thanks for the help by now! ISPConfig AND the howto's are really great for Beginners to start up with and I will soon try to honor this (PayPal or so?)

Flo

falko
21st June 2006, 02:23
I, important in this case, forgot to add the user admin...that's why ISPConfig could not authenticate (?) with Web-FTP-Login!?So you tried to connect to Web-FTP as the user admin? The admin user with whom you log into ISPConfig is no system user, it's a user that exists only in ISPConfig. By creating a system user admin you can now log in to FTP, but this system user admin has nothing to do with the ISPConfig user admin.

I will soon try to honor this (PayPal or so?)

FloWrite Till a PM if you want to make a donation. :)

schmidtedv
21st June 2006, 08:35
well, I tried to login into Web-FTP with different users the first time, but it didn't work...maybe something else went better the second time I installed the system now and its not because of missing System-User "admin" but now it works...

taylan
21st June 2006, 11:15
hello i try to use web-ftp it didnt work even when i try to use from xp command line i recieve following error message do you have any idea thanks


Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\taylan gulmez>ftp 192.168.1.100
Connected to 192.168.1.100.
220 localhost.localdomain FTP server (Version 5.60) ready.
User (192.168.1.100:(none)): taylan
530 Must perform authentication before identifying USER.
Login failed.
ftp>


QUOTE=falko]Which distribution do you use?[/QUOTE]

till
21st June 2006, 12:48
hello i try to use web-ftp it didnt work even when i try to use from xp command line i recieve following error message do you have any idea thanks


Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\taylan gulmez>ftp 192.168.1.100
Connected to 192.168.1.100.
220 localhost.localdomain FTP server (Version 5.60) ready.
User (192.168.1.100:(none)): taylan
530 Must perform authentication before identifying USER.
Login failed.
ftp>

You must authenticate yourself with username and password, this is not an anonymous FTP connection.

taylan
22nd June 2006, 02:18
hello
it allows me to anonymus ftp connection but doesnt allow user connection
when i use ftp damdakikedi.com then user name line comes when i put password
i recieve

C:\Documents and Settings\taylan gulmez>ftp damdakikedi.com
Connected to damdakikedi.com.
220 localhost.localdomain FTP server (Version 5.60) ready.
User (damdakikedi.com:(none)): tgulmez
530 Must perform authentication before identifying USER.
Login failed.
ftp> bye
221 Goodbye.

any idea

till
22nd June 2006, 13:42
Please try zo use an FTP-Client like ws_FTP or SmartFTP. Did you enable the FTP checkbox in the website?

If you dont disabled the username prefix, your username must start with web[ID]_.