PDA

View Full Version : Log file issues


Zoon
3rd September 2005, 20:52
Heya,

Firstly, ISPConfig is excellent, especially for a free product.

Secondly, am having some problems with the log files.

The build is a brand new flat install of redhat FC4 and I followed the howtoforge "perfect setup" guide exactly, EXCEPT I have SELinux enabled and I'm using the firewall which comes with FC4 instead of the firewall built in to ISPConfig

httpd wouldn't start originally with the original CustomLog statement in httpd.conf as follows:

CustomLog "|/root/ispconfig/cronolog --symlink=/var/log/httpd/ispconfig_access_log /var/log/httpd/ispconfig_access_log_%Y_%m_%d" combined_ispconfig

I had to comment it out in order for httpd to start correctly. I removed part of the line and httpd would start - as follows:

CustomLog "/var/log/httpd/ispconfig_access_log_%Y_%m_%d" combined_ispconfig

... this shows which bit was not working but obviously the CustomLog command does not do the same thing as before.

Once I had gotten past this, I added a vhost, and httpd failed to start again.

Going methodically, I commented out every line in Vhosts_ispconfig.conf and one by one set them active again until I found the command causing httpd to fail starting.

This is the command which caused the issue:

ErrorLog /home/web4/log/error.log

This is ls -l on the vhost folder

[root@emily web4]# ls -l
total 48
drwxrwxr-x 2 apache web4 4096 Sep 3 18:10 cgi-bin
drwxr-xr-x 2 apache web4 4096 Sep 3 19:50 log
drwxrwxrwx 2 apache web4 4096 Sep 3 18:10 phptmp
drwxr-xr-x 2 apache web4 4096 Sep 3 18:10 ssl
drwxr-xr-x 2 apache web4 4096 Sep 3 18:10 user
drwxrwxr-x 3 apache web4 4096 Sep 3 18:10 web

Any help on this would be appreciated ... I'm not too fussed about logs myself but chances are I won't be the only one with websites on this server and they may want to look at their logs.

Cheers :)

Zoon
3rd September 2005, 21:04
Oh and one other thing differ from the default, I used /home instead of /home/www for the root dir for web account folders.

till
4th September 2005, 07:55
Heya,

Firstly, ISPConfig is excellent, especially for a free product.

Secondly, am having some problems with the log files.

The build is a brand new flat install of redhat FC4 and I followed the howtoforge "perfect setup" guide exactly, EXCEPT I have SELinux enabled and I'm using the firewall which comes with FC4 instead of the firewall built in to ISPConfig

httpd wouldn't start originally with the original CustomLog statement in httpd.conf as follows:

CustomLog "|/root/ispconfig/cronolog --symlink=/var/log/httpd/ispconfig_access_log /var/log/httpd/ispconfig_access_log_%Y_%m_%d" combined_ispconfig

I had to comment it out in order for httpd to start correctly. I removed part of the line and httpd would start - as follows:

CustomLog "/var/log/httpd/ispconfig_access_log_%Y_%m_%d" combined_ispconfig

... this shows which bit was not working but obviously the CustomLog command does not do the same thing as before.

Once I had gotten past this, I added a vhost, and httpd failed to start again.

Going methodically, I commented out every line in Vhosts_ispconfig.conf and one by one set them active again until I found the command causing httpd to fail starting.

This is the command which caused the issue:

ErrorLog /home/web4/log/error.log

This is ls -l on the vhost folder

[root@emily web4]# ls -l
total 48
drwxrwxr-x 2 apache web4 4096 Sep 3 18:10 cgi-bin
drwxr-xr-x 2 apache web4 4096 Sep 3 19:50 log
drwxrwxrwx 2 apache web4 4096 Sep 3 18:10 phptmp
drwxr-xr-x 2 apache web4 4096 Sep 3 18:10 ssl
drwxr-xr-x 2 apache web4 4096 Sep 3 18:10 user
drwxrwxr-x 3 apache web4 4096 Sep 3 18:10 web

Any help on this would be appreciated ... I'm not too fussed about logs myself but chances are I won't be the only one with websites on this server and they may want to look at their logs.

Cheers :)

With your modifications the apache Logging in ISPConfig wont work anymore.

SELinux dont like apache directories in the /home directory. You can a) disable SELinux b) reconfigure SELinux that it accepts the home directory and the cronolog logging application (dont know how) or c) find out in which directory SELinux accepts apache vhosts and install ISPConfig with this settings (maybe you have to copy the cronolog binary to another location too).

Zoon
4th September 2005, 11:55
I just did

vi /etc/sysconfig/selinux

and set

SELINUX=disabled

and its all working ok now. I don't need it on anyway, cheers for the help :D