PDA

View Full Version : webpages only display default site


bosei
3rd September 2005, 07:43
Help.

For some reason I have just found that all my webs will only display the default host. e.g:
www.domain1.tld will only go to www.localhost:80. In other words, ISPConfig is creating the web and all files OK as I can see this under /srv/www/webX however I cannot see the site at all and can only see the default web created when appache was installed under SuSE. The only fix I can find for this is to use SuSEConfig to add a virtual host with it's docroot pointing to /srv/www/webX. Is there something wrong with the ISPConfig directives and they are not being included?

Tnx
bosei

till
3rd September 2005, 10:37
Help.

For some reason I have just found that all my webs will only display the default host. e.g:
www.domain1.tld will only go to www.localhost:80. In other words, ISPConfig is creating the web and all files OK as I can see this under /srv/www/webX however I cannot see the site at all and can only see the default web created when appache was installed under SuSE. The only fix I can find for this is to use SuSEConfig to add a virtual host with it's docroot pointing to /srv/www/webX. Is there something wrong with the ISPConfig directives and they are not being included?

Tnx
bosei

This loooks like a DNS-issue. The apache default host is always shown when the apache webserver does not have a vhost with the requested IP :: domain combination.

Does your DNS point to the correct IP?
If you are in a NAT enviroment, did you use the External IP of your router and not your private IP?
Does the websites have the correct IP?
If you are in a NAT enviroment, did you use the private IP for the websites and not the external IP?

falko
6th September 2005, 20:52
Help.

For some reason I have just found that all my webs will only display the default host. e.g:
www.domain1.tld will only go to www.localhost:80. In other words, ISPConfig is creating the web and all files OK as I can see this under /srv/www/webX however I cannot see the site at all and can only see the default web created when appache was installed under SuSE. The only fix I can find for this is to use SuSEConfig to add a virtual host with it's docroot pointing to /srv/www/webX. Is there something wrong with the ISPConfig directives and they are not being included?

Tnx
bosei

Does the file Vhosts_ispconfig.conf get written, or is it empty? Is it included in your httpd.conf?

bosei
7th September 2005, 19:49
Does the file Vhosts_ispconfig.conf get written, or is it empty? Is it included in your httpd.conf?

Yes it is getting written and No, it is not included in httpd.conf. I have also checked /etc/sysconfig apache2 and it is not listed there also.

I seem to have messed things up

Warning: mysql_connect() [function.mysql-connect]: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 76

Warning: mysql_connect() [function.mysql-connect]: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 76

Warning: Cannot modify header information - headers already sent by (output started at /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php:76) in /home/admispconfig/ispconfig/web/login/login.php on line 56


as I tried to fix an issue with mysql and ftp services stopping at 23:30 every night (only thing happening at 23:00 is a backup using LONE-TAR, which ends at 23:15) by running:
apt-get install mysql mysql-client mysql-shared mysql-devel perl-DBD-mysql perl-DBI perl-Data-ShowTable.

This action has now introduced further errors:

Aug 7 10:18:09 netex01 postfix[9832]: fatal: parameter inet_interfaces: no local interface found for ::1

Sep 7 12:00:01 netex01 postfix/smtp[20864]: warning: connect to private/tlsmgr: No such file or directory
Sep 7 12:00:03 netex01 postfix/smtp[20864]: warning: connect to private/tlsmgr: No such file or directory
Sep 7 12:00:03 netex01 postfix/smtp[20864]: warning: problem talking to server private/tlsmgr: No such file or directory
Sep 7 12:00:03 netex01 postfix/smtp[20864]: warning: no entropy for TLS key generation: disabling TLS support
Sep 7 12:30:01 netex01 postfix/smtp[21401]: warning: connect to private/tlsmgr: No such file or directory
Sep 7 12:30:02 netex01 postfix/smtp[21401]: warning: connect to private/tlsmgr: No such file or directory
Sep 7 12:30:02 netex01 postfix/smtp[21401]: warning: problem talking to server private/tlsmgr: No such file or directory
Sep 7 12:30:02 netex01 postfix/smtp[21401]: warning: no entropy for TLS key generation: disabling TLS support
Sep 7 12:30:08 netex01 postfix/smtpd[21404]: warning: connect to private/tlsmgr: No such file or directory
Sep 7 12:30:09 netex01 postfix/smtpd[21404]: warning: connect to private/tlsmgr: No such file or directory
Sep 7 12:30:09 netex01 postfix/smtpd[21404]: warning: problem talking to server private/tlsmgr: No such file or directory
Sep 7 12:30:09 netex01 postfix/smtpd[21404]: warning: no entropy for TLS key generation: disabling TLS support
Sep 7 12:30:09 netex01 postfix/smtpd[21404]: warning: support for restriction "check_relay_domains" will be removed from Postfix; use "reject_unauth_destination" instead


I hope I do not have to delete and re-install the whole thing.

I notice there is an update feature in ISPConfig... What url should this be set to?

bosei
8th September 2005, 00:01
Ooohhhhhhh... do I... I do????

Shucks. seems to have gone strangely quiet.

bosei
8th September 2005, 03:30
Used yast to force postfix update and all seems to be fixed.

if anyone could help with the issue of ftp and mysql stopping I would be gratefull

till
8th September 2005, 11:46
Does the socket file: /var/lib/mysql/mysql.sock exists and did you get any errors when you restart mysql?

bosei
8th September 2005, 19:43
Does the socket file: /var/lib/mysql/mysql.sock exists and did you get any errors when you restart mysql?


Yep. It exists and there are no errors when starting by executing "/etc/init.d/mysql start".

falko
9th September 2005, 18:54
Yep. It exists and there are no errors when starting by executing "/etc/init.d/mysql start".
Any MySQL error messages in /var/log/messages or /var/log/syslog?

bosei
9th September 2005, 22:25
Any MySQL error messages in /var/log/messages or /var/log/syslog?

Hi Falko

No error messages that I can see in /var/logs/messages

I have re-installed apache and updated mysql from yast so monitoring tonight.

Thanks