PDA

View Full Version : Problem with send/ receive mail in ISPconfig


freesqrt
16th May 2010, 12:54
Hi there,

just recently I have installed a fresh ISPcofig 2. everything is ok but no mail is transferred between this and other servers.

I had add these records in dns:

########################
A Record
IP-Adresse Hostname
217.218.11.213 www
217.218.11.213 mx1
217.218.11.213 mail

CNAME
Hostname Target

MX
Mailserver Hostname
mx1.mydomain.com
mail.mydomain.com

SPF
Hostname
mydomain.com
#######################

what you think about the problem?

regards,

falko
17th May 2010, 14:27
Any errors in your mail log?

freesqrt
23rd May 2010, 08:13
Hi Falko,

here is some of log in /var/log/maillog:

###################################
May 23 10:34:03 mx1 postfix/error[22555]: warning: connect to mysql server 127.0.0.1: Unknown database 'dbispconfig'
May 23 10:34:03 mx1 postfix/error[22555]: fatal: mysql:/etc/postfix/mysql-virtual_relaydomains.cf(0,lock|fold_fix): table lookup problem
May 23 10:34:03 mx1 postfix/error[22556]: warning: connect to mysql server 127.0.0.1: Unknown database 'dbispconfig'
May 23 10:34:03 mx1 postfix/error[22556]: fatal: mysql:/etc/postfix/mysql-virtual_relaydomains.cf(0,lock|fold_fix): table lookup problem
May 23 10:34:03 mx1 postfix/error[22557]: warning: connect to mysql server 127.0.0.1: Unknown database 'dbispconfig'
May 23 10:34:03 mx1 postfix/error[22557]: fatal: mysql:/etc/postfix/mysql-virtual_relaydomains.cf(0,lock|fold_fix): table lookup problem
May 23 10:34:03 mx1 postfix/error[22559]: warning: connect to mysql server 127.0.0.1: Unknown database 'dbispconfig'
May 23 10:34:03 mx1 postfix/error[22559]: fatal: mysql:/etc/postfix/mysql-virtual_relaydomains.cf(0,lock|fold_fix): table lookup problem
May 23 10:34:04 mx1 postfix/qmgr[22542]: warning: private/retry socket: malformed response
May 23 10:34:04 mx1 postfix/master[30392]: warning: process /usr/libexec/postfix/error pid 22554 exit status 1
May 23 10:34:04 mx1 postfix/qmgr[22542]: warning: transport retry failure -- see a previous warning/fatal/panic logfile record for the problem description
May 23 10:34:04 mx1 postfix/master[30392]: warning: /usr/libexec/postfix/error: bad command startup -- throttling
May 23 10:34:04 mx1 postfix/qmgr[22542]: 925A21D630A: to=<root@mx1.eshtehardpnu.ac.ir>, relay=none, delay=2827904, delays=2827902/2.1/0/0, dsn=4.3.0, status=deferred (unknown mail transport error)
May 23 10:34:04 mx1 postfix/qmgr[22542]: warning: connect to mysql server 127.0.0.1: Unknown database 'dbispconfig'
May 23 10:34:04 mx1 postfix/qmgr[22542]: fatal: mysql:/etc/postfix/mysql-virtual_relaydomains.cf(0,lock|fold_fix): table lookup problem
May 23 10:34:04 mx1 postfix/master[30392]: warning: process /usr/libexec/postfix/error pid 22555 exit status 1
May 23 10:34:04 mx1 postfix/master[30392]: warning: process /usr/libexec/postfix/error pid 22556 exit status 1
May 23 10:34:04 mx1 postfix/master[30392]: warning: process /usr/libexec/postfix/error pid 22557 exit status 1
May 23 10:34:04 mx1 postfix/master[30392]: warning: process /usr/libexec/postfix/error pid 22559 exit status 1
May 23 10:34:05 mx1 postfix/master[30392]: warning: process /usr/libexec/postfix/qmgr pid 22542 exit status 1
May 23 10:35:01 mx1 postfix/proxymap[22585]: warning: empty macro name: "$local_recipient_maps $#mydestination $#virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps"
May 23 10:35:01 mx1 postfix/proxymap[22585]: fatal: dictionary mail_dict: macro processing error
May 23 10:35:02 mx1 postfix/master[30392]: warning: process /usr/libexec/postfix/proxymap pid 22585 exit status 1
May 23 10:35:02 mx1 postfix/master[30392]: warning: /usr/libexec/postfix/proxymap: bad command startup -- throttling
May 23 10:36:02 mx1 postfix/proxymap[22606]: warning: empty macro name: "$local_recipient_maps $#mydestination $#virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps"
May 23 10:36:02 mx1 postfix/proxymap[22606]: fatal: dictionary mail_dict: macro processing error
May 23 10:36:03 mx1 postfix/master[30392]: warning: process /usr/libexec/postfix/proxymap pid 22606 exit status 1
May 23 10:36:03 mx1 postfix/master[30392]: warning: /usr/libexec/postfix/proxymap: bad command startup -- throttling
#####################################

some fatal errors are in dictionary mail_dict and database.

any idea?

clucian
23rd May 2010, 09:15
You have some problems on postfix to connect to mysql.

Check your file configuration /etc/postfix/mysql-virtual_relaydomains.cf or mysql table !

freesqrt
6th June 2010, 11:50
Hey Claucian,

yes you were right. there is some misconfig in mysql parameters in postfix.

I have uninstall/reinstall ISPConfig several times. however I change the database name during the installation process, the "dbname" in files mysql-virtual_relaydomains.cf and mysql-virtual_domains.cf are remained "dbispconfig" !!!!!

when a user try to send a mail following log has been generate:

#############################
Jun 6 14:15:47 mx1 dovecot: imap-login: Login: user=<web1_ahb>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
Jun 6 14:15:47 mx1 sendmail[10060]: o569jlha010060: Authentication-Warning: mx1.domainclf.com: admispconfig set sender to ahb@domainclf.com using -f
Jun 6 14:15:47 mx1 sendmail[10060]: o569jlha010060: from=ahb@domainclf.com, size=339, class=0, nrcpts=1, msgid=<4b342ab181545cf6029c092573407fee@localhost>, relay=admispconfig@localhost
Jun 6 14:15:47 mx1 postfix/smtpd[10061]: connect from mx1.domainclf.com[127.0.0.1]
Jun 6 14:15:47 mx1 postfix/smtpd[10061]: setting up TLS connection from mx1.domainclf.com[127.0.0.1]
Jun 6 14:15:47 mx1 sendmail[10060]: STARTTLS=client, relay=[127.0.0.1], version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
Jun 6 14:15:47 mx1 postfix/smtpd[10061]: Anonymous TLS connection established from mx1.domainclf.com[127.0.0.1]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
Jun 6 14:16:07 mx1 postfix/proxymap[10062]: warning: connect to mysql server 127.0.0.1: Access denied for user 'ispconfig'@'localhost' to database 'dbispconfig'
Jun 6 14:16:07 mx1 postfix/proxymap[10062]: warning: mysql query failed: Table 'db_ispconfig.mail_domain' doesn't exist
Jun 6 14:16:07 mx1 postfix/trivial-rewrite[10075]: fatal: proxy:mysql:/etc/postfix/mysql-virtual_domains.cf(0,lock|fold_fix): table lookup problem
Jun 6 14:16:08 mx1 postfix/smtpd[10061]: warning: problem talking to service rewrite: Connection reset by peer
Jun 6 14:16:08 mx1 postfix/qmgr[10019]: warning: problem talking to service rewrite: Success
Jun 6 14:16:08 mx1 postfix/master[10016]: warning: process /usr/libexec/postfix/trivial-rewrite pid 10075 exit status 1
Jun 6 14:16:08 mx1 postfix/master[10016]: warning: /usr/libexec/postfix/trivial-rewrite: bad command startup -- throttling

Jun 6 14:17:08 mx1 postfix/proxymap[10062]: warning: connect to mysql server 127.0.0.1: Access denied for user 'ispconfig'@'localhost' to database 'dbispconfig'
Jun 6 14:17:08 mx1 postfix/proxymap[10062]: warning: mysql query failed: Table 'db_ispconfig.mail_domain' doesn't exist
Jun 6 14:17:08 mx1 postfix/trivial-rewrite[10107]: fatal: proxy:mysql:/etc/postfix/mysql-virtual_domains.cf(0,lock|fold_fix): table lookup problem
Jun 6 14:17:09 mx1 postfix/qmgr[10019]: warning: problem talking to service rewrite: Success
Jun 6 14:17:09 mx1 postfix/smtpd[10061]: warning: problem talking to service rewrite: Connection reset by peer
Jun 6 14:17:09 mx1 postfix/master[10016]: warning: process /usr/libexec/postfix/trivial-rewrite pid 10107 exit status 1
Jun 6 14:17:09 mx1 postfix/master[10016]: warning: /usr/libexec/postfix/trivial-rewrite: bad command startup -- throttling

#############################

the problem is there is no "mail_domain" table in db_ispconfig!!!!!!

what you think about this misconfig?
Thankyou,

falko
7th June 2010, 13:35
Did you install ISPConfig 2 or 3? What's in /etc/postfix/main.cf? Which tutorial (URL) did you use to set up the server?

freesqrt
7th June 2010, 13:47
Hey falko,

I'd installed ISpconfig 2. I installed in completely based on "perfect server" manual for fedora 9.

the problem is the ispconfig requests for tables that are not exists for example "mail_transport" !!!!.

the end part of mail.cf is:

##########################
readme_directory = /usr/share/doc/postfix-2.5.6/README_FILES
# Enable IPv4, and IPv6 if supported
inet_protocols = all
myhostname = mx1.eshtehardpnu.ac.ir
mynetworks = 127.0.0.0/8
virtual_alias_domains =
##virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_mailbox_base = /var/vmail
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
smtpd_sasl_auth_enable = yes
broken_sasl_auth_clients = yes
smtpd_sasl_authenticated_header = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination
smtpd_use_tls = yes
smtpd_tls_security_level = may
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
#relay_domains = mysql:/etc/postfix/mysql-virtual_relaydomains.cf
virtual_create_maildirsize = yes
virtual_maildir_extended = yes
virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_limit_maps.cf
virtual_mailbox_limit_override = yes
virtual_maildir_limit_message = "The user you are trying to reach is over quota."
virtual_overquota_bounce = yes
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/mysql-virtual_sender.cf
smtpd_client_restrictions = check_client_access mysql:/etc/postfix/mysql-virtual_client.cf
maildrop_destination_concurrency_limit = 1
maildrop_destination_recipient_limit = 1
virtual_transport = maildrop
header_checks = regexp:/etc/postfix/header_checks
mime_header_checks = regexp:/etc/postfix/mime_header_checks
nested_header_checks = regexp:/etc/postfix/nested_header_checks
body_checks = regexp:/etc/postfix/body_checks
content_filter = amavis:[127.0.0.1]:10024
receive_override_options = no_address_mappings
smtpd_sasl_local_domain =
smtpd_sasl_security_options = noanonymous
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
home_mailbox = Maildir/
mailbox_command =

mydestination = /etc/postfix/local-host-names
relay_domains = $mydestination
virtual_maps = hash:/etc/postfix/virtusertable
#############################

I have remove/install ISPconfig several times but is it usefull to uninstall/ reinstall postfix and ispconfig?

thank you,

falko
8th June 2010, 15:46
Somehow your Postfix is configured for virtual users instead of system users, and this setup is incompatible with ISPConfig 2. Is it possible that you accidently used the "Perfect Server" tutorial for ISPConfig 3 instead 2?

freesqrt
12th June 2010, 10:28
Hey Falko,

thank you very much. the problem had been solved!!!!:D

I have removed ISPconfig and postfix rpm. then install step 12 of the perfect server manual again.

that was because the first time I had installed ISPconfig 3 and then removed it and installed ISPcnfig 2. but the configuration in /etc/postfix/mysql-virtual_* was remained.
I think the ISPconfig does not completely uninstalled by removing /root/ispconfig and /home/admispconfig !!!

Regards,

m4l41k4t
6th July 2012, 06:28
I am having the same problem.
but I have not tried to uninstall / install ISPConfig because of fear of web data that already exist will also be lost (already have 2 web hosting).
Is there any solution other than the Uninstall / Install ISPConfig?

ISPConfig Version: 3.0.4.5
Tutorial :http://www.howtoforge.com/perfect-server-ubuntu-12.04-lts-apache2-bind-dovecot-ispconfig-3-p7
OS Ubuntu : 12.04 32 Bit

The following error contained in the tail-f / var / log / mail.log :
Jul 6 00:22:56 test postfix/error[8944]: warning: mysql:/etc/postfix/mysql-virtual_relaydomains.cf: table lookup problem
Jul 6 00:22:56 test postfix/error[8975]: warning: mysql:/etc/postfix/mysql-virtual_relaydomains.cf: table lookup problem
Jul 6 00:22:56 test postfix/error[8987]: warning: mysql:/etc/postfix/mysql-virtual_relaydomains.cf: table lookup problem
Jul 6 00:22:56 test postfix/error[9131]: 8F01ED0BE0E: to=<goosq@yahoo.com.tw>, relay=none, delay=375916, delays=375584/328/0/4.8, dsn=4.3.0, status=deferred (address resolver failure)
Jul 6 00:22:56 test postfix/error[8971]: 6E5A3D0E5DA: to=<dedee@kimo.com.tw>, relay=none, delay=24857, delays=24580/274/0/3.5, dsn=4.4.2, status=deferred (delivery temporarily suspended: lost connection with 127.0.0.1[127.0.0.1] while sending RCPT TO)
Jul 6 00:22:56 test postfix/error[8920]: 53978D074E3: to=<accoutered@kimo.com.tw>, relay=none, delay=31466, delays=31187/274/0/4.4, dsn=4.4.2, status=deferred (delivery temporarily suspended: lost connection with 127.0.0.1[127.0.0.1] while sending RCPT TO)
Jul 6 00:22:56 test postfix/error[9321]: 83230D0DD36: to=<jing84535@yahoo.com.tw>, relay=none, delay=115462, delays=115129/326/0/6.9, dsn=4.3.0, status=deferred (address resolver failure)
Jul 6 00:22:56 test postfix/error[8961]: 8875DD06313: to=<taping55@yahoo.com.tw>, relay=none, delay=32610, delays=32331/273/0/6, dsn=4.4.2, status=deferred (delivery temporarily suspended: lost connection with 127.0.0.1[127.0.0.1] while sending RCPT TO)
Jul 6 00:22:56 test postfix/error[8961]: warning: mysql:/etc/postfix/mysql-virtual_relaydomains.cf: table lookup problem
Jul 6 00:22:56 test postfix/error[8903]: 62FDBD01E2F: to=<mi70369@yahoo.com.tw>, relay=none, delay=150218, delays=149885/325/0/8.1, dsn=4.3.0, status=deferred (address resolver failure)
Jul 6 00:22:56 test postfix/error[8901]: warning: mysql:/etc/postfix/mysql-virtual_relaydomains.cf: table lookup problem
Jul 6 00:22:56 test postfix/error[8901]: warning: 65E8DD0731B: flush service failure
Jul 6 00:22:56 test postfix/error[8958]: 63E1DD1095C: to=<ath@ms43.hinet.net>, relay=none, delay=1970, delays=1691/273/0/6, dsn=4.4.2, status=deferred (delivery temporarily suspended: lost connection with 127.0.0.1[127.0.0.1] while sending RCPT TO)
Jul 6 00:22:56 test postfix/error[8958]: warning: mysql:/etc/postfix/mysql-virtual_relaydomains.cf: table lookup problem
Jul 6 00:22:56 test postfix/error[8958]: warning: 63E1DD1095C: flush service failure
Jul 6 00:22:56 test postfix/error[9321]: warning: mysql:/etc/postfix/mysql-virtual_relaydomains.cf: table lookup problem
Jul 6 00:22:56 test postfix/error[8903]: warning: mysql:/etc/postfix/mysql-virtual_relaydomains.cf: table lookup problem
Jul 6 00:22:56 test postfix/error[8903]: warning: 62FDBD01E2F: flush service failure
Jul 6 00:22:56 test postfix/error[8993]: 8E75AD07148: to=<cymcym@iplus.net.tw>, relay=none, delay=31791, delays=31513/274/0/3.9, dsn=4.4.2, status=deferred (delivery temporarily suspended: lost connection with 127.0.0.1[127.0.0.1] while sending RCPT TO)
Jul 6 00:22:56 test postfix/error[8939]: warning: mysql:/etc/postfix/mysql-virtual_relaydomains.cf: table lookup problem
Jul 6 00:22:56 test postfix/error[8978]: warning: mysql:/etc/postfix/mysql-virtual_relaydomains.cf: table lookup problem
Jul 6 00:22:56 test postfix/error[8971]: warning: mysql:/etc/postfix/mysql-virtual_relaydomains.cf: table lookup problem
Jul 6 00:22:56 test postfix/error[8969]: warning: mysql:/etc/postfix/mysql-virtual_relaydomains.cf: table lookup problem
Jul 6 00:22:56 test postfix/error[9131]: warning: mysql:/etc/postfix/mysql-virtual_relaydomains.cf: table lookup problem
Jul 6 00:22:56 test postfix/error[8991]: warning: mysql:/etc/postfix/mysql-virtual_relaydomains.cf: table lookup problem
Jul 6 00:22:56 test postfix/error[9321]: warning: 83230D0DD36: flush service failure
Jul 6 00:22:56 test postfix/error[8965]: warning: mysql:/etc/postfix/mysql-virtual_relaydomains.cf: table lookup problem
Jul 6 00:22:56 test postfix/error[8993]: warning: mysql:/etc/postfix/mysql-virtual_relaydomains.cf: table lookup problem
Jul 6 00:22:56 test postfix/error[8975]: warning: BEECDD01C34: flush service failure
Jul 6 00:22:56 test postfix/error[8944]: warning: 6BC4AD01968: flush service failure
Jul 6 00:22:56 test postfix/error[8961]: warning: 8875DD06313: flush service failure
Jul 6 00:22:56 test postfix/error[8978]: warning: B1085D0AAFA: flush service failure
Jul 6 00:22:56 test postfix/error[8939]: warning: 6303DD09AEB: flush service failure
Jul 6 00:22:56 test postfix/error[8920]: warning: mysql:/etc/postfix/mysql-virtual_relaydomains.cf: table lookup problem
Jul 6 00:22:56 test postfix/error[9131]: warning: 8F01ED0BE0E: flush service failure
Jul 6 00:22:56 test postfix/error[8987]: warning: 6E237D0366B: flush service failure
Jul 6 00:22:56 test postfix/error[8971]: warning: 6E5A3D0E5DA: flush service failure
Jul 6 00:22:56 test postfix/error[8991]: warning: 578DCD092CC: flush service failure
Jul 6 00:22:56 test postfix/error[8965]: warning: 623C8D071A8: flush service failure
Jul 6 00:22:56 test postfix/error[8969]: warning: 62735D09B6F: flush service failure
Jul 6 00:22:56 test postfix/error[8993]: warning: 8E75AD07148: flush service failure
Jul 6 00:22:56 test postfix/error[8920]: warning: 53978D074E3: flush service failure
Jul 6 00:22:56 test postfix/smtpd[9113]: warning: connect to mysql server 127.0.0.1: Can't connect to MySQL server on '127.0.0.1' (111)
Jul 6 00:22:56 test postfix/smtpd[9113]: warning: mysql:/etc/postfix/mysql-virtual_client.cf: table lookup problem
Jul 6 00:22:56 test postfix/smtpd[9113]: NOQUEUE: reject: RCPT from unknown[190.33.184.107]: 451 4.3.5 <unknown[190.33.184.107]>: Client host rejected: Server configuration error; from=<dmmpvwlwcgpdm@gmail.com> to=<venus.h1031@msa.hinet.net> proto=SMTP helo=<124.81.213.252>
Jul 6 00:22:56 test postfix/smtpd[9113]: too many errors after RCPT from unknown[190.33.184.107]
Jul 6 00:22:56 test postfix/trivial-rewrite[9182]: warning: proxy:mysql:/etc/postfix/mysql-virtual_domains.cf: table lookup problem
Jul 6 00:22:56 test postfix/smtpd[9113]: disconnect from unknown[190.33.184.107]
Jul 6 00:22:56 test postfix/trivial-rewrite[9182]: warning: virtual_mailbox_domains lookup failure

till
6th July 2012, 09:08
Name resolution is not working correctly on your server or you changed your mysql configuratio so that it does not listen to localhost anymore. Check your /etc/hosts file to ensure that it contains the line:

127.0.0.1 localhost

and ccheck your mysql config to ensure that mysql listens on all interfaces.

m4l41k4t
6th July 2012, 11:02
Not intend to apologize in advance for the double post, but since reading the above problem and the solution re-install ISPConfig. But because I am afraid to reinstall ISPConfignya think could be done with the upgrade version but not as well.

Previously the problem is when I access the ISPConfig web hosting and web access to ISPConfig (https://XXXX:8080) appears an error like this "Warning: mysql_connect (): Too many connections in / usr / local / ISPConfig / interface / lib / classes / db_mysql.inc.php on line 76 Warning: mysql_connect (): Too many connections in / usr / local / ISPConfig / interface / lib / classes / db_mysql.inc.php on line 76 ".

Then in / etc / mysql / my.cnf I add the following line "max_connections = 500" and the above error is not there anymore.
But when I try to test send email can not and appear error like my previous post.


and for your advice before I check should have been:

root@test:~# cat /etc/hosts
127.0.0.1 localhost
113.XXX.XXX.XXX dummy.example.net
124.XXX.XXX.XXX test.dummy.example.net test

# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
root@test:~#


root@test:~# grep bind-address /etc/mysql/my.cnf
#bind-address = 127.0.0.1
root@test:~#

What should I do this again so I can finish the problem?



UPDATED:


now I'm watching is no more error as before.
But when I try to send a test email sent but not entered in the Mail Inbox.

I try to telnet port 25 from the cmd very long response and then drop out:
220 test.dummy.example.net ESMTP (Network)
421 4.4.2 test.dummy.wanxp.net Error: timeout exc

Connection to host lost.

C:\Documents and Settings\Administrator>


and very many activity from mail.log
Jul 6 05:40:36 test postfix/smtpd[13598]: lost connection after CONNECT from unknown[180.211.163.108]
Jul 6 05:40:36 test postfix/smtpd[13598]: disconnect from unknown[180.211.163.108]
Jul 6 05:40:36 test postfix/cleanup[12320]: 11F7ED114EA: message-id=<34094546.698x650812188s>
Jul 6 05:40:37 test postfix/smtpd[13598]: warning: hostname mvx-201-76-189-3.mundivox.com does not resolve to address 201.76.189.3: Name or service not known
Jul 6 05:40:37 test postfix/smtpd[13598]: connect from unknown[201.76.189.3]
Jul 6 05:40:37 test postfix/smtpd[13019]: 0E68FD110D3: client=unknown[83.111.172.202]
Jul 6 05:40:37 test postfix/smtpd[13598]: lost connection after CONNECT from unknown[201.76.189.3]
Jul 6 05:40:37 test postfix/smtpd[13338]: disconnect from unknown[218.93.235.35]
Jul 6 05:40:37 test postfix/smtpd[13338]: connect from unknown[202.69.40.174]
Jul 6 05:40:37 test postfix/smtpd[13338]: lost connection after CONNECT from unknown[202.69.40.174]
Jul 6 05:40:37 test postfix/smtpd[13338]: disconnect from unknown[202.69.40.174]
Jul 6 05:40:37 test postfix/smtpd[13598]: disconnect from unknown[201.76.189.3]
Jul 6 05:40:37 test postfix/smtpd[13338]: connect from unknown[213.230.21.98]
Jul 6 05:40:37 test postfix/smtpd[13598]: connect from ns3.s-dns.de[66.113.136.93]
Jul 6 05:40:37 test postfix/smtpd[13598]: lost connection after CONNECT from ns3.s-dns.de[66.113.136.93]
Jul 6 05:40:37 test postfix/smtpd[13598]: disconnect from ns3.s-dns.de[66.113.136.93]
Jul 6 05:40:37 test postfix/smtpd[13598]: connect from 189-83-29-161.user.veloxzone.com.br[189.83.29.161]
Jul 6 05:40:37 test postfix/smtpd[13598]: lost connection after CONNECT from 189-83-29-161.user.veloxzone.com.br[189.83.29.161]
Jul 6 05:40:37 test postfix/smtpd[13598]: disconnect from 189-83-29-161.user.veloxzone.com.br[189.83.29.161]
Jul 6 05:40:37 test postfix/smtpd[13598]: connect from unknown[213.230.21.98]
Jul 6 05:40:37 test postfix/smtpd[13598]: lost connection after CONNECT from unknown[213.230.21.98]
Jul 6 05:40:37 test postfix/smtpd[13598]: disconnect from unknown[213.230.21.98]
Jul 6 05:40:37 test postfix/smtpd[13598]: connect from unknown[213.230.21.98]
Jul 6 05:40:37 test postfix/smtpd[13598]: lost connection after CONNECT from unknown[213.230.21.98]
Jul 6 05:40:37 test postfix/smtpd[13598]: disconnect from unknown[213.230.21.98]
Jul 6 05:40:37 test postfix/smtpd[13598]: connect from unknown[210.17.221.25]

till
6th July 2012, 11:41
Previously the problem is when I access the ISPConfig web hosting and web access to ISPConfig (https://XXXX:8080) appears an error like this "Warning: mysql_connect (): Too many connections in / usr / local / ISPConfig / interface / lib / classes / db_mysql.inc.php on line 76 Warning: mysql_connect (): Too many connections in / usr / local / ISPConfig / interface / lib / classes / db_mysql.inc.php on line 76 ".

Ok,so your connection Limit is too low:

set:

max_connections = 500
max_user_connections = 500

in postfix my.cnf in the [mysqld] section and restart mysql.

Then check the file /etc/resolv.conf and ansure that all dns servers listed there exist and are reachable from your server.

m4l41k4t
6th July 2012, 12:06
in the file / etc / mysql / my.cnf I have add the following line:
max_connections = 500
max_user_connections = 500

in the file /etc/resolv.conf
nameserver 8.8.8.8
nameserver 8.8.4.4

And after that there is no more error as before.

but after that it now

But when I try to send a test email sent but not entered in the Mail Inbox.

I try to telnet port 25 from the cmd very long response and then drop out:
220 test.dummy.example.net ESMTP (Network)
421 4.4.2 test.dummy.example.net Error: timeout exc

Connection to host lost.

C:\Documents and Settings\Administrator>


and very many activity from mail.log, in tail -f /var/log/mail.log

Jul 6 05:40:36 test postfix/smtpd[13598]: lost connection after CONNECT from unknown[180.211.163.108]
Jul 6 05:40:36 test postfix/smtpd[13598]: disconnect from unknown[180.211.163.108]
Jul 6 05:40:36 test postfix/cleanup[12320]: 11F7ED114EA: message-id=<34094546.698x650812188s>
Jul 6 05:40:37 test postfix/smtpd[13598]: warning: hostname mvx-201-76-189-3.mundivox.com does not resolve to address 201.76.189.3: Name or service not known
Jul 6 05:40:37 test postfix/smtpd[13598]: connect from unknown[201.76.189.3]
Jul 6 05:40:37 test postfix/smtpd[13019]: 0E68FD110D3: client=unknown[83.111.172.202]
Jul 6 05:40:37 test postfix/smtpd[13598]: lost connection after CONNECT from unknown[201.76.189.3]
Jul 6 05:40:37 test postfix/smtpd[13338]: disconnect from unknown[218.93.235.35]
Jul 6 05:40:37 test postfix/smtpd[13338]: connect from unknown[202.69.40.174]
Jul 6 05:40:37 test postfix/smtpd[13338]: lost connection after CONNECT from unknown[202.69.40.174]
Jul 6 05:40:37 test postfix/smtpd[13338]: disconnect from unknown[202.69.40.174]
Jul 6 05:40:37 test postfix/smtpd[13598]: disconnect from unknown[201.76.189.3]
Jul 6 05:40:37 test postfix/smtpd[13338]: connect from unknown[213.230.21.98]
Jul 6 05:40:37 test postfix/smtpd[13598]: connect from ns3.s-dns.de[66.113.136.93]
Jul 6 05:40:37 test postfix/smtpd[13598]: lost connection after CONNECT from ns3.s-dns.de[66.113.136.93]
Jul 6 05:40:37 test postfix/smtpd[13598]: disconnect from ns3.s-dns.de[66.113.136.93]
Jul 6 05:40:37 test postfix/smtpd[13598]: connect from 189-83-29-161.user.veloxzone.com.br[189.83.29.161]
Jul 6 05:40:37 test postfix/smtpd[13598]: lost connection after CONNECT from 189-83-29-161.user.veloxzone.com.br[189.83.29.161]
Jul 6 05:40:37 test postfix/smtpd[13598]: disconnect from 189-83-29-161.user.veloxzone.com.br[189.83.29.161]
Jul 6 05:40:37 test postfix/smtpd[13598]: connect from unknown[213.230.21.98]
Jul 6 05:40:37 test postfix/smtpd[13598]: lost connection after CONNECT from unknown[213.230.21.98]
Jul 6 05:40:37 test postfix/smtpd[13598]: disconnect from unknown[213.230.21.98]
Jul 6 05:40:37 test postfix/smtpd[13598]: connect from unknown[213.230.21.98]
Jul 6 05:40:37 test postfix/smtpd[13598]: lost connection after CONNECT from unknown[213.230.21.98]
Jul 6 05:40:37 test postfix/smtpd[13598]: disconnect from unknown[213.230.21.98]
Jul 6 05:40:37 test postfix/smtpd[13598]: connect from unknown[210.17.221.25]

m4l41k4t
8th July 2012, 03:57
because still not normal I try to test this also apt-get update and apt-get upgrade on my ubuntu machine.
And also because I have seen in the menu "Monitor" like this:

ISPConfig 3.0.4.6
State: info (0 unknown, 0 info, 2 warning, 0 critical, 0 error)
ok:
The state of your Hard-Disk space is ok [More...]
Your Mail queue load is ok [More...]
Your RAID is ok [More...]
Your Server load is ok [More...]
All needed services are online [More...]
The System Log is O.K. [More...]

warning:
Your virus protection is OUTDATED! [More...]
One or more components needs an update [More...]

but when I get to step apt-get upgrade I found a massive this, is this a problem or not?

or should I uninstall / install again to "Postfix, amavisd-new, SpamAssassin, And Clamav" and whether in this way there is a negative-effect with the email that has been previously dicreate?


clamav (0.97.5+dfsg-1) unstable; urgency=medium

This release of clamav no longer ships signature files in clamav-base so
no signatures are available until after freshclam has run and downloaded
them. This is an upstream change.

-- Scott Kitterman <scott@kitterman.com> Fri, 15 Jun 2012 11:39:26 -0400

/tmp/tmpBagrWi (END)

m4l41k4t
8th July 2012, 07:58
Updated:

I have tried to uninstall and install Clamav and has been updated.
I see from mailog (/ var / log / mail.log) is very much like spam email activity within 20 seconds was more than 1121 Kbytes in 204 Requests in the Mail Queue.
Is it because many of these activities that cause I can not send and receive email?
I've tried to delete the Mail Queue with the command "postsuper-d ALL" and deleted but there is always more.
Shortly after I tried to remove and test send / receive email could not be fixed.

And how to reduce the activity of this spam on my server?

Thanks

falko
8th July 2012, 22:44
warning:
Your virus protection is OUTDATED! [More...]
One or more components needs an update [More...]

but when I get to step apt-get upgrade I found a massive this, is this a problem or not?

or should I uninstall / install again to "Postfix, amavisd-new, SpamAssassin, And Clamav" and whether in this way there is a negative-effect with the email that has been previously dicreate?


clamav (0.97.5+dfsg-1) unstable; urgency=medium

This release of clamav no longer ships signature files in clamav-base so
no signatures are available until after freshclam has run and downloaded
them. This is an upstream change.

-- Scott Kitterman <scott@kitterman.com> Fri, 15 Jun 2012 11:39:26 -0400

/tmp/tmpBagrWi (END)
http://www.howtoforge.com/forums/showthread.php?t=51487&highlight=virus+protection+OUTDATED

m4l41k4t
9th July 2012, 04:28
http://www.howtoforge.com/forums/showthread.php?t=51487&highlight=virus+protection+OUTDATED


If it can be said to be normal, but why I still can not send / receive emails where previously there was no problem.

previously I have done this at my ubuntu machine "apt-get-u upgrade" but stop and appear like this: * d / cron.default: change to a deprecated message to make it clear
/ tmp / tmpccxWzC

This is because I still can not send / receive email?

Thanks.

m4l41k4t
10th July 2012, 09:50
The problem can not send / receive e-mail has been Successful and thank you for all the solution.

And one more thing I want to ask: why in this tutorial there is talk about saslauthd (http://www.howtoforge.com/perfect-server-ubuntu-11.10-ispconfig-3-p4) but in this tutorial does not exist (http: / / www.howtoforge.com/perfect-server-ubuntu-12.04-lts-apache2-bind-dovecot-ispconfig-3-p4). Is SMTP auth only be done in ubuntu, 11:10 ISPConfig-3-and-ubuntu-12:04 ISPConfig-3 can not be done?
Because now I'm watching from mail.log so many activities Spam.

falko
11th July 2012, 16:48
And one more thing I want to ask: why in this tutorial there is talk about saslauthd (http://www.howtoforge.com/perfect-server-ubuntu-11.10-ispconfig-3-p4) but in this tutorial does not exist (http: / / www.howtoforge.com/perfect-server-ubuntu-12.04-lts-apache2-bind-dovecot-ispconfig-3-p4). Is SMTP auth only be done in ubuntu, 11:10 ISPConfig-3-and-ubuntu-12:04 ISPConfig-3 can not be done?
Because now I'm watching from mail.log so many activities Spam.
One tutorial uses Courier and saslauthd, the other one uses Dovecot (which is able to handle SMTP-AUTH, so saslauthd is not needed).

m4l41k4t
12th July 2012, 03:43
One tutorial uses Courier and saslauthd, the other one uses Dovecot (which is able to handle SMTP-AUTH, so saslauthd is not needed).


is possible if I want to try "Postfix With SMTP-AUTH" in this tutorial "http://www.howtoforge.com/perfect-server-ubuntu-12.04-lts-apache2-bind-dovecot-ispconfig-3-p4"?
I want to try setting the SMTP-AUTH because so much spam mail activities in mail.log and efect my IP Mailserver blocked by the "spamcop.net, gmail.com (I can not send mail to Gmail with error: address has been blocked. 550 - 5.7.1 Please visit
http://www.google.com/mail/help/bulk_mail.html to review 550 5.7.1 our Bulk
and I also can not send to yahoomail ".

I've tried to follow the tutorial at this link about "Postfix With SMTP-AUTH And TLS" (http://www.howtoforge.com/perfect-server-ubuntu-9.04-ispconfig-2-p5) but it did not work at start fail .

root@test:/tmp# /etc/init.d/saslauthd status
* Checking SASL Authentication Daemon saslauthd [fail]
root@test:/tmp# /etc/init.d/saslauthd restart
* Stopping SASL Authentication Daemon saslauthd [ OK ]
* Starting SASL Authentication Daemon saslauthd /usr/sbin/saslauthd: invalid option -- ':'
usage: saslauthd [options]

option information:
-a <authmech> Selects the authentication mechanism to use.
-c Enable credential caching.
-d Debugging (don't detach from tty, implies -V)
-r Combine the realm with the login before passing to authentication mechanism
Ex. login: "foo" realm: "bar" will get passed as login: "foo@bar"
The realm name is passed untouched.
-O <option> Optional argument to pass to the authentication
mechanism.
-l Disable accept() locking. Increases performance, but
may not be compatible with some operating systems.
-m <path> Alternate path for the saslauthd working directory,
must be absolute.
-n <procs> Number of worker processes to create.
-s <kilobytes> Size of the credential cache (in kilobytes)
-t <seconds> Timeout for items in the credential cache (in seconds)
-v Display version information and available mechs
-V Enable verbose logging
-h Display this message.

saslauthd 2.1.25
authentication mechanisms: sasldb getpwent kerberos5 pam rimap shadow ldap

[ OK ]
root@test:/tmp#

Thanks