PDA

View Full Version : BIND-Server: Offline


severnet
8th November 2009, 18:58
I've installed ISPConfig 2.2.34 on the Perfect Server Fedora 11, but after that BIND-Server is not working. Here are screenshots and log run:

http://img682.imageshack.us/img682/3848/services.png

http://img130.imageshack.us/img130/6929/settings.png

# service named status
rndc: connect failed: 127.0.0.1#953: connection refused
named is stopped

# service named start
Starting named:
Error in named configuration:
zone localhost.localdomain/IN: loading from master file named.localhost failed: file not found
_default/localhost.localdomain/IN: file not found
zone localhost/IN: loading from master file named.localhost failed: file not found
_default/localhost/IN: file not found
zone 1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0. 0.0.0.0.0.0.0.ip6.arpa/IN: loading from master file named.loopback failed: file not found
_default/1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0. 0.0.0.0.0.0.0.ip6.arpa/IN: file not found
zone 1.0.0.127.in-addr.arpa/IN: loading from master file named.loopback failed: file not found
_default/1.0.0.127.in-addr.arpa/IN: file not found
zone 0.in-addr.arpa/IN: loading from master file named.empty failed: file not found
_default/0.in-addr.arpa/IN: file not found
[FAILED]

Can you tell how to solve this problem?

falko
9th November 2009, 14:15
What's in your named.conf?

falko
10th November 2009, 18:30
I'm not sure if this is the correct one. What's the output of updatedb
locate named.conf?

TheBirdMan
18th January 2010, 03:53
Hi Falco,

I'm getting the same error after the "perfect install fedora 12" before beginning ispconfig 2 install. bind-chroot was installed durring the pre-ispconfig, Did I miss something?

named.conf
//
// Provided by Red Hat bind package to configure the ISC BIND named(8) DNS
// server as a caching only nameserver (as a localhost DNS resolver only).
//
// See /usr/share/doc/bind*/sample/ for example named configuration files.
//

options {
listen-on port 53 { 127.0.0.1; };
listen-on-v6 port 53 { ::1; };
directory "/var/named";
dump-file "/var/named/data/cache_dump.db";
statistics-file "/var/named/data/named_stats.txt";
memstatistics-file "/var/named/data/named_mem_stats.txt";
allow-query { localhost; };
recursion yes;
dnssec-enable yes;
dnssec-validation yes;
dnssec-lookaside . trust-anchor dlv.isc.org.;
};

logging {
channel default_debug {
file "data/named.run";
severity dynamic;
};
};

zone "." IN {
type hint;
file "named.ca";
};

include "/etc/named.rfc1912.zones";

include "/etc/pki/dnssec-keys//named.dnssec.keys";
include "/etc/pki/dnssec-keys//dlv/dlv.isc.org.conf";

TheBirdMan
18th January 2010, 05:14
Hi,

I disabled ROOTDIR="/var/named/chroot" in /etc/sysconfig/named and everything is working. There are not any DNS records under chroot, Should we just copy them or am I missing the bigger picture?

Is chroot-bind necessary? this server will need strong security on the internet but won't have many users.

Thanks,

Scott

happz
23rd January 2010, 17:05
Hello guys,

I too have this exact problem which tells me that this could be widespread. Can someone research this and if found that the steps in the perfect server setup need to be adjust that is get fixed? Also, when I commented out the same line BIND turned on but I need to know what the next step to take.

Regards,
hAppz