PDA

View Full Version : imap client parameter?


ablc
27th August 2005, 19:33
All seems working well except thunderbird / outlook can't fetch any mails.

The mails are receive correctly (.../web7/user/web7_xxx/Maildir/new )
but none of the clients are able to see this folder .

I guess the solution is obvious but i can't see it :o

thx

i just found that:

incoming mail are under:
/var/www/web8/user/web8_ablc/Maildir/new
but
all the clients go to:
/var/www/web8/Mail/Maildir/
:confused:
What's wrong ???

till
27th August 2005, 20:49
All seems working well except thunderbird / outlook can't fetch any mails.

The mails are receive correctly (.../web7/user/web7_xxx/Maildir/new )
but none of the clients are able to see this folder .

I guess the solution is obvious but i can't see it :o

thx

i just found that:

incoming mail are under:
/var/www/web8/user/web8_ablc/Maildir/new
but
all the clients go to:
/var/www/web8/Mail/Maildir/
:confused:
What's wrong ???

All clients go to: /var/www/web8/Mail/Maildir/ or this particular client. If the Client is the admin of the web, the location is correct.

Are you shure your IMAP / POP3 daemons support Maildir? Try to set Maildelivery in ISPConfig to Mailbox, send a mail to an account and then check in your mailclient if you can fetch the mail from this account.

ablc
27th August 2005, 21:10
according your reply, the emails for the admin goes to the good directory Mail/Maildir and the "normal user" goes to the good directory.

I can see all the mail under these directories but no email clients can retrieve them

till
27th August 2005, 21:14
according your reply, the emails for the admin goes to the good directory Mail/Maildir and the "normal user" goes to the good directory.

I can see all the mail under these directories but no email clients can retrieve them

All Email goes to $HOME/Maildir

Have you tried this?

Are you shure your IMAP / POP3 daemons support Maildir? Try to set Maildelivery in ISPConfig to Mailbox, send a mail to an account and then check in your mailclient if you can fetch the mail from this account.

ablc
27th August 2005, 21:32
where should i found the mbox ?

the mail is delivered according the log but no client can find it

till
27th August 2005, 22:27
where should i found the mbox ?

/var/spool/mail (in most cases)

the mail is delivered according the log but no client can find it

Yes, and that is caused in most cases by the wrong mbox/maildir setting.

To activate the mbox, go to Management > Server > Settungs in the controlpanel and activate it on the mail tab.

ablc
27th August 2005, 22:30
maildir is unchecked

till
27th August 2005, 22:34
maildir is unchecked

Have you setup your system accordingly to one of the howtos? It seems that mail is not handled at all by the procmail scripts delivered with ispconfig because when mail is unchecked it is impossible to get emails in the maildirs.

ablc
27th August 2005, 22:39
yep, I followed the "perfect mandriva" one.

I checked both /var/spool/mail and ~/Maildir and no mail at all !
it seems vanished somewhere else !

But If i checked Maildir, i found the mail in the maildir directory.

I really don't understand why no clients are able to seek them !

till
27th August 2005, 22:46
yep, I followed the "perfect mandriva" one.

I checked both /var/spool/mail and ~/Maildir and no mail at all !
it seems vanished somewhere else !

But If i checked Maildir, i found the mail in the maildir directory.

I really don't understand why no clients are able to seek them !

Please set maildelivery to mbox, wait 1 minute, then send a mail to an account you created on your server. Then try to fetch the mail with pop3. Post the output from your maillog here. and check also your syslog for errors.

ablc
27th August 2005, 22:58
here is the result:

nothing under /var/spool/mail

Aug 27 21:53:15 vador postfix/pickup[6863]: 044BCEE283: uid=0 from=<root>
Aug 27 21:53:15 vador postfix/cleanup[7648]: 044BCEE283: message-id=<20050827195314.044BCEE283@mail.lccnet.net>
Aug 27 21:53:15 vador postfix/qmgr[6864]: 044BCEE283: from=<root@mail.lccnet.net>, size=328, nrcpt=1 (queue active)
Aug 27 21:53:15 vador postfix/pickup[6863]: 2A856EE284: uid=10008 from=<web8_ablc>
Aug 27 21:53:15 vador postfix/cleanup[7648]: 2A856EE284: message-id=<20050827195315.2A856EE284@mail.lccnet.net>
Aug 27 21:53:15 vador postfix/local[7650]: 044BCEE283: to=<web8_ablc@mail.lccnet.net>, orig_to=<ablc@lccnet.net>, relay=local, delay=1, status=sent (delivered to command: /usr/bin/procmail -f-)
Aug 27 21:53:15 vador postfix/qmgr[6864]: 044BCEE283: removed
Aug 27 21:53:15 vador postfix/qmgr[6864]: 2A856EE284: from=<web8_ablc@mail.lccnet.net>, size=356, nrcpt=1 (queue active)
Aug 27 21:53:15 vador postfix/local[7650]: 2A856EE284: to=<admispconfig@localhost.lccnet.net>, orig_to=<admispconfig@localhost>, relay=local, delay=0, status=sent (delivered to command: /usr/bin/procmail -f-)
Aug 27 21:53:15 vador postfix/qmgr[6864]: 2A856EE284: removed
Aug 27 21:54:56 vador imapd[7767]: imap service init from 192.168.0.254
Aug 27 21:54:56 vador imapd[7767]: Authenticated user=web8_ablc host=router.lccnet.net [192.168.0.254]
Aug 27 21:54:57 vador imapd[7768]: imap service init from 192.168.0.254
Aug 27 21:54:57 vador imapd[7768]: Authenticated user=web8_ablc host=router.lccnet.net [192.168.0.254]
Aug 27 21:55:00 vador CROND[7770]: (mail) CMD (/usr/bin/python -S /usr/lib/mailman/cron/gate_news)
Aug 27 21:55:08 vador imapd[7768]: Logout user=web8_ablc host=router.lccnet.net [192.168.0.254]
Aug 27 21:55:08 vador imapd[7767]: Logout user=web8_ablc host=router.lccnet.net [192.168.0.254]
Aug 27 21:56:03 vador ipop3d[7786]: pop3 service init from 192.168.0.254
Aug 27 21:56:07 vador ipop3d[7786]: Auth user=web8_ablc host=router.lccnet.net [192.168.0.254] nmsgs=0/0
Aug 27 21:56:07 vador ipop3d[7786]: Logout user=web8_ablc host=router.lccnet.net [192.168.0.254] nmsgs=0 ndele=0

ablc
28th August 2005, 11:53
It was a quota problem that canceled the mbox delivery.

But imap still not workin :( from the client pov.

lc

till
28th August 2005, 12:00
It was a quota problem that canceled the mbox delivery.

But imap still not workin :( from the client pov.

lc

You mean POP3 works now and IMAP fails?

ablc
28th August 2005, 12:02
yes and still nothing relevent in the logs...

imapd doesn't seems very verbose !

till
28th August 2005, 12:07
yes and still nothing relevent in the logs...

imapd doesn't seems very verbose !

Did you know which imap daemon is installed? Cyrus, courier, UW-Imap ...?

ablc
28th August 2005, 12:12
it's the one provided with mandriva, the Bekerley one I think.

It's the one coming with Falco's tuts.

OK [CAPABILITY IMAP4REV1 LITERAL+ SASL-IR LOGIN-REFERRALS AUTH=LOGIN] vador.lccnet.net IMAP4rev1 2004.357mdk at Sun, 28 Aug 2005 11:09:41 +0200 (CEST)

The Imapd provided with the howto doesn't support Maildir according the imapd faq !!!

ablc
28th August 2005, 13:38
:)
all works now. Some hint:

If your logs said you receive emails and you can't find them, have a look at your quotas, it could help!

lc

till
28th August 2005, 20:19
it's the one provided with mandriva, the Bekerley one I think.

It's the one coming with Falco's tuts.

OK [CAPABILITY IMAP4REV1 LITERAL+ SASL-IR LOGIN-REFERRALS AUTH=LOGIN] vador.lccnet.net IMAP4rev1 2004.357mdk at Sun, 28 Aug 2005 11:09:41 +0200 (CEST)

The Imapd provided with the howto doesn't support Maildir according the imapd faq !!!

Fine that it is solved now :) The default of ISPConfig is MBox, so ISPConfig would have worked out of the box if there where not the quota issues you had.