PDA

View Full Version : LAMP - No Package Available (for php/mysql)


TechN9Ne1730
23rd September 2009, 18:39
I am running CentOS 5.3 on a VPS. It is using the centos kernel and not openvz or anything like that. I have set up a LAMP server before on CentOS 5.3 using an openvz kernel so this is not my first LAMP install. However I am stumped now. I have installed RPMForge before and installed it now.

So now I try to run yum like so:
yum install httpd php php-mysql php-gd php-mbstring php-mcrypt mysql mysql-server phpmyadmin
however it says no package available except for htppd/apache which it says are already installed.

Does it sound like i missed something when doing RPMForge?

falko
24th September 2009, 14:49
Is the RPMforge repository present and enabled in the /etc/yum.repos.d/ directory?

TechN9Ne1730
24th September 2009, 14:56
Yes it is, but looks like i forgot to set a priority for it. Does that matter?

After talking with my host they said the packaged were installed already. This baffles me as every linux distro i have ever seen usually says the pacage is installed and up to date. Furthermore I even tried to remove MySQL using yum, which i did, and webmin no longer recognized mysql, but yet it still told me the same thing as above when I tried "yum install mysql mysql-server."

falko
25th September 2009, 13:10
Can you check if enabled is set to 1 in all the repository files in /etc/yum.repos.d/?

TechN9Ne1730
25th September 2009, 15:21
My centos-base.repo looks exactly like the one here:
http://wiki.centos.org/PackageManagement/Yum/Priorities
Except for
gpgkey=http://mirror.centos.org/centos/RPM-GPG-KEY-centos4
which is of course
gpgkey=http://mirror.centos.org/centos/RPM-GPG-KEY-centos5
for my set up. Have enabled the ones that have enable next to them in that file. The RPMForge repo is set to enabled=1. kbsingh-CentOS-Extras.repo and CentOS-Media.repo are all set to enabled=1.

Now i ran yum update and gets:
root@server101 [/etc/yum.repos.d]# yum update
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
* rpmforge: apt.sw.be
* base: centosj3.centos.org
* updates: centosh.centos.org
* c5-media:
* contrib: mirror.nsc.liu.se
* centosplus: centosb2.centos.org
* addons: centosj-msync-dvd.centos.org
* extras: centosh2.centos.org
file:///media/CentOS/repodata/repomd.xml: [Errno 5] OSError: [Errno 2] No such file or directory: '/media/CentOS/repodata/repomd.xml'
Trying other mirror.
file:///media/cdrecorder/repodata/repomd.xml: [Errno 5] OSError: [Errno 2] No such file or directory: '/media/cdrecorder/repodata/repomd.xml'
Trying other mirror.
file:///media/cdrom/repodata/repomd.xml: [Errno 5] OSError: [Errno 2] No such file or directory: '/media/cdrom/repodata/repomd.xml'
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: c5-media. Please verify its path and try again

which has never happened before.

TechN9Ne1730
25th September 2009, 20:23
CentOS-Base.repo looked just like this:
http://wiki.centos.org/PackageManagement/Yum/Priorities
I set enabled to 1 on [centosplus] and [contrab].

In kbsingh-CentOS-Extras.repo [kbs-CentOS-Extras] is enabled. [kbs-CentOS-Extras] is not(Enabled=0)

CentOS-Media.repo enabled=0 but i changed it to 1.

rpmforge.repo enabled=1

Since making the changes i know get:
Loaded plugins: fastestmirror, priorities
Determining fastest mirrors
* rpmforge: apt.sw.be
* base: centosj3.centos.org
* updates: centosj-msync-dvd.centos.org
* c5-media:
* contrib: mirror.nsc.liu.se
* centosplus: centosb2.centos.org
* addons: centosj-msync-dvd.centos.org
* extras: centosh2.centos.org
kbs-CentOS-Extras | 951 B 00:00
primary.xml.gz | 157 B 00:00
rpmforge | 1.1 kB 00:00
primary.xml.gz | 3.5 MB 00:01
rpmforge 9603/9603
base | 1.1 kB 00:00
primary.xml.gz | 878 kB 00:00
base 2508/2508
updates | 951 B 00:00
primary.xml.gz | 353 kB 00:00
updates 528/528
file:///media/CentOS/repodata/repomd.xml: [Errno 5] OSError: [Errno 2] No such file or directory: '/media/CentOS/repodata/repomd.xml'
Trying other mirror.
file:///media/cdrecorder/repodata/repomd.xml: [Errno 5] OSError: [Errno 2] No such file or directory: '/media/cdrecorder/repodata/repomd.xml'
Trying other mirror.
file:///media/cdrom/repodata/repomd.xml: [Errno 5] OSError: [Errno 2] No such file or directory: '/media/cdrom/repodata/repomd.xml'
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: c5-media. Please verify its path and try again

TechN9Ne1730
25th September 2009, 20:43
root@server [/]# grep exclude /etc/yum.conf
exclude=apache* bind-chroot courier* dovecot* exim* httpd* mod_ssl* mysql* nsd* perl* php* proftpd* pure-ftpd* ruby* spamassassin* squirrelmail*

That could be a problem :p

falko
26th September 2009, 15:05
To me it looks as if yum is trying to get the packages from the CentOS CDs/DVD...