PDA

View Full Version : FTP very slow in LAN, "fast" from WAN-> Firewall problem?


Pasco
22nd August 2005, 14:56
Hi 2gether,

I have a strange problem with FTP. If I access my (ISPConfig)Server from outside, that means from the WAN, it runs normaly (I guess this is normal speed at least...Even though it could be much faster..). But if I access it via LAN it's veeery very slow. It must be some network/firewall issue.

Has anyone any clue?

BTW: my ISPConfig-Server is in the DMZ and therefore my LAN client is in a different subnet..but there should be no restrictions vom the LAN->DMZ from the firewall. I have disabled the ISPConfig firewall too.

So I don't know where's the problem actually..

Any help would be greatly appreciated, thx in advance,
P@sco

till
22nd August 2005, 14:58
Hi 2gether,

I have a strange problem with FTP. If I access my (ISPConfig)Server from outside, that means from the WAN, it runs normaly (I guess this is normal speed at least...Even though it could be much faster..). But if I access it via LAN it's veeery very slow. It must be some network/firewall issue.

Has anyone any clue?

BTW: my ISPConfig-Server is in the DMZ and therefore my LAN client is in a different subnet..but there should be no restrictions vom the LAN->DMZ from the firewall. I have disabled the ISPConfig firewall too.

So I don't know where's the problem actually..

Any help would be greatly appreciated, thx in advance,
P@sco


Have you disabled DNS-Lookups in your proftpd.conf?

Pasco
22nd August 2005, 19:46
No not yet :) But I'll do now so..

Pasco
22nd August 2005, 20:53
Oh, I've already had disabled DNS look-ups actually...so do you have any other ideas? ;-)

falko
22nd August 2005, 22:03
Oh, I've already had disabled DNS look-ups actually...so do you have any other ideas? ;-)

Have you tried to use "Passive Transfers" in your FTP client? Normally that helps. :)

Pasco
22nd August 2005, 23:13
Nice info, thanks :D . No it's a looot faster! So it's some kind of firewall issue, I think...

I have about 4-5 MB/s on my 100 Mbit/s Network (LAN) now...I think that's normal...

(I've read some trick somewhere to bring it near to the "theory" of 100 MBit/s or 12.5 MBytes/s, but that's a long time ago, don't know the link anymore. It depends also on the nic, duplex-mode etc. I guess)

Thx so much, the main problem is solved! ;-)

GrZ, p@sco

HoUsECAt
7th March 2006, 16:17
a little off topic... but on my LAN at home i get around 10mbyte/s .... but it depends on your type router, configuration of servers and cable length ;)