PDA

View Full Version : Installation problem: PHP problem?


hgoor
21st August 2005, 19:32
I followed this http://www.falkotimme.com/howtos/perfect_setup_suse9_3/ setup thinghy to the letter, but I still ran into a problem installing ISPconfig.

It runs all the way but its stops with this message:

checking lex output file root... ./configure: line 2422: lex: command not found
configure: error: cannot find output from lex; giving up
ERROR: Could not configure PHP

What is going wrong and how do I fix it?

Especially since I did a clean install of SUSE following that perfect setup tutorial...

till
21st August 2005, 19:38
I followed this http://www.falkotimme.com/howtos/perfect_setup_suse9_3/ setup thinghy to the letter, but I still ran into a problem installing ISPconfig.

It runs all the way but its stops with this message:

checking lex output file root... ./configure: line 2422: lex: command not found
configure: error: cannot find output from lex; giving up
ERROR: Could not configure PHP

What is going wrong and how do I fix it?

Especially since I did a clean install of SUSE following that perfect setup tutorial...

The program "lex" is missing to compile PHP. Install lex from your SuSE 9.3 installation media to fix this.

hgoor
21st August 2005, 20:55
The program "lex" is missing to compile PHP. Install lex from your SuSE 9.3 installation media to fix this.

Ah! Thanks for the tip. So I guess when you follow the install instructions from that website it's not complete? Obviously when you do a out-of-the box install of suse like the page tells you to do, SuSE does not default install this Lex?

I will let you know if this fixes the problem!

Thanks again!

hgoor
21st August 2005, 21:14
The program "lex" is missing to compile PHP. Install lex from your SuSE 9.3 installation media to fix this.

Uhm, I have a small problem: when I search the packages from within yast, there is no program 'lex'

What is the full name if any? :confused:

falko
21st August 2005, 21:50
Uhm, I have a small problem: when I search the packages from within yast, there is no program 'lex'

What is the full name if any? :confused:

The name is flex, and in the tutorial there's this line:
apt-get install findutils ncftp readline libgcc glibc-devel findutils-locate gcc flex lynx :D

hgoor
21st August 2005, 22:09
The name is flex, and in the tutorial there's this line:
apt-get install findutils ncftp readline libgcc glibc-devel findutils-locate gcc flex lynx :D

OMG :eek: I now see what I did wrong! I just reviewed my history and see that I did copy & paste the whole line into konsole but missed the X in flex! That's why it wasn't installed :mad:

I'll let you know if this works!

ps: wouldn't it be possible to to write some script that does the whole thingy you describe in your otherwise perfect how-to?

PPS: I copy & pasted that line into a root konsole, and now I got this message:

*** WARNING ***
Found /etc/postfix/main.cf.SuSEconfig, exiting...
*** WARNING ***

do I need to worry about that? It did seem to have finished the rest though...

falko
21st August 2005, 22:34
PPS: I copy & pasted that line into a root konsole, and now I got this message:

*** WARNING ***
Found /etc/postfix/main.cf.SuSEconfig, exiting...
*** WARNING ***

do I need to worry about that? It did seem to have finished the rest though...

No, nothing to worry about. :)

hgoor
21st August 2005, 23:15
No, nothing to worry about. :)

Hey tanks m8! I got it up and running :D

I still have a lot to learn here I see. I better print & read the manuals!