PDA

View Full Version : trouble with wordpress and suPhp


Ovidiu
2nd May 2009, 15:48
wordpress has placed this .htaccess inside my web folder and needs it:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress


seems ok to me, at least it ran with ispcfg2
now I get an 500 server error and the log file says:

.htaccess: RewriteEngine not allowed here

can't find much on this with google, I checked and the rewrite module is loaded with apache2.
I tried adding this directive within the ispcfg3 administration ot this certain website but it didn't help:

<Directory "/var/www/clients/client1/web2/">
Options All
AllowOverride All
Order allow,deny
Allow from all
</Directory>

Ovidiu
2nd May 2009, 15:59
k, solved that. my syntax was a little wrong, this fixed it:

<Directory /var/www/clients/client1/web2/web>
Options All
AllowOverride All
Order allow,deny
Allow from all
</Directory>

now I get another 500 error and the log says:

SoftException in Application.cpp:245: File "/var/www/clients/client1/web2/web/index.php" is writeable by group

chmod -R 755 web/ helped here

Ovidiu
2nd May 2009, 16:56
ok, seems I got it to run. how can I check if it is indeed running on suPhp?

###edit###
answered my own question, top says:

6621 web2 20 0 482m 62m 11m R 3 1.6 0:01.42 web2 php-cgi

Ovidiu
2nd May 2009, 17:46
ahhh! another problem!

all of a sudden the site doesn't work anymore, I go back and find the default index.html that I deleted is back, thus preventing my index.php from working, then I get a 404 error and notice my .htacess file has been overwritten by an empty default one?

is ispcfg restoring itsself? how could I prevent this?