PDA

View Full Version : ISPConfig 3 and .html files


reason8
2nd May 2009, 12:58
Does ISPConfig 3 handle .html files differently than ISPConfig 2? I am trying to load a default page of index.html and it is not working. Its giving me an error of:

Forbidden

You don't have permission to access /index.html on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2.2.10 (Linux/SUSE) Server at amsico.com Port 80

I have added index.html to the /etc/apache2/httpd.conf, run SuSeconfig and restarted apache with no success. I've even renamed the file index.htm and tried to reload the page and it gives me the same error even though there is no index.html file.

Thanks!

till
2nd May 2009, 21:38
ISPconfig handles html files correctly of course, there must a misconfiguration on the server. Please take a look at the error log of the website for a detailed error message.

reason8
2nd May 2009, 22:00
ISPconfig handles html files correctly of course, there must a misconfiguration on the server. Please take a look at the error log of the website for a detailed error message.

I see no errors. What exactly am I looking for?

I deleted everything in the folder and updated an .htm file and now I get the error:

Forbidden

You don't have permission to access / on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2.2.10 (Linux/SUSE) Server at kernbits.com Port 80

I do get the following after restarting apache2:

/etc/init.d/apache2 restart
[Sat May 02 12:59:29 2009] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
Syntax OK
Shutting down httpd2 (waiting for all children to terminate) done
Starting httpd2 (prefork) [Sat May 02 12:59:31 2009] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
done

What is this virtualhost overlap on port 80?

reason8
3rd May 2009, 05:36
Ok. I figured it out. The files in the /web folder by default do not allow permissions to the public to view. I had to set public permissions to READ for either the individual file OR apply those permissions to the folder itself and select include contest for either ALL folders (in the /web dir) or ALL files.

This brings me to a another question: Should the /web folder (and all of its contents) be set to READ and/or EXECUTE by the public? There are other folder in the directory by default such as STATS and ERRORS. Should these be set to public READ and/or EXECUTE?

I didnt have to do this in ISPC2 but maybe this is a security feature in version 3.

Thanks!

till
3rd May 2009, 10:37
The default pertmissions that ispconfig sets for the directories should be fine. They work for me on all supported linux distributions. If you changed them manually just set them back to the defaults (chmod 755).

reason8
3rd May 2009, 22:18
The default pertmissions that ispconfig sets for the directories should be fine. They work for me on all supported linux distributions. If you changed them manually just set them back to the defaults (chmod 755).

Well they didnt work for me in version 3. The default index.html file will display but when I copy my index.html file over it will not. It tells me either I do not have permissions to "/" or to "/index.html". Setting the permission on the index.html for public allows me to view it.

reason8
4th May 2009, 01:38
Update:
It looks like initially I have to set public permissions on the folder for any NEW files and folders that I ftp over to the /web folder. Is this normal? I never had this issue with version 2 but like I said before, maybe it is a upgrade in functionality for security reasons. My only concern is that users will have to do this also.

till
4th May 2009, 08:04
Yes, thats normal and it is the same then in ISPConfig 2. Take a look at the permissions of your files in ispconfig 2, they have to be world readable as apache will not be able to read them otherwise. Looks as if you upload your files with the wrong chmod settings.

reason8
4th May 2009, 08:19
Yes, thats normal and it is the same then in ISPConfig 2. Take a look at the permissions of your files in ispconfig 2, they have to be world readable as apache will not be able to read them otherwise. Looks as if you upload your files with the wrong chmod settings.

I did have this problem with persmissions in version 2 and I have already uninstalled it but I will take your word for it :p

reason8
4th May 2009, 13:57
When you said that I uploaded the files with the wrong chmod permissions, were you implying with ISPConfig 2 or ISPConfig 3? As I said before 2 uploaded with no problems using FireFTP for mozilla firefox. Using the same FTP client and ISPConfig 3, its a different story.

myglobaldata
5th May 2009, 03:55
1.I just finalized a Ispconfig 3 install and am testing. I have this same problem and can assure you that it does not happen in Ispconfig 2. When I ftp a file into a site, it does not overwrite properly, it creates a second version of the file, like index.html.1 and leaves index.html in there. Then if I delete the original and upload, it gives a permissions error.

2. once this error starts, it not only effects the site that I was working on but it causes the same error for all the websites??????? CHMOD 755 fixes it but this is surely an error or bug of some kind.

My install is on SUSE11.1 and the install went smoothly.

Please someone give me an idea

reason8
5th May 2009, 04:15
1.I just finalized a Ispconfig 3 install and am testing. I have this same problem and can assure you that it does not happen in Ispconfig 2. When I ftp a file into a site, it does not overwrite properly, it creates a second version of the file, like index.html.1 and leaves index.html in there. Then if I delete the original and upload, it gives a permissions error.

2. once this error starts, it not only effects the site that I was working on but it causes the same error for all the websites??????? CHMOD 755 fixes it but this is surely an error or bug of some kind.

My install is on SUSE11.1 and the install went smoothly.

Please someone give me an idea

Very same problem here on both accounts. On ISPC2, I could FTP a file over to the /web folder and the FTP program would ask me if I wanted to overwrite, I would indicate yes and it would indeed overwrite the file (not in ISPC3. The original file remains and the new file is incremented with a filename.html.#) I have found that I must delete the file first and then ftp files over.

I dont know if it is an error or a bug but from what till is saying, the permissions behavior is the same for ISPC2 (which I did not experience) Maybe it's just on opensuse problem/bug?

till
5th May 2009, 14:36
Take a look into the pure-ftpd configuration file on your server to see if there is any setting set to not overwrite files by default. Same for upload permissions.

reason8
5th May 2009, 20:09
Take a look into the pure-ftpd configuration file on your server to see if there is any setting set to not overwrite files by default. Same for upload permissions.

Autorename is: On
Umask is: 177:077
But usmask doesnt make since because default permissions for ISPC3 are not set to this. I believe they are set to 700

myglobaldata
7th May 2009, 04:45
Thanks for your help! I made these changes to the pure-ftpd.conf file:


Umask 133:022


AutoRename no

and now it works great.

I do have one comment. For some strange reason, when I had the apache error caused by the file permission problem, it cause all the vhosts to stop working, even the default ip. Why would this happen and if its normal, I might be hesitant to give any customer shell access because they could chmod a file improperly and kill all the sites on this box????

Any ideas?

reason8
10th September 2009, 13:57
Hello and good morning. I recently upgraded to ISPConfig 3.0.1.4 and I noticed that the pure-ftp settings indicated here are reset back to default. I do not know if this is a concern or simply a inconvenience which must be adjusted after a update but I wanted to give my input.

Thanks!

abdi
9th November 2012, 12:54
ISPconfig handles html files correctly of course, there must a misconfiguration on the server. Please take a look at the error log of the website for a detailed error message.

Till, is it possible to set the default page (http://www.faqforge.com/linux/controlpanels/ispconfig3/ispconfig-3-where-are-the-templates-for-the-config-files-and-default-pages/) [in /usr/local/ispconfig/server/conf/] from index.html to index.php ?

I would really love to have an index.php for some other dynamic reason.

Thanks, Joseph

till
9th November 2012, 13:14
You would have to chnage the code of the apache plugin if you want to use a index.php file as default ispconfig index file.