PDA

View Full Version : Invalid user at installation


zillac
2nd May 2009, 12:36
I followed the guide (http://www.howtoforge.com/perfect-server-centos-5.2-ispconfig-3) of installing ispconfig3 for CentOS 5.2 on CentOS 5.3,
and got following error:


chown: `ispconfig:ispconfig': invalid user
chown: `getmail': invalid user


and


httpd: bad user name ispconfig
Starting httpd: [FAILED]


What should I do from this point?

Thanks in advance.

till
2nd May 2009, 21:37
Redo the setup. It seems as if you have getmail not installed and / or that you did not run the ispconfig setup as root user.

zillac
2nd May 2009, 21:45
You're right. I figured it out after posting : )
I actually updated the title to say [solved] but some how it isn't reflected in the forum.

sylcor
15th August 2009, 02:58
Forgive my english please.
I just installed the perfect-server-centos-5.3-x86_64-ispconfig-3 from scratch ( about 4 times in 2 days) . Everything is working flawlessly all the way trough...except at the end when it's time to install ispconfig. Just before that i tried with success http://myserverip/webmail OK, http://myserverip/phpmyadmin OK. So i was good.
When i install ispconfig i've got all the 4 times the same message: chown: `ispconfig:ispconfig': usager invalide chown: `getmail': usager invalide . HTTPD wont start.
I swear i follow all the procedure line by line, and i'm sure i have getmail installed.
So i join in the my ispconfig output configuration in hope that someone can help me. I will love to use ispconfig :)

Thanks again.

zillac
15th August 2009, 03:33
sometimes sudo -s does not work. I first thought sudo would be enough, but it turns out that I'm wrong.
I still do not know the reason, but some commands are missing when in sudo -s.

so, try running the install script under root user, that should fix the issue.

sylcor
18th August 2009, 15:29
Hi :)
I logged in as root user
1. drop database dbispconfig in mysql
2. run the php -q install.php script...same thing

Do i need to re-run all the installation process with the root user ?

Thank you!

till
18th August 2009, 15:31
1) Login as root user. You can not use sudo for installation as it will loose its priveliges during install.
2) uninstall ispconfig with the uninstall.php script.
3) Install it again with install.php script.

sylcor
18th August 2009, 16:05
Thanks i understand fast but you have to explain me a long time lol

Working at last :)

rylangrant
1st February 2010, 11:05
Hi, I've logged in as root and when I tried to run the install i get the same error:
chown: `ispconfig:ispconfig': invalid user
chown: `getmail': invalid user
...
Stopping httpd: [FAILED]
httpd: bad user name ispconfig
Starting httpd: [FAILED]

I've checked and made sure that I have getmail installed and I have tried to uninstall / reinstall. Previously I also had an issue getting pure-ftpd to work (wouldnt start when installed with yum but seems to be ok when i installed the rpm).

I also noticed that above this during the Configuring Apache section i get:

Configuring Apache
PHP Warning: Invalid argument supplied for foreach() in /tmp/ispconfig3_install /install/dist/lib/fedora.lib.php on line 436

I opened up the fedora.lib.php file to that line and i see the following section, with the foreach part being the line with the error:

// copy('tpl/apache_ispconfig.conf.master',$vhost_conf_dir.'/ispconfig.conf');
$content = rf("tpl/apache_ispconfig.conf.master");
$records = $this->db->queryAllRecords("SELECT * FROM server_ip WHERE server_id = ".$c$
if(count($records) > 0) {
foreach($records as $rec) {
$content .= "NameVirtualHost ".$rec["ip_address"].":80\n";
$content .= "NameVirtualHost ".$rec["ip_address"].":443\n";
}
}


Any suggestsions on what might be wrong or where to look? I'm running CentOS 5.4

Thanks!

falko
2nd February 2010, 15:08
What's the output of getenforce?

azorman
4th March 2010, 03:39
greetings falko !

I was also getting these messages when running install.php
chown: `ispconfig:ispconfig': invalid user
chown: `getmail': invalid user

All I had to do to fix it was to add /sbin and /usr/sbin to the path, drop the database and reinstall ispconfig!

You guys do a great job!