PDA

View Full Version : messed up my ISPC3 installation


brandoni
30th April 2009, 10:48
I've been working on my new system for a couple of weeks now and it seemed almost ready to go into production, until... I dropped squirrelmail and roundcube in favor of the egroupware package. After this the ISPConfig control panel wouldn't load right anymore- the page only displayed the title but no content.

For whatever reason I thought it would be a good idea to change the ispconfig user password in mysql... well now nothing works :eek: The first thing I need to work on now is IMAP.

rather that reinstalling again, i want to understand how to fix it. I tried putting the new password into every affected file in both encrypted form and plain text (which way is correct anyways?) but still get this error:

authdaemond: failed to connect to mysql server (server=127.0.0.1, userid=ispconfig): Access denied for user 'ispconfig'@'localhost' (using password: YES)

I can log into mysql using this account and password. I've even tried giving this mysql account complete access to everything.

the files I changed were:
/etc/postfix/mysql-virtual_*.cf
/etc/courier/authmysqlrc
/usr/local/ispconfig/interface/lib/config.inc.php
/usr/local/ispconfig/server/lib/config.inc.php

I would be so grateful for some help or a hint :D

till
30th April 2009, 14:46
The passord is stored in plaintext in these files.

brandoni
30th April 2009, 15:11
ahh, thank you. the password just looked cryptic :)

till
30th April 2009, 15:18
Yes, it is based on a random value that is additionally hashed with md5 to generate a cleartext password containing chars and numbers.