PDA

View Full Version : ispconfig 3 login problem


pip
29th April 2009, 21:54
just installed fedora 10 with ispconfig 3, worked perfect the first time i logged in
www.myserver.com:8080/ i changed the password, looked around, then logged out, now i can't login with either the admin admin, or the user/password i added

mysql -h hostname -u root -p works

i can go into ispdb in mysql and see the sys_user name and password

phpmyadmin even works perfect

any suggestions

till
30th April 2009, 15:50
Please never change the mysql password of the ispconfig user manually. The old password is stored in the ispconfig config.inc.php files, take this password and use it to set the password in mysql back to the old value.

pip
30th April 2009, 21:55
Thanks it's working

RomaSvcs
12th May 2009, 06:39
I have the same problem but don't understand the answer (yes i am a newbee).

till could you please explain the steps?

Thanks

carlos barrera::confused:

till
12th May 2009, 20:49
Undo the changes that you manually did and it will start working again. As I posted above, the unencrypted password can be found in the file /usr/local/ispconfig/server/lib/config.inc.php

trexen
13th May 2009, 01:03
I dont know if this is the same error ore i couldent understand the solution.

But i just setup a new ispconfig 3 installation, and the first thing i did was to change the admin password and logout, then in but it tells me that i give the wrong password.

How can i recover the password? via mysql och change in some file ?

thanks
//Marcus

till
13th May 2009, 10:14
This thraed is not about changing the administrator password for ispconfig. This thread is about internal mysql passwords in ispconfig.

You can change the admin password in the sys_user table. The password has to be encrypted with crypt (crypt-md5 with salt).

trexen
13th May 2009, 10:37
ok, i miss understand.

See if i can find how to change admin password =)
//M

Found it. =)