View Full Version : Upgrading from Ubuntu 8.10 to 9.04

28th April 2009, 13:42
I was wondering if upgrading a server running ISPconfig on Ubuntu 8.10 to Ubuntu 9.04 is supported?

If so is there anything special I need to know?

If not, is there any indication for when this will be supported?


29th April 2009, 11:54
I haven't tried (tried this with an ISPConfig 2 server only where I had no problems), but I think it should work. If you want to go sure, make a backup before the upgrade (e.g. with SystemImager, Ghost4Linux or Clonezilla).

29th April 2009, 22:59
Please if someone tries it, please post the results



5th May 2009, 02:15
I just tried this by doing the following. (It is not reccommended to do this by ssh.)

apt-get install update-manager-core

1 package to be deleted
36 packages to be installed
394 packages to be upgraded

Download size 269M

I will post further results in about 1 -2 hours.

5th May 2009, 04:49
During the upgrade I was given a few options.

1. I kept the currently installed version of /etc/mysql/my.cnf (default)
2. I kept the currently installed version of /etc/apache2/ports.conf (default)
3. I kept the currently installed version of /phpmyadmin/apache.conf (default)
4. I choose NO to configure database for phpmyadmin with dbconfig-common.
5. I deleted obsolete packages
6. Restarted the computer.

Now I have incoming E-mail broke. Please see following post

Good Luck.

6th May 2009, 06:22
It seems that I found my first problem with the upgrade.
incoming mail is not working. This is what I see in my ispc cron log.

/bin/sh: /usr/local/ispconfig/server/scripts/run-getmail.sh: Permission denied

I tried to log in as root and run script and got this error.

/usr/share/getmail4/getmailcore/baseclasses.py:26: DeprecationWarning: the sets module is deprecated
import sets
Error: configuration file /etc/getmail/*.conf does not exist

I have lots of mail showing in mail queue. something similar to.

BF118E05B 4637 Tue May 5 11:12:33 MAILER-DAEMON
(connect to cluster-b.mailcontrol.com[]:25: Connection timed out)

I don't know where to go from here.
Can anyone help?


6th May 2009, 14:52

The upgrade removed several files including the /tmp dir where ISPConfig was originally downloaded.

I downloaded ispconf again and reinstalled.

12th May 2009, 11:10
Thanks for posting your experiences, this is very useful!