PDA

View Full Version : webmail


m u r
20th August 2005, 23:06
I have two machines: one for mail and one for web/dns. They both have the same domain, but different hostnames (mail.mydomain.com and web.mydomain.com). I access ISPConfig by https://mail.mydomain.com and https://web.mydomain.com. Will this cause problems?

When I try to go to use webmail (https://mail.mydomain.com/webmail), it times out. Also, I'm having trouble getting new mailboxes to work in each of the sites (ie. info@mydomain.com works, but joe@mydomain.com doesn't). I have several domains set up on both the mail and web/dns box, and I didn't do anything special to do virtual hosting. I just added new sites to the same client and used the same IP. Any ideas what I'm doing wrong?

falko
21st August 2005, 13:37
When I try to go to use webmail (https://mail.mydomain.com/webmail), it times out.

ISPConfig is running on port 81 unless you changed that.

Also, I'm having trouble getting new mailboxes to work in each of the sites (ie. info@mydomain.com works, but joe@mydomain.com doesn't). I have several domains set up on both the mail and web/dns box, and I didn't do anything special to do virtual hosting.

On the web/dns box you have to choose "External mailserver" for the domains (under Co-Domains and under Options).

m u r
21st August 2005, 17:21
I can log on to webmail now. Thanks!

Since I changed it to external in "co-domains" AND in "options," I get the following error when sending to the email addresses using a mail client:

info@mur-design.com SMTP error from remote mailer after RCPT TO:<info@mur-design.com>:host mail.archsupply.com [166.70.145.208]: 554 <info@mur-design.com>:Recipient address rejected: Relay access denied

or when sending using Opera webmail:

<info@archsupply.com>: host mail.archsupply.com[166.70.145.208] said: 554 <info@archsupply.com>: Recipient address rejected: Relay access denied (in reply to RCPT TO command)

I am behind a firewall -- would that be the problem?

I can send mail; I just can't receive it.

till
21st August 2005, 17:36
I can log on to webmail now. Thanks!

Since I changed it to external in "co-domains" AND in "options," I get the following error when sending to the email addresses using a mail client:

info@mur-design.com SMTP error from remote mailer after RCPT TO:<info@mur-design.com>:host mail.archsupply.com [166.70.145.208]: 554 <info@mur-design.com>:Recipient address rejected: Relay access denied

or when sending using Opera webmail:

<info@archsupply.com>: host mail.archsupply.com[166.70.145.208] said: 554 <info@archsupply.com>: Recipient address rejected: Relay access denied (in reply to RCPT TO command)

I am behind a firewall -- would that be the problem? The three domains in question are rwhm.net, mur-design.com, and archsupply.com.

I can send mail; I just can't receive it.

You only have to set mailserver to external on your website-server, not on your mailserver. Have you set the MX record pointing to your mailserver not your webserver?

When you set mailserver to external, this server will not accept emails for the domains anymore.

m u r
21st August 2005, 17:49
Works perfectly. Thank you so so much!