View Full Version : Courier-imap amd maildrop failure on Suse 11 64-bit

17th April 2009, 12:16

Trying to install ISPConfig 3 on a freshly installed OpenSuse 11 64 bit machine and having the following problems

rpm --force -i maildrop-2.0.4-10.5.i586.rpm
warning: maildrop-2.0.4-10.5.i586.rpm: Header V3 DSA signature: NOKEY, key ID 6530cd38
error: Failed dependencies:
libcourierauth.so is needed by maildrop-2.0.4-10.5.i586

courier-authlib and libauthmysql are both installed

The other thing is that I cannot install courier-imap

Yast keeps telling me that it 'conflicts with imap provided by itself'

Tried uninstalling imap first, makes no difference

I'm thinking tht with maildrop maybe I need an x86_64 version but I can't think of annything to try regarding the imap problem

Can anyone help?

18th April 2009, 11:35

49 views and no replies

It's looking like that's a no then

No matter, ISPConfig is just something I thought I'd take a look at as I had a fresh, clean Suse on the machine ready to move my server setup to a different box

I'll redo it fresh again and go back to the existing postfix/dovecot setup I have using the existing confs

18th April 2009, 14:00
Yes, you must use the x86_64 rpms on an x86_64 systems. The rpms for i686 won't work.

19th April 2009, 15:05
Cheers for confirming that falko

There were a few things I had already set up myself such as the dns server etc, and I also thought I might as well put Suse 11.1 on the machine rather than 11 as I have a dvd here from installing it on a different box, so I'm starting afresh

Are there any other issues I should be aware of when setting up ispconfig 3 on a 64 bit system?

I won't be following the instructions on the software packages to install to the letter this time, I think it will work better if I use Yast's software manager to install the packages before installing ispconfig itself

19th April 2009, 16:51
Are there any other issues I should be aware of when setting up ispconfig 3 on a 64 bit system?
Not that I know, but I didn't try myself.

19th April 2009, 22:01
Installed Suse 11.1 x86_64 and started following the instructions in INSTALL_OPENSUSE_11_1.txt

Letting the Yast software manager gui find the the packages itself this time, all went ok, until .....

Solvable courier-imap- conflicts with imap provided by itself

The only option offered to resolve the conflict is to not install courier-imap

Obviously this is a Suse issue rather than an ISPConfig one and I'm going to ask about it on their forum, but it would be good if anyone else that has come across this whilst trying to set up ispconfig on suse 11.1 64-bit and managed to solve it posts what they did to fix it

If I manage to solve it after asking on the opensuse forum I'll post it here in case anyone else comes across the same problem

19th April 2009, 22:15
Also I have been unable to find the getmail package for 64-bit suse 11.1 anywhere

Is this package absolutely necessary?

Can't say I've ever heard of it before, but from the name I guess it's something like fetchmail, could I just use that?

Scratch that, found the getmail site and got a getmail 4.9.0 tarball that works with all architectures and appears to have installed just fine

wget http://download.opensuse.org/repositories/server:/mail/openSUSE_11.0/i586/getmail-4.7.6-1.4.i586.rpm

That line from the isconfig 3 instructions threw me a little as I was looking for an x86_64 rpm

20th April 2009, 14:50
Didn't bother with the Suse forum, managed to get all the packages installed that INSTALL_OPENSUSE_11_1.txt tells you to in order to prepare for the ISPConfig 3 install except for mydns-ng-mysql

mydns-ng-1.2.8-1.1 refused to install complaining that it first needed mydns-ng_binary, a package which only returns rpmbone search pages for it when googling, and those pages have no results either. This was when using the rpm from the Suse repositories, tarball for the latest version ( obtained from sourceforge installed just fine

Have not been able to find a matching mydns-ng-mysql for it though, I will just have to wait and see if that becomes a problem later

There was a development library package I had to install before maildrop would configure, and at least one of the other packages I had to get tarballs for needed paths specified for the ./configure scripts as they were not searching in /usr/lib64 when trying to auto-configure things

One minor point regarding the instructions in INSTALL_OPENSUSE_11_1.txt which isn't specific to installing on 64-bit, after installing PhpMyAdmin it tells you to create a symbolic link to /usr/local/ispconfig/interface/web/phpmyadmin in /srv/www/htdocs/phpMyAdmin ... but ISPConfig hasn't been installed by this point so the folder you are trying to link to does not yet exist

I stopped before installing the actual ISPConfig package as it was already after 3am and I thought it best I get at least some sleep, I'm going to do that now and cross my fingers that the fact I'm not using the same versions of some packages specified in the instructions doesn't throw up a whole other set of problems ... wish me luck

20th April 2009, 15:45
And here's the first problem:

Logging into mysql using the command-line client works fine:

rune@godzooky:~> mysql -h localhost -u root -p
Enter password:
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 2
Server version: 5.1.33-log SUSE MySQL RPM

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.


When I run the ISPConfig installer:

MySQL database to create [dbispconfig]:

MySQL charset [utf8]:

Unable to connect to mysql server Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
MySQL server hostname [localhost]:

Looks like the mysql socket it's looking for isn't being created:

godzooky:/var/lib/mysql # ls -a
. .. ibdata1 ib_logfile0 ib_logfile1 mysql mysql-bin.000001 mysql-bin.000002 mysql-bin.000003 mysql-bin.000004 mysql-bin.index

My existing server machine (that this one will eventually be replacing) is on suse 11 64 bit, I checked on that out of curiosity and there's no socket in /var/lib/mysql on there either

Don't really know what to do next now, anyone have any ideas?

20th April 2009, 23:59
Check /etc/my.cnf or /etc/mysql/my.cnf

There should be some socket=/var/lib/mysql/mysql.sock lines in the [mysqld] and [mysqld_safe] sections. If not, add them (or change them).

My Debian uses /var/run/mysql/mysqld.sock, so check spellings.. ;-)


21st April 2009, 01:10
That allowed me to install it, so cheers for that mate

Don't why I didn't think of it myself and suse uses the same path as debian btw

The next problem is that it won't allow me to login:

Username or Password wrong.1

Restarting the apache as the instructions suggest makes no difference, I've even completely rebooted the whole machine and it still won't let me in

21st April 2009, 14:21
Also fooling about with the socket location seems to have tooled things in mysql

Unless I reset it to the suse default I can't login to mysql with the mysql client

phpMyAdmin throws up an error telling the server either isn't responding (which I know it is), or that the socket is incorrectly configured

Regardless of how I set the socket up, be it the suse default or where ispconfig likes it to be that error stays the same

I've uninstalled both mysql and phpmyadmin and reinstalled them and nothing changes