PDA

View Full Version : Webmail won't work


jamesls
15th April 2009, 07:15
I thiink my squirrel is hibernating

I'm running ubuntu 81.0, ispconfig 3 I used the ubuntu perfect server ispconfig 3.

Iv'e managed to get my web sites to resolve through a browser, and normal pop3 & smtp works ok for the 3 different sites.

Ive tried http:// ip add/webmail, 127.0.0.1/webmail, hostname/webmail, websites/webmail.

all come back with a not found error

In the dns records I have
A mail 10.0.0.10 0
A ns1 10.0.0.10 0
A victim6.co.co. 10.0.0.10 0
MX victim6.co.co. mail.victim6.co.co. 10
NS victim6.co.co. ns1.victim6.co.co.
that is al, not sure if I should alter any other records

When I was installing squirrel mail it worked ok, when tested with the http://ip/webmail - it came up with the login screen.

running ls -l /etc/apache2/conf.d
total 12
-rw-r--r-- 1 root root 237 20 18:31 apache2-doc
-rw-r--r-- 1 root root 269 21 01:05 charset
lrwxrwxrwx 1 root root 28 1 00:48 phpmyadmin.conf -> ../../phpmyadmin/apache.conf
-rw-r--r-- 1 root root 1464 ene 21 01:05 security

James

Horfic
15th April 2009, 08:09
It sounds like your webmail folder isn't linked to the squirrel webmail folder.

till
15th April 2009, 12:31
Most likely you created a IP based website in ISPConfig instead of a namebased and now you can not access webmail over IP anymore. A slution is e.g. to create a symlink in your website that points to the squirrelmail sources.

jamesls
15th April 2009, 17:45
Ok..... not sure quite what I've done then.

I've 3 web sites all test ones.
When I was setting up the dns bits I entered their domain names, and ips as follows.
DNS .. select client, zone "victim7.vx", NS "ns1" and gave it an email "admin.victim7.vx
Records select A, hostname "victim7.vx.", ip "10.0.0.10" (the ip of my host pc)
Select A, hostname "mail", ip "10.0.0.10"
Select A Hostname "ns1" ip "10.0.0.10"
Select MX hostname "victim7.vx.", mailserver "mail.victim7.vx"
Select NS zone "victim7.vx", hostname "ns1.victim7.vx."

Should I have entered 127.0.0.1 instead of 10.0.0.10, all the web sites point to 10.0.0.1

In the folder /var/www/ I have the following

FOLDERS Client, php-fcgi-scripts, webalizer
LINKS goof.tet, victim6.co.co, victim7.vx (3 web sites I made) webmail, and ispconfig which says its broken.
FILES index.html the original apache install "it works".

The questions now.
1. How do I change apache to names rather than ip's
I think I want to run names, I have 1 internet ip and 5 web sites.
At this point I don't want to have to configure extra virtual local IP's.

2. If I want to run SSL will I be able to do so if I'm using the "names" ?
SSL and WEBMAIL are optional to me, good to have and be able to do.

I'm fairly new to Linux, and know very little about ISP's other than using Cpanel as a client etc

jamesls
15th April 2009, 20:47
I tried placing links to squirrelmail in each website folder, and that worked ok for my 3 different sites.

I'm still wondering if I have "names" or "ip" websites setup though, and how I change them to "names"

James

Many thanks for your help

till
16th April 2009, 13:33
If you select '*' in the IP field then your sites are nambased. If you select a IP they are IP based.

jamesls
16th April 2009, 19:07
The more I play with ispconfig 3 and the more I read, the more impressed I am with this software, its a nice open framework that allows you to do almost anything you wish, the data stored in a table format make it easy to develope from a programing pespective.
Well done!!

Anyway

All the web sites have a "*" in ispconfig > sites >IP Address, I don't have the option to enter an IP.
I also had a look at my apache config files

In my /etc/apache2/sites-available/ mywebsite1.conf I have:-


..
<VirtualHost *:80>
DocumentRoot /var/www/victim6.co.co/web

ServerName victim6.co.co
ServerAdmin webmaster@victim6.co.co


## added for isp config
NameVirtualHost 192.168.100:80 192.168.0.100 is my wireless card
<VirtualHost 192.168.0.100:80>
ServerAdmin webmaster@localhost
DocumentRoot /var/www/apache2-default/

..

Reading the apache virtual hosts docs surgest that its configured to "names".

In ispconfig I have entered the ip 10.0.0.10 of my wired nic for all the A records (I have 2 network cards)

I've just setup another web site using the ip 192... and that won't work with webmail unless I add a link to squirrelmail.

james