PDA

View Full Version : PHPMyadmin not work


thenicespider
9th April 2009, 13:45
Everything is ok instead PHPMyadmin.

When I open http://ip_address/phpmyadmin or http://domain.com/phpmyadmin then error:
- The requested URL /phpmyadmin was not found on this server.

I have create a symlink for phpMyAdmin:
ln -s /srv/www/htdocs/phpMyAdmin /usr/local/ispconfig/interface/web/phpmyadmin

Any idea how to fix this error.

till
10th April 2009, 11:18
You missed to enter the port. If you created a symlink /usr/local/ispconfig/interface/web/phpmyadmin then phpmyadmin is accessed with:

http://ip_address:8080/phpmyadmin

thenicespider
12th April 2009, 13:19
The link in the client area is:
- http://domain.com:8080/sites/database_phpmyadmin.php?id=1

But when I click on the link then converted to:
- http://domain.com/phpmyadmin

How to fix?

falko
13th April 2009, 18:07
What's the output of ls -la /srv/www/htdocs/phpMyAdmin/?

Horfic
13th April 2009, 20:14
I know now how to get phpmyadmin to work for the domains when the website has a ip selected. AND NOT * AS IP
ln -s /var/www/phpmyadmin /var/www/{domain}/phpmyadmin

So my question is, what do I have to change that ISPConfig create this symbolic link automatic, when you create a website.

till
13th April 2009, 23:07
You can e.g. edit the apache plugin or write your own plugin.

thenicespider
14th April 2009, 05:40
Output of ls -la /srv/www/htdocs/phpMyAdmin/ is:

svr1:~ # ls -la /srv/www/htdocs/phpMyAdmin/

total 1240
drwxr-xr-x 8 root root 4096 Apr 9 17:45 .
drwxr-xr-x 4 root root 4096 Apr 9 01:59 ..
-rw-r--r-- 1 root root 227902 Mar 31 18:04 Documentation.html
-rw-r--r-- 1 root root 6813 Mar 31 18:04 index.php
-rw-r--r-- 1 root root 411 Mar 31 18:04 license.php
-rw-r--r-- 1 root root 12043 Mar 31 18:04 main.php
-rw-r--r-- 1 root root 25840 Mar 31 18:04 navigation.php
-rw-r--r-- 1 root root 52856 Mar 31 18:04 pdf_schema.php
lrwxrwxrwx 1 root root 26 Apr 9 17:45 phpMyAdmin -> /srv/www/htdocs/phpMyAdmin
-rw-r--r-- 1 root root 360 Mar 31 18:04 phpinfo.php
....... etc ........

baskin
16th May 2009, 14:41
I have the same problem on a new ispconfig 3 install on opensuse 11.1.

I can access phpmyadmin manual, but not through the link inside ispconfig's web interface. Although the link seems right (http://myserver:8080/sites/database_phpmyadmin.php?id=2) as soon i select it it reverts to http://myserver/phpmyadmin and eventually is not working.

How can i fix this?

Thanks in advance.

XRolando
4th August 2009, 15:18
I have the same problem on a new ispconfig 3 install on opensuse 11.1.

I can access phpmyadmin manual, but not through the link inside ispconfig's web interface. Although the link seems right (http://myserver:8080/sites/database_phpmyadmin.php?id=2) as soon i select it it reverts to http://myserver/phpmyadmin and eventually is not working.

How can i fix this?

Thanks in advance.

Exact same issue on opensuse 11.1.

catalyst
6th February 2010, 08:19
I have same issue on Cent OS 5.4 with ispconfig 3.
http://www.domain.com:8080/sites/database_phpmyadmin.php?id=1 (can't open it)
http://www.domain.com/phpmyadmin (can be opened)

How to fix it?

till
6th February 2010, 20:15
Set the correct hostname for the server in the ispconfig server settings.

catalyst
7th February 2010, 05:47
Set the correct hostname for the server in the ispconfig server settings.

Yes! The hostname is correct. It is the same as the hostname when I installed the Cent OS.
Any other issue?
Thank you!

till
7th February 2010, 17:22
Ok. But ispconfig is doing the phpmyadmin redirect to the hostname that you have set in ispconfig server settings, if the redirect goes to a wrong hostname / domain, then it can not be set correctly in ispconfig. There is no other option, so please check again and compare the domain / hostname you get redirected to with the settings in ispconfig.

Stojc
10th March 2010, 17:28
Ok. But ispconfig is doing the phpmyadmin redirect to the hostname that you have set in ispconfig server settings, if the redirect goes to a wrong hostname / domain, then it can not be set correctly in ispconfig. There is no other option, so please check again and compare the domain / hostname you get redirected to with the settings in ispconfig.

I think it can be corrected and phpmyadmin will then work on any domain and on the right port. Simply open file database_phpmyadmin.php in /var/www/ispconfig/sites/ and look for line

header('location:' . $http . '://' . $serverData['server_name'] . '/phpmyadmin'); (not sure why is this rewrite needed - except if you want
always to come in from same address)

and replace it with

header('location:/phpmyadmin');

Save it and then try. On my server works fine.

BorderAmigos
17th March 2010, 21:25
I had this same problem with 3.0.2. The port number is lost when the link is clicked and it is trying on port 80.

I changed the line above to include the port number and it now works...

header('location:' . $http . '://' . $serverData['server_name'] . ':8080/phpmyadmin');

till
17th March 2010, 21:27
The above does not apply to ISPConfig 3.0.2 anymore, in ISPConfig 3.0.2, you set the link to phpmyadmin under System > Interface Config. So instead of modifying any code, enter the URL to phpmyadmin in the interface config settings.

BorderAmigos
17th March 2010, 21:33
Thank you. I did not know that.

Stojc
17th March 2010, 23:22
Thanks, Till. I also noticed that, but few days later (after I changed the code).

Regards

menahem
24th March 2010, 00:08
The above does not apply to ISPConfig 3.0.2 anymore, in ISPConfig 3.0.2, you set the link to phpmyadmin under System > Interface Config. So instead of modifying any code, enter the URL to phpmyadmin in the interface config settings.
Till,
It did not worked for me.:(

phpmyadmin was installed by apt-get. (we are talking about debian etch - 4.0r8)

At /var/www lib i have a link to:/usr/share/phpmyadmin.

At ispconfig (ver 3.0.2.1) -->system-->interface config-->PHPMyAdmin URL i inserted: www.domain.tld.

www.domain.tld is the FQDN for the 1 domain hosted by the server i.e server domain name (server it self) lets say is abcd.com server full domain name (after running hostname -f)= host.abcd.com.

Now: 1st. web site is... www.abcd.com

Putting the URL www.abcd.com/phpmyadmin in ispconfig (ver 3.0.2.1) -->system-->interface config-->PHPMyAdmin URL i am getting a (nice looking) 404.

Please advice hoto fix it.
Thank you.
Menahem

miguelal
25th March 2010, 20:39
I had the exact same problem. You probably already fixed it but in the interest of helping any others that stumble upon this thread:

Appending the following line to /etc/apache2/apache2.conf did it for me:

Include /etc/phpmyadmin/apache.conf

jumba
28th August 2010, 15:38
Same problem here on an Ubuntu 10.04 server with ISPConfig 3.0.2.2.
In System > Interface Config, if I enter something like /newalias as the new phpMyAdmin URL and then restart apache, it does not work.
phpMyAdmin can only be accessed from example.com/phpmyadmin and example.com/newalias returns a 404.

till
28th August 2010, 16:43
You have to enter a fully qualified URL starting with http://....

jumba
7th September 2010, 03:57
Those are the settings for the server and affect all sites hosted on that server so I can't enter a FQDN.
I haven't found a place where the the URL of phpMyAdmin can be configured for each site.

orasis
11th September 2010, 19:05
Hello,

I am trying since yesterday to make a perfect installation os ispconfig 3 on ubuntu 9,10
I have followed everything step by step and without errors on this tutorial: http://www.howtoforge.com/perfect-server-ubuntu-9.10-ispconfig-3

I have created a couple of addresses on no-ip.com service and using the one for the main ispconfig addrress like example.bounceme.net:8080 and works perfect and also another one like examplesite.bounceme.net that I have created as a site in ispconfig and also works great, created ftp user that connects with success, database, etc.

my problem is I cannot find a way since yesterday, in how to access phpmyadmin. I mean I cannot even get there at all. All I get the following:

trying on: http://example.bounceme.net:8080/phpmyadmin
I get:

Object not found!

The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again.

If you think this is a server error, please contact the webmaster.
Error 404
example.bounceme.net
Sat Sep 11 18:57:34 2010
Apache/2.2.12 (Ubuntu)

trying on: http://example.bounceme.net/phpmyadmin
..same result as the above one. the same I get if I try on the site I have created. Also if I click on the icon to access the database inside ispcofig I get the same.

I tryed to change the phpmyadmin address at System Config but similar errors.
In Server Config my Hostname says: example.bounceme.net
I changed that to example but same.

Very confused here, once there's been a while I haven't used ispcofig and things changed, and I also forgot some things.
please some help here, I am not that good !
Thanks so much !

orasis
11th September 2010, 19:57
oh guys, you know what the problem was ?

I run dpkg-reconfigure phpmyadmin and all I noticed was that I had to hit spacebar to add a little * when choosing apache2. previously I had jsut hit ENTER...

well !!

jumba
11th October 2010, 15:54
Those are the settings for the server and affect all sites hosted on that server so I can't enter a FQDN.
I haven't found a place where the the URL of phpMyAdmin can be configured for each site.

Could you fix this in the next version?
Thanks

till
11th October 2010, 15:59
phpmyadmin is installed globally for all sites and not on a per site basis and you can set the phpmyadmin URL as fqdn (starting with http://....) in ispconfig under system > interface config.