PDA

View Full Version : stats only shows 2 days ago data?


HellMind
5th April 2009, 19:37
when I go to /stats
I just see the last 2 days stats
Its like isn't storing the old data or it is deleting it.

till
6th April 2009, 09:35
Older logfiles get deleted but not older stats as webalizer keeps the stats in his history file.

HellMind
8th April 2009, 05:22
Older logfiles get deleted but not older stats as webalizer keeps the stats in his history file.

Something is wrong because I see just the last days statistics

What is happening?

till
8th April 2009, 09:12
Please make sure that you have enabled incremental log file processing in /etc/webalizer/webalizer.conf

HellMind
8th April 2009, 20:48
Please make sure that you have enabled incremental log file processing in /etc/webalizer/webalizer.conf

Now, I have enabled it.

But I don't see any changes.

till
8th April 2009, 20:55
If you enabled it now then you see the first changes in 2 days.

HellMind
12th April 2009, 01:24
If you enabled it now then you see the first changes in 2 days.

It works!
But I think this was a bug because I ispc didin't do that on installation

Norman
17th June 2009, 09:50
I can confirm I also got this issue. Maybe mention this in the perfect setup install guides?

HellMind
17th June 2009, 10:38
Maybe was an old bug and the new releases don't fix it, if you upgrade

Norman
18th June 2009, 20:06
I set Incremental to yes
in /etc/webalizer/webalizer.conf

But I still only see 2 days worth of stats when it updated the stats.
Any idea why?

The server is freshly installed from recent ispconfig 3 package. So Im wondering what causes this.

till
18th June 2009, 23:15
You have to wait at least 2 days.

OnePercentile
28th June 2009, 20:29
I don't think this Incremental thing is a bug. It's obviously one of a thousand settings that ruins previous stats, is annoying and, I'm guessing, just got overlooked.

Now if there is a way to retrieve the stats data previous the days shown, in order to keep the more than a years worth of stats up2date, that would be nice.

Thanks

J

Nicke
29th June 2009, 23:58
I had the same problem. Followed the "Perfect server"-guide. :)
I have now changed incremetial to yes.