PDA

View Full Version : www.mydomain.tld goes to it works!


Etienne
5th April 2009, 14:28
Hi,

I've been trying to figure this out already for some time by myself but I cant really figure it out, I know it must be something simple but...

I have a "Perfect Server setup Debian Lenny" wit ISPconfig 3 on it, I cant seem to get the sites right, I have two sites, 1 web-worlds.com and the second dolls-world.com, when in my browser I try to open "www.web-worlds.com" I get the It Works page, but when I type "web-worlds.com" I get the default ISPConfig web site, so kinda the other way arround cuz I want both to point to the default, anybody that can help me figure out how to do this, I am missing something but cant seem te figure out what.

Anyway thanks in advance,
Etienne

till
6th April 2009, 10:30
You have to select www as auto subdomain in the website settings.

Etienne
7th April 2009, 16:24
Till,

Okay that did the job allright for the "www.web-worlds.com" domain, only my second domain "www.dolls-world.com" still keeps opening in it works, what is the trick there ??

Thanks,
Etienne

Etienne
8th April 2009, 11:40
You gotta be kidding me... is there nobody else besides Falko and Till that knows how to setup a second domain ???? very sad :(

till
8th April 2009, 11:43
The second domain is setup exactly the same then the first and third domain.

Etienne
8th April 2009, 14:46
Okay, as far as i know all the information is the same for both domains, i will illustrate here what is the problem, together with screen shots.

http://www.web-worlds.com - OK
http://web-worlds.com - OK
http://www.web-worlds.com/webmail - gives 404
http://web-worlds.com/webmail - gives 404
http://www.web-worlds.com/phpmyadmin - OK
http://web-worlds.com/phpmyadmin - OK
http://www.web-worlds.com:8080 - OK
http://web-worlds.com:8080 - OK

http://www.dolls-world.com - gives It Works
http://dolls-world.com - gives It Works
http://www.dolls-world.com/webmail - OK
http://dolls-world.com/webmail - OK
http://www.dolls-world.com/phpmyadmin - OK
http://dolls-world.com/phpmyadmin - OK
http://www.dolls-world.com:8080 - OK
http://dolls-world.com:8080 - OK

192.168.123.200 - gives It Works
192.168.123.200/webmail - OK
192.168.123.200/phpmyadmin - OK
192.168.123.200:8080 -OK

My Registrar setup:

http://www.web-worlds.com/GODADDY.jpg

My Dynamic DNS host:

http://www.web-worlds.com/DNS.jpg

My ISPConfig Webdomain setup:

http://www.web-worlds.com/1st.jpg

My ISPConfig DNS zone setup:

http://www.web-worlds.com/3rd.jpg

continues in next post.

Etienne
8th April 2009, 14:47
continued:

My ISPConfig DNS Records setup:

http://www.web-worlds.com/4rd.jpg

This kinda sums it up, if you need anything else I will be happy to provide, cuz i really want this to work.

Thanks in advance
Etienne

ggohdin
8th April 2009, 23:57
Hi, you need fullstops at the end of your domain names in your dns zone records. e.g "web-world.com." How ever your zone record for dolls-world.com. is correct, just see where the full stops are in that zone and do the same with the other zones.

Etienne
9th April 2009, 00:38
Hi ggohdin,

Could you be a little more specific, I dont understand what you mean with full stops??

Thanks,
Etienne

ggohdin
9th April 2009, 00:51
ok so this is an example of how records should look in you zone (soa).

web-worlds.com. A 123.123.123.123 0
mail A 123.123.123.123 0
ns1 A 123.123.123.123 0
ns2 A 123.123.123.123 0
www A 123.123.123.123 0
web-worlds.com. MX mail.web-worlds.com. 10
web-worlds.com. NS ns1.web-worlds.com. 0
web-worlds.com. NS ns2.web-worlds.com. 0

Ok. so here we have the fullstops at the end of your domain and your name server, just copy that in you Zone records in ispconfig3.

Remember that it can take up to 3 days for things to work properly, and also because your domain name is the same as your Name server (ns1.web-worlds.com etc) you might have to create a Glue record with your registrar.

Etienne
9th April 2009, 14:46
Hi, you need fullstops at the end of your domain names in your dns zone records. e.g "web-world.com." How ever your zone record for dolls-world.com. is correct, just see where the full stops are in that zone and do the same with the other zones.

That makes no sense, because the "web-worlds.com" opens up normally, but the "dolls-world.com" not ???

But I changed them to full stops anyway.

But why could it take up to 3 days considdering that the changes are on my server and dont reflect to the outside world?

Correct me if i'm wrong but when somebody types "http://www.web-worlds.com" then the first to respond is Godaddy because there is the name registered, Godaddy gives the ns1.dnsexit.com.

On DNSExit it looks up the ip adres and then links to that, then on my server it is rerouted to the right web adress???

Is this the right way ??

Thanks in advance,
Etienne

falko
9th April 2009, 15:00
Why do you set up DNS records in ISPConfig when your registrar is running the nameservers for your domains? That makes no sense to me.

Anyway, can you post the vhost configurations of www.web-worlds.com and www.dolls-world.com?

Etienne
9th April 2009, 15:41
Hi Falko,

What is your suggestion then, to turn of MyDNS in the ISPconfig ??

And vhost.conf I dont have, at least a find / vhost.conf say so.

Thanks,
Etienne

falko
10th April 2009, 13:52
What is your suggestion then, to turn of MyDNS in the ISPconfig ??If your registrar is running the nameservers for your domains, then you don't need to configure anything in the DNS part of ISPConfig.

And vhost.conf I dont have, at least a find / vhost.conf say so.

Which distribution are you using? For Debian/Ubuntu, the files should be in /etc/apache2/sites-available.

Etienne
11th April 2009, 12:29
Okay I turned off mydns in ISPconfig, and waited 2 days, but still no change.

The output for web-worlds.com.vhost:

<Directory /var/www/web-worlds.com>
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>

<VirtualHost *:80>
DocumentRoot /var/www/web-worlds.com/web

ServerName web-worlds.com
ServerAlias www.web-worlds.com
ServerAdmin webmaster@web-worlds.com

ErrorLog /var/log/ispconfig/httpd/web-worlds.com/error.log

<Directory /var/www/web-worlds.com/web>
Options FollowSymLinks
AllowOverride Indexes AuthConfig Limit
Order allow,deny
Allow from all

# ssi enabled
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
Options +Includes
</Directory>
<Directory /var/clients/client1/web1/web>
Options FollowSymLinks
AllowOverride Indexes AuthConfig Limit
Order allow,deny
Allow from all

# ssi enabled
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
Options +Includes
</Directory>

# cgi enabled
<Directory /var/clients/client1/web1/cgi-bin>
Order allow,deny
Allow from all
</Directory>
ScriptAlias /cgi-bin/ /var/clients/client1/web1/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
# suexec enabled
SuexecUserGroup web1 client1
# mod_php enabled
AddType application/x-httpd-php .php .php3 .php4 .php5
php_admin_value sendmail_path "/usr/sbin/sendmail -t -i -fwebmaster@web-worlds.com"
php_admin_value upload_tmp_dir /var/clients/client1/web1/tmp
php_admin_value session.save_path /var/clients/client1/web1/tmp
#php_admin_value open_basedir /var/clients/client1/web1:/usr/share/php5


</VirtualHost>

and of dolls-world.com.vhost:

<Directory /var/www/dolls-worlds.com>
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>

<VirtualHost *:80>
DocumentRoot /var/www/dolls-worlds.com/web

ServerName dolls-worlds.com
ServerAlias www.dolls-worlds.com
ServerAdmin webmaster@dolls-worlds.com

ErrorLog /var/log/ispconfig/httpd/dolls-worlds.com/error.log

<Directory /var/www/dolls-worlds.com/web>
Options FollowSymLinks
AllowOverride Indexes AuthConfig Limit
Order allow,deny
Allow from all

# ssi enabled
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
Options +Includes
</Directory>
<Directory /var/clients/client1/web3/web>
Options FollowSymLinks
AllowOverride Indexes AuthConfig Limit
Order allow,deny
Allow from all

# ssi enabled
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
Options +Includes
</Directory>

# cgi enabled
<Directory /var/clients/client1/web3/cgi-bin>
Order allow,deny
Allow from all
</Directory>
ScriptAlias /cgi-bin/ /var/clients/client1/web3/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
# suexec enabled
SuexecUserGroup web3 client1
# mod_php enabled
AddType application/x-httpd-php .php .php3 .php4 .php5
php_admin_value sendmail_path "/usr/sbin/sendmail -t -i -fwebmaster@dolls-worlds.com"
php_admin_value upload_tmp_dir /var/clients/client1/web3/tmp
php_admin_value session.save_path /var/clients/client1/web3/tmp
#php_admin_value open_basedir /var/clients/client1/web3:/usr/share/php5


</VirtualHost>


Hope somebody can figure this out...

Thanks,
Etienne

Etienne
11th April 2009, 12:36
:confused: Hmm i allready see something strange... there is everywhere written dolls-worlds.com and it should be dolls-world.com ??

Really wondering from where comes the extra s, and why it is not reflected in ISPConfig files???

Any clues ?

TIA
Etienne

falko
12th April 2009, 15:32
Did you use dolls-worlds.com or dolls-world.com in the ISPConfig web interface?

Etienne
12th April 2009, 15:58
For some reason I have occassionally used world and occassionally used worlds ..??.. but I changed it now by vi the .host file and making new symlinks, and all is working (trail and error)

Only thing now left is the symlink to the webmail, if you have any fast clues on how to do this because a simple symlink seems to run into permission problems...

Thanks,
Etienne

Etienne
12th April 2009, 16:14
Never mind, this is also solved :) turns out a webmail symlink from the web1/web to usr/share/squirrelmail did the trick.

This thread can be closed:)

Thanks to all people involved!