View Full Version : Argument "-" isn't numeric in numeric gt (>) at /usr/sbin/vlogger line 456

5th April 2009, 13:21
Fresh install of Ispconfig on CentOS 5, things appear to be working however the ispconfig web interface periodically becomes unusable, only blank pages show up, cannot log in due to javascript errors and so forth.

Restarting apache temporarily resolves.

Also, the following repeatedly appears in /var/log/httpd/error_log:

Argument "-" isn't numeric in numeric gt (>) at /usr/sbin/vlogger line 456, <STDIN> line 18

I tried this:


but no real difference, same error shows up in the error_log

perl-TimeDate is installed

which vlogger outputs: /usr/sbin/vlogger

the above two items I have seen mentioned in other threads where the problem appeared similar.

6th April 2009, 14:52
I've added this to our bugtracker.

27th April 2009, 02:45
I had the same problem. For me, the right solution for this problem is to change only one letter %b from lowercase to uppercase in file /etc/httpd/conf/sites-available/ispconfig.conf,
in LogFormat line. Change:

LogFormat "%v %h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined_ispconfig
to this
LogFormat "%v %h %l %u %t \"%r\" %>s %B \"%{Referer}i\" \"%{User-Agent}i\"" combined_ispconfig

Lowercase b to uppercase B. It looks that vlogger does not understand dash - when it's zero it must be zero.
As it is written here already: http://httpd.apache.org/docs/1.3/mod/mod_log_config.html

%B (Bytes sent, excluding HTTP headers),
%b (Bytes sent, in CLF format i.e. a '-' rather than a 0 when no bytes are sent)