PDA

View Full Version : No connect admin and webmail


jfruano
3rd April 2009, 16:04
I cannot enter to the panel of administration and webmail putting the address I.P. or the name of my server example:

www.mydomain.com:8080 www.mydomain.com/webmail

In www.mydomain.com:8080
no connect any page.

In webmail showme page page error 404 page not found

Only I can enter to the panel of administration putting:

192.168.2.3:8080

and not access to webmail with:
192.168.2.3/webmail

Can they help me to configure well my server ?

Thank you

till
4th April 2009, 10:37
The domain www.mydomain.com has to point with a dns A-Record to the server IP or in case thyt your server is behind a router then to the external IP address.

jfruano
4th April 2009, 12:05
Thanks Till for your response.

I do not have own DNS.

I have my own I.P. (xxx.xxx.xxx.xxx)

This my server config:


In Server Config :

Network Configuration (checked)

IP Address xxx.xxx.xxx.xxx (my I.P.)
Netmask 255.255.255.0
Gateway 192.168.2.1
Hostname mydomain.tld
Nameservers 192.168.2.3 (the gateway in my router for the server)

Please you can say if this configuration is correct ?

I have to add some DNS in ISPConfig ?


Thank you for answering and your excellent work.

falko
4th April 2009, 14:22
I do not have own DNS.

Then you must configure the DNS record on the authoritative nameservers for mydomain.com (probably your registrar's nameservers?).

jfruano
6th April 2009, 18:39
I not connect to Squirrelmail

I put xxx.xxx.xxx.xxx (my I.P.) /webmail and showme ERROR 404 page not found.

Connect fine when i enter in admin panel xxx.xxx.xxx.xxx:8080
but not in xxx.xxx.xxx.xxx/webmail

Please help. :confused:

J.F. Ruano

jfruano
7th April 2009, 14:53
Please, can nobody help me? :o

Some suggestion please.

Thank you.

J.F. Ruano

falko
7th April 2009, 17:48
Which distribution are you using, and which tutorial did you use to set the system up?

jfruano
7th April 2009, 18:12
Which distribution are you using, and which tutorial did you use to set the system up?

Debian Lenny

and your The Perfect Server - Debian Lenny (Debian 5.0) [ISPConfig 3] (http://www.howtoforge.com/perfect-server-debian-lenny-ispconfig3)

Thanks Falko for your response.

zosorock
7th April 2009, 19:35
Same distribution and same tutorial I used. I think his problem is similar to mine and joemateer (http://www.howtoforge.com/forums/showthread.php?t=33315)'s. Perhaps it's Apache 2.2 related?

jfruano
8th April 2009, 04:59
I think that we are several users are the same problem. He would be grateful very much to whom it us could help do some response.

I ask for pardon for repeat me in this topic, but it performs importance for my, and till now they have not reported any solution. :confused:
Thanks and excuse for repeating this help.

J.F. Ruano

archerjd
8th April 2009, 05:19
What is the output of the following command? ls -l /etc/apache2/conf.d

jfruano
8th April 2009, 11:47
What is the output of the following command? ls -l /etc/apache2/conf.d

server1:/# ls -l /etc/apache2/conf.d
total 12
-rw-r--r-- 1 root root 237 ene 20 18:31 apache2-doc
-rw-r--r-- 1 root root 269 ene 21 01:05 charset
lrwxrwxrwx 1 root root 28 abr 1 00:48 phpmyadmin.conf -> ../../phpmyadmin/apache.conf
-rw-r--r-- 1 root root 1464 ene 21 01:05 security
server1:/#

Thanks for your response

J.F. Ruano.

till
8th April 2009, 12:21
You can only connect to webmail over the IP if you have not created any website that is explicitely bound to that IP. So either you select * for all sites and not the IP address or you will have to create a website for your webmail application and phpmyadmin and then install phpmyadmin and webmail into this website.

jfruano
8th April 2009, 14:57
Totally strange, previously I had tried all forms many days and was not working. Nevertheless now putting * in all domains I.P. as says Till , and now works very fine.

Stranger, stranger, stranger. :eek::eek::eek:

But finally solved. :)

Thank you very much for everything and I ask pardon for the inconveniences.

J.F. Ruano.