PDA

View Full Version : Postfix / Amavisd / Courier on Debian Lenny


meinemitternacht
2nd April 2009, 15:41
Ok I followed the tutorial and have everything working great, except sometimes messages don't go through. Here is the mail.log excerpt:


Mar 28 17:06:27 meinkleinewelt postfix/smtpd[13851]: connect from wfto.cc[127.0.0.1]
Mar 28 17:06:27 meinkleinewelt postfix/smtpd[13851]: D7743FD97D: client=wfto.cc[127.0.0.1]
Mar 28 17:06:27 meinkleinewelt postfix/cleanup[13859]: D7743FD97D: message-id=<62008.1238259987@wfto.cc>
Mar 28 17:06:27 meinkleinewelt postfix/qmgr[9860]: D7743FD97D: from=<***********@wfto.cc>, size=1143, nrcpt=1 (queue active)
Mar 28 17:06:27 meinkleinewelt postfix/smtpd[13851]: disconnect from wfto.cc[127.0.0.1]
Mar 28 17:06:27 meinkleinewelt amavis[20346]: (20346-07) (!)DENIED ACCESS from IP ***.**.***.*, policy bank ''
Mar 28 17:06:27 meinkleinewelt postfix/smtp[13861]: D7743FD97D: to=<SomeEmailAddress@aol.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.02, delays=0.01/0.01/0/0, dsn=4.4.2, status=deferred (lost connection with 127.0.0.1[127.0.0.1] while receiving the initial server greeting)


Any hints?

till
2nd April 2009, 16:03
Please post the content of the /etc/hosts file

meinemitternacht
2nd April 2009, 16:29
127.0.0.1 wfto.cc wfto localhost localhost.localdomain

meinemitternacht
2nd April 2009, 20:12
Does the /etc/hosts look correct?

till
2nd April 2009, 21:16
The lines must be:

127.0.0.1 localhost localhost.localdomain
192.168.0.1 wfto.cc wfto



and then replace 192.168.0.1 with the IP of your server.

meinemitternacht
3rd April 2009, 16:36
Ok I did that and it still doesn't work. Gives me the same "deferred" error in the mail.log file. Let me restart the server and see what happens.