PDA

View Full Version : ISPconfig 3.0.0.9 ([warn] NameVirtualHost IP...:80 has no VirtualHosts)


edge
21st March 2009, 23:24
For some reason I'm getting the following warning when starting (and stopping) Apache2 on my ISPcondig 3.0.0.9 server. (I've masked the real IP)
OS is Debian Lenny.
/etc/init.d/apache2 start
Starting web server: apache2[Sat Mar 21 22:16:01 2009] [warn] NameVirtualHost 65.55.21.250:80 has no VirtualHosts
[Sat Mar 21 22:16:01 2009] [warn] NameVirtualHost 65.55.21.250:443 has no VirtualHosts
Not sure if this was all the time, but today I've placed the server in a DC, and I needed to change all the IP's on it.

Looking at the /etc/apache2/sites-available/ispconfig.conf I do see the two IP's, but I do not see them in any of the .vhost files

falko
22nd March 2009, 16:12
Do the .vhost files use the correct IPs?

edge
22nd March 2009, 17:44
Yes they do, but I found the problem (sort of)
I had all sites set to use IP *
After I set one of the sites to the server IP, the "[warn] NameVirtualHost 65.55.21.250:80 has no VirtualHosts" warning was gone.

I DO still have the warning: "[warn] NameVirtualHost 65.55.21.250:443 has no VirtualHosts"

till
22nd March 2009, 19:07
This warning is fine as you do not run a SSL site on this IP yet.

alex288288
1st August 2009, 22:57
im getting the same problem

[root@208 ~]# /etc/init.d/httpd restart
Stopping httpd: [ OK ]
Starting httpd: [Sat Aug 01 16:05:09 2009] [warn] NameVirtualHost 208.93.233.53:80 has no VirtualHosts
[Sat Aug 01 16:05:09 2009] [warn] NameVirtualHost 208.93.233.53:443 has no VirtualHosts
[Sat Aug 01 16:05:09 2009] [warn] NameVirtualHost *:8080 has no VirtualHosts
[Sat Aug 01 16:05:09 2009] [warn] NameVirtualHost *:443 has no VirtualHosts
[Sat Aug 01 16:05:09 2009] [warn] NameVirtualHost *:80 has no VirtualHosts


do i need to delete this ? ive uninstalled ISPconfig3... needs to be reinstalled

till
2nd August 2009, 07:57
See my post #4. This warning is fine, so there has nothing to be changed.