PDA

View Full Version : named and fc4 oops


jnoble
19th August 2005, 18:16
Hello all.

I installed 2.0.7 on a fresh FC4 install (according to guide) and all seemed to work well, no errors reported, apache and such were working fine, however, named was not serving as a NS.

One of the other threads said to check the symlink in the chroot dir, It was not there, (here where the oops comes in) somehow I overwrote the real named.conf and rndc.conf with symlinks, as you can imagine, this made things not work :(

I have tried yum to remove and reinstall all the components that look relevant( bind, bind-chroot, NetworkManager, caching-nameserver) and named works untill the first edit of a zone in ISPconfig, then I get this error when restarting named.:

Starting named:
Error in named configuration:
zone 0.0.127.in-addr.arpa/IN: loaded serial 1997022700
zone 0.168.192.in-addr.arpa/IN: loaded serial 2005081901
dns_master_load: pri.verde.info:19: mail.verde.info: CNAME and other data
zone verde.info/IN: loading master file pri.verde.info: CNAME and other data
_default/verde.info/IN: CNAME and other data


I also tried running 2.0.7 as a upgrade install, and that did not resolve it.

is there a way to fix it again? or should I reinstall fc4 and start over?


James
James

falko
19th August 2005, 18:29
Can you post the file pri.verde.info here?

jnoble
19th August 2005, 19:49
Hello, here is the file, looks good to me?

$TTL 86400
@ IN SOA ns1.verdecommunications.com. admin.verde.info. (
2005081901 ; serial, todays date + todays serial #
28800 ; refresh, seconds
7200 ; retry, seconds
604800 ; expire, seconds
86400 ) ; minimum, seconds
;
NS ns1.verdecommunications.com. ; Inet Address of name server 1
NS ns2.verdecommunications.com. ; Inet Address of name server 2
;

mail MX 10 192.168.0.33.

verde.info. A 192.168.0.33
www A 192.168.0.33
ww A 192.168.0.33

mail CNAME verde.info.

;;;; MAKE MANUAL ENTRIES BELOW THIS LINE! ;;;;


The ww. entry is not an error, just testing

James