PDA

View Full Version : Ispconfig3 SPF how to add?


HellMind
11th March 2009, 17:32
I need a sample how to set up the SPF ns records

I tried
TXT domain.com spf1 mx -all 0
And with
TXT domain.com v=spf1 mx -all 0

and I get no answer of TXT question using dig.
Ty

till
12th March 2009, 12:16
Just add the SPF record as txt record to your domain. If you want to query your server with dig, login to the server and then use:

dig @localhost .......

so you dont have to wait a few hours to let your dns records propagate.

HellMind
12th March 2009, 14:39
I did that but I get no reply, how can I debug that error?

till
12th March 2009, 15:09
Do you get answers for other records of this domain? If yes, change a record for this domain in the local server and query it again to see if the answer changes too.

HellMind
12th March 2009, 15:13
I can't see any TXT reply
It seems the mydns is ignoring all the TXT records

The others a mx and cname records works fine

till
12th March 2009, 15:14
1) Which mydns version do you use?
2) Is the record in the mysql database that mydns queries?

HellMind
12th March 2009, 19:59
mydns --version
mydns (mydns) 1.2.8.25 (MySQL 5.0.51a)

in the mysql ispconfig db I got the TXT entry

71 1 5 riud riud 1 6 xxx.com TXT v=spf1 mx ~all 0 86400 Y

till
12th March 2009, 20:08
You missed to add the dot at the end of mejorserver.com. It must be "mejorserver.com." if the dns record shall be for the domain mejorserver.com and not mejorserver.com.mejorserver.com

HellMind
12th March 2009, 20:17
You missed to at the dot at the end of mejorserver.com. It must be "mejorserver.com." if the dns record shall be for the domain xxx.com and not xxx.com.xxx.com

Thank you :)
It works now.

.

u4david
23rd April 2010, 21:35
moved to new post

bahadircolak
7th May 2010, 11:41
Should we include " signs?

Like:
"v=spf1 ~all"

Or just:
v=spf1 ~all

falko
8th May 2010, 13:19
Yes, please include the quotation marks (").

u4david
8th May 2010, 20:44
my works with out the "