PDA

View Full Version : Ispconfig 3 Vhost issues.


DestRoYeD
25th February 2009, 22:56
I Have Ispconfig 3 installed, One of my Coworkers was setting up awstats and made a mess of the Vhost files, I Have managed to fix this problem, But now many of my sites including the ispconfig 3 Admin, No longer work they just Redirect to the Default page.

Nothing in the apache error.log or the error log for that particular vhost.

I Have check the vhost files of the sites that don't work and they look fine.

This is the error i get when i restart apache2

XXXXXX@XXXX:/etc/apache2/sites-available$ sudo /etc/init.d/apache2 start
* Starting web server apache2

[Thu Feb 26 10:45:50 2009] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
[Thu Feb 26 10:45:50 2009] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
[Thu Feb 26 10:45:50 2009] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
[Thu Feb 26 10:45:50 2009] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
[Thu Feb 26 10:45:50 2009] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
[Thu Feb 26 10:45:50 2009] [error] VirtualHost _default_:8080 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
[Thu Feb 26 10:45:50 2009] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
[Thu Feb 26 10:45:50 2009] [warn] NameVirtualHost *:8080 has no VirtualHosts


[Thu Feb 26 10:45:50 2009] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results

I have heard that this is a common problem with Ubuntu/Debian and has to do with the default file.


Any Ideas?

Brett

till
25th February 2009, 23:41
Yes, thats a issie with the default file. Open the apache default host file and replace * with *:80 in thevhost and the namevirtualhost directive and then restart apache.

DestRoYeD
26th February 2009, 00:55
Cheers till,

I tried this and it just made all sites go to the default


* Stopping web server apache2
[Thu Feb 26 12:51:22 2009] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Thu Feb 26 12:51:22 2009] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Thu Feb 26 12:51:22 2009] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Thu Feb 26 12:51:22 2009] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Thu Feb 26 12:51:22 2009] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Thu Feb 26 12:51:22 2009] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Thu Feb 26 12:51:22 2009] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Thu Feb 26 12:51:22 2009] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Thu Feb 26 12:51:22 2009] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Thu Feb 26 12:51:22 2009] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Thu Feb 26 12:51:22 2009] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Thu Feb 26 12:51:22 2009] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Thu Feb 26 12:51:22 2009] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Thu Feb 26 12:51:22 2009] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Thu Feb 26 12:51:22 2009] [warn] NameVirtualHost *:8080 has no VirtualHosts


My main problem is not being able to access the ispconfig administration. It just goes to the Default page e.t.c /var/www/index.php

till
26th February 2009, 09:13
Looks as if you specified more then one default host manually in your installation. You will have to remove them.

DestRoYeD
26th February 2009, 21:08
Thanks Till, That was it still getting the same messages when i restart apache, But everything seems to be working now :)

Cheers

vk1003
25th November 2010, 11:29
hi there,

not sure if i have to post this here or as a new topic.. we have installed the centos 5.5 and installed ispconfig3 as well, mails are working perfectly for the domain we create via the ispconfig control panel and ftp is working absolutely fine showing all folders inside and uploading is smooth as well.

but the website alone is not showing up.. for what ever domain account we create it shows the apache test page only and not that of the one we uploaded on ftp..

We installed apache and everything via the ispconfig3 and nothign was manually edited.. can some one help us where the mistake is hapening to sort the same.

regards
venkat v

till
25th November 2010, 11:35
Add the ip address of the servcr under system > server ip and then select the ip in the website settings.

vk1003
25th November 2010, 11:42
hi till,

thanks for the immediate reply, we had the public ip added and were actually choosing it.. and it still wasnt loading.. i will ask my system engineer to the log error shortly on here as i think it should give some idea..


One small piece of information, i am registering domains else where and holding the dns with the domain and pointing mx, a and cname entries to this server.

regards
venkat

till
25th November 2010, 11:44
If you are in a NAT enviroment, then you have to use the private and not public IP. Public IP's are only used in dns but not in website settings.

vk1003
25th November 2010, 11:46
Yes my AIRTEL Router has NAT settings and i use that to forward the ports to my local machine which contains the linux installed..

you said we should add only the local ip .. does that mean that i should add the 192.168.1.2 ip in the ispconfig if i am on nat !! am i right

vk1003
25th November 2010, 11:49
also another issue i faced is that the :8080 was working fine when i tried accessing from a differnet connection from our office (but it was that of the same provider) and for some of friends located in different places.. the :8080 was not opening..

do we need to do anything specific for it to show up in all places over the internet ?

regards
venkat

falko
26th November 2010, 13:59
you said we should add only the local ip .. does that mean that i should add the 192.168.1.2 ip in the ispconfig if i am on nat !! am i right
If that is your local IP, then yes.

and for some of friends located in different places.. the :8080 was not opening.Some ISPs might block port 8080.

vk1003
27th November 2010, 06:04
hi the following are the main issues that i face..

1. we have installed the ispconfig and centos 5.5 and were able to add the domains .. while checking on the same server, the ispconfig login is showing up but the sites for the domains we created are not showing ... it simply keeps showing up the apache test page for all domains created in it.

2. I control the dns on the domain level. i have put the A record to point to this ip .. does this have any effect on this ?.


I am a newbie and would like to have a good explanation to help sort this out.

regards
venkat v

falko
28th November 2010, 19:08
Did you select * or a specific IP address for your web sites in ISPConfig?

vk1003
1st December 2010, 14:13
hi

thanks for all your help now i am able to get the server load different site live.. but only one issue is now before us.. for exampls www.mytranslator.in is the domain running on that server.. and the ispconfig is http://www.mytranslator.in:8080 for some it opens but for many its showing nothing.. cant we not change this port to some thing else like :2000 or :443 or :8443 like that ?

if so how to do it ?

regards
venkat

falko
2nd December 2010, 15:35
Please make sure that your firewall allows requests on port 8080.

gawry
21st July 2011, 06:17
All my domains added in the ISP config panel are pointing to the same page.

This is what i get when I restart Apache.

root@web1:/etc/apache2# /etc/init.d/apache2 restart
Restarting web server: apache2[Thu Jul 21 00:52:31 2011] [warn] NameVirtualHost 192.168.175.56:443 has no VirtualHosts
... waiting [Thu Jul 21 00:52:33 2011] [warn] NameVirtualHost 192.168.175.56:443 has no VirtualHosts


Any ideas?

till
21st July 2011, 10:15
Make sure that you selected either * or the ip address for all websites and do not mix that. If you selcted now * for all sites and get the behaviour that you described, then switch all sites to use the IP address.

gawry
21st July 2011, 22:54
I've fixed the issue but I don't know what was the cause. As it was a fresh installation I've just reinstalled everything again an it worked.

gawry
21st July 2011, 22:58
I would love to help ISP Config with a UX Redesign. I have a UX Consultancy from Brazil and I'm using for some of our servers. I think that ISP Config is great in some aspects but it lacks a better UI and some functionality.

Client templates for example could be more powerful, I had to create a manual procedure to "Add new site" to remember that emails, ftp, ssh, domains and etc need do be configured each time i add a new website