PDA

View Full Version : ISPconfig 3 r1 to r2 upgrade failed


mghens
18th February 2009, 09:46
I run a Debian 4 system. Ran the upgrade. It choked on the finish of the script when apache2 was restarted. It could not find FCGIWrapper starter script in /var

I had to restore from backup to back out.

mghens
18th February 2009, 09:48
My scroll back was not long enough, but it was this file: .php-fcgi-starter

till
18th February 2009, 10:44
You have to choose "yes" when the updater asks if you want to reconfigure the services. Also make sure that mod_php is installed as it is used for the controlpanel.

mghens
18th February 2009, 17:18
Till,

Those were enabled.

I had did what you said. I basically did defaults and yes.

What I noticed what was different between then R1 and R2

was

R1:

FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/php-fcgi-starter .php

R2:

FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php


My Apache choked on the latter.

mghens
18th February 2009, 17:24
Also, I don't have /var/www/ispconfig directory.

jcombs_31
18th February 2009, 20:30
I had the same problems with the update.

jcombs_31
20th February 2009, 03:39
Any news on this?

till
20th February 2009, 09:26
have you instellad and enabled mod_php? If not, please do it now.

mghens
20th February 2009, 11:34
Till,

mod_php is installed. It has been installed since I installed 3.0.0.8 RC1. This means that it installed for the upgrade to 3.0.0.9RC2

Against better judgment, I did a upgrade try again. I also did a script of the session. This should show the failed part. I basically had to restore ISPConfig RC1 from backup.

Script started on Fri 20 Feb 2009 12:50:12 AM PST
merlin:~/ispconfig3_install/install# ls^M
apps lib tpl uninstall.php^M
dist options.conf.php typescript update.php^M
install.php sql uninstall-fedora.php^M
merlin:~/ispconfig3_install/install# php -q update.php ^M
^M
^M
--------------------------------------------------------------------------------^M
_____ ___________ _____ __ _ ^M
|_ _/ ___| ___ \ / __ \ / _(_) ^M
| | \ `--.| |_/ / | / \/ ___ _ __ | |_ _ __ _ ^M
| | `--. \ __/ | | / _ \| '_ \| _| |/ _` |^M
_| |_/\__/ / | | \__/\ (_) | | | | | | | (_| |^M
\___/\____/\_| \____/\___/|_| |_|_| |_|\__, |^M
__/ |^M
|___/ ^M
--------------------------------------------------------------------------------^M
^M
^M
>> Update ^M
^M
Operating System: Debian 4.0 or compatible^M
^M
This application will update ISPConfig 3 on your server.^M
MySQL root password []: *****^M
^M
Reconfigure Services? (yes,no) [yes]: ^M
^M
Configuring Postfix^M
Configuring Jailkit^M
Configuring SASL^M
Configuring PAM^M
Configuring Courier^M
Configuring Spamassassin^M
Configuring Amavisd^M
Configuring Getmail^M
Configuring Pureftpd^M
Configuring MyDNS^M
Configuring Apache^M
Configuring Database^M
Configuring Firewall^M
Updating ISPConfig^M
ISPConfig Port [8080]: ^M
^M
Reconfigure Crontab? (yes,no) [yes]: ^M
^M
Updating Crontab^M
Restarting services ...^M
Stopping MySQL database server: mysqld.^M
Starting MySQL database server: mysqld.^M
Checking for corrupt, not cleanly closed and upgrade needing tables..^M
Stopping Postfix Mail Transport Agent: postfix.^M
Starting Postfix Mail Transport Agent: postfix.^M
Restarting SASL Authentication Daemon: saslauthd.^M
Stopping amavisd: amavisd-new.^M
Starting amavisd: amavisd-new.^M
Stopping ClamAV daemon: clamd.^M
Starting ClamAV daemon: clamd .^M
Stopping Courier authentication services: authdaemond.^M
Starting Courier authentication services: authdaemond.^M
Stopping Courier IMAP server: imapd.^M
Starting Courier IMAP server: imapd.^M
Stopping Courier IMAP-SSL server: imapd-ssl.^M
Starting Courier IMAP-SSL server: imapd-ssl.^M
Stopping Courier POP3 server: pop3d.^M
Starting Courier POP3 server: pop3d.^M
Stopping Courier POP3-SSL server: pop3d-ssl.^M
Starting Courier POP3-SSL server: pop3d-ssl.^M
Warning: DocumentRoot [/var/www/ispconfig/] does not exist^M
Syntax error on line 20 of /etc/apache2/sites-enabled/000-ispconfig.vhost:^M
can't get fastcgi file info: /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter, errno: 2^M
Forcing reload of web server (apache2)... waiting ^[[31mfailed!^[[39;49m^M
Restarting ftp server: Running: /usr/sbin/pure-ftpd-mysql -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -A -b -H -u 1000 -E -O clf:/var/log/pure-ftpd/transfer.log -B^M
Update finished.^M
merlin:~/ispconfig3_install/install# exit^M

Script done on Fri 20 Feb 2009 12:51:08 AM PST

Adien
20th February 2009, 19:11
I had allready the same problem.
I solved it by create the directorys:
var/www/php-fcgi-scripts/ispconfig
var/www/ispconfig

and copy the file php-fcgi-starter.master from
ispconfig3_install/server/conf
to
var/www/php-fcgi-scripts/ispconfig

and rename it to php-fcgi-starter.

mghens
20th February 2009, 22:51
Thanks!

That did the trick.

I had two more edits beyond your recommendations.

The upgrade added an extra port 443 /etc/apache2/ports.conf.

Also I had to change:

FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php

to

FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/php-fcgi-starter .php

in /etc/apache2/sites-available/ispconfig.vhost

jcombs_31
21st February 2009, 23:55
I just don't understand why the update made these changes but not the correct actions to fix it? Will this be addressed Till?

guardian
22nd February 2009, 10:59
I have exactly the same problem.

till
22nd February 2009, 13:03
I will take a look at this if a modification for the next updates is needed.

@guardian: the fix for the problem is lareday mentioned in the thread.