PDA

View Full Version : Cannot login to ISPConfig3


gcambull
29th January 2009, 22:47
Not sure what happened, I had it running ok earlier, then when I tried to enable the mail settings it locked up, so I reboot the server. Now I try to login in and it says it cannot find it, says unable to establish connection.??

gcambull
29th January 2009, 23:01
ok I went to server and typed: netstat -tap and I didnt see the httpd on, so I tried to restart and it gave me failure stating that syntax was wrong in line 37 of /etc/httpd/conf/sites-enabled/xxx.com.vhosts, invalid command "FCGIWrapper" perhaps misspelled or define by a module not included in server config.

till
30th January 2009, 12:51
This means that you selceted fcgi for php in thatw ebsite but missed to install mod_fcig in your apache server. To fix this, install mod_fcgi from your linux distribution.

gcambull
30th January 2009, 20:48
Thanks Till,

I am working with CentOS 5.2 and am noobie at it. how would I go about aquiring and installing the mod_fcgi? I tried the yum install mod_fcgi but that didnt work, then did a search for it and found it at the sourceforge.net and downloaded on my regular PC, but how do I get it to the server (text based)?

Thanks for the help.

till
30th January 2009, 21:42
Try:

yum search fcgi

to find the name of the centos package that has to be installed.

gcambull
30th January 2009, 21:59
Till, the result was:

lighttpd-fastcgi.i386
perl-fcgi-async.noarch
perl-fcgi-procmanager

I did find the mod_fcgid at http://journal.paul.querna.org/articles/2006/01/01/using-mod_fcgid-for-ruby-on-rails-applications./ and am wondering if I can follow those directions but with the newest version of mod_fcgid or should I do something else?

Well the link for the mod_fcgid wont work because I still need to find the file..

falko
31st January 2009, 14:59
I've written a tutorial about this yesterday which I will publish in a few days. Here's an excerpt:

mod_fcgid is not available in the official CentOS repositories, but there's a package for CentOS 5.x in the centos.karan.org testing repository. We enable the repository as follows:

cd /etc/yum.repos.d/
wget http://centos.karan.org/kbsingh-CentOS-Extras.repo

Next we open /etc/yum.repos.d/kbsingh-CentOS-Extras.repo...

vi /etc/yum.repos.d/kbsingh-CentOS-Extras.repo

... and set gpgcheck to 0 and enabled to 1 in the [kbs-CentOS-Testing] section:

[...]
[kbs-CentOS-Testing]
name=CentOS.Karan.Org-EL$releasever - Testing
gpgcheck=0
gpgkey=http://centos.karan.org/RPM-GPG-KEY-karan.org.txt
enabled=1
baseurl=http://centos.karan.org/el$releasever/extras/testing/$basearch/RPMS/

Afterwards we can install Apache2, mod_fcgid, and PHP5:

yum install httpd mod_fcgid php-cli

gcambull
1st February 2009, 19:48
Falko,

Sorry it took me a while to reply. This is good news, when will the tut be ready to read, or is that the whole enchilada.

I have since re-installed CentOs 5.2 to the whole hd, since I couldnt do anything about the wipeout I did with enabling fastcgi, when I didnt even have that installed. Maybe there should have been a small do not...in the how to, after all i am a noob and us noobs tend to push buttons that we shouldnt push, hah reminds me of when I was training BigTruck driver noobs, they would touch a button/switch and I would yell NO! LMAO

anyways, I didnt have too many errors re-installing ISPConfg3, though I will post them in a new thread, or search first.

Thanks

falko
2nd February 2009, 13:13
This is good news, when will the tut be ready to read

In a few days. :) But my previous post shows how you can install mod_fcgid on CentOS.