PDA

View Full Version : Empty mails after update to 2.0.7


maxx
16th August 2005, 14:55
After update I get totally empty emails from time to time to my email account. Sender, receiver, subject and body are all empty, what is this?

- Maxx

till
16th August 2005, 15:06
After update I get totally empty emails from time to time to my email account. Sender, receiver, subject and body are all empty, what is this?

- Maxx

There is nothing updated in this part of the software. Try to disable mailscan.

http://www.howtoforge.com/forums/showthread.php?t=261

maxx
17th August 2005, 14:33
There is nothing updated in this part of the software. Try to disable mailscan.

http://www.howtoforge.com/forums/showthread.php?t=261

Took spam, av, mailscan off.
Put it back on.. Still have this problem so I cant use them now. And this happened after update.

- Maxx

till
17th August 2005, 14:41
Took spam, av, mailscan off.
Put it back on.. Still have this problem so I cant use them now. And this happened after update.

- Maxx

Deactivate only mailscan as described in the other posts not spamfilter and antivirus.

maxx
17th August 2005, 21:12
Deactivate only mailscan as described in the other posts not spamfilter and antivirus.

Did that. It comes from spamfilter or antivirus. Havent tested that yet.

till
18th August 2005, 10:42
Did that. It comes from spamfilter or antivirus. Havent tested that yet.

Ok, please try this, if it is spamassassin that makes these errors:

SpamAssassin

The ISPConfig comes with SpamAssassin, but without the Perl modules needed by
SpamAssassin. Run the following command after the installation of the ISPConfig:

/home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamassassin

If errors appear you have to install some Perl modules.

perl -MCPAN -e shell
install HTML::Parser
install DB_File
install Net::DNS (when prompted to enable tests, choose "no")
install Digest::SHA1

To leave the Perl shell type

q

If

/home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamassassin

does not return any error everything is fine. You can then leave SpamAssassin by typing
" CTRL + c".

maxx
19th August 2005, 10:28
Ok, please try this, if it is spamassassin that makes these errors:

SpamAssassin

The ISPConfig comes with SpamAssassin, but without the Perl modules needed by
SpamAssassin. Run the following command after the installation of the ISPConfig:

/home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamassassin

If errors appear you have to install some Perl modules.

perl -MCPAN -e shell
install HTML::Parser
install DB_File
install Net::DNS (when prompted to enable tests, choose "no")
install Digest::SHA1

To leave the Perl shell type

q

If

/home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamassassin

does not return any error everything is fine. You can then leave SpamAssassin by typing
" CTRL + c".


When I did /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamassassin
it doesnt say or do anything.. or report any errors. So i guess its okay.

- Maxx

Now I found out. Its the antivirus that does this problem. Can I fix somehow?

- Maxx

brt
17th March 2008, 14:53
Now I found out. Its the antivirus that does this problem. Can I fix somehow?



same problem here, totally empty emails, no sender, no subject, no mailheaders (!?)

how did you know it has something to do with antivirus ?

falko
18th March 2008, 15:58
Any errors in your mail log? Have you tried to disable Mailscan and/or Antivirus in ISPConfig?

brt
18th March 2008, 17:07
yes the problem still exists when Mailscan is disabled, and no there are no errors in the mail-log.

a quick comparison of date/time of an empty email with the logfile showed that at this moment no email was incoming at all. all i could see in the maillog at this time was popfetching of this client.

falko
19th March 2008, 15:10
Do these emails arrive at fixed times, or do they come randomly? I'm thinking it might be a cron jog or some other process that's sending them...

brt
27th March 2008, 13:37
the email-file is empty:
-rw------- 1 office1 web11 0 2008-03-27 12:43:56.000000000 +0100 /var/kunden/web11/user/office1/Maildir/new/1206618236.19315_0.nibbler

but there was an email incoming at this time:

Mar 27 12:43:50 localhost postfix/cleanup[19207]: 775FB4B46F: message-id=<25A78EEF.D000CAD3@*****.com>
Mar 27 12:43:50 localhost postfix/qmgr[4917]: 775FB4B46F: from=<****@****.com>, size=57728, nrcpt=1 (queue active)
Mar 27 12:43:56 localhost postfix/local[19209]: 775FB4B46F: to=<office1@mail.*****.com>, orig_to=<****@****.com>, relay=local, delay=5.5, delays=0.09/0/0/5.5, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
Mar 27 12:43:56 localhost postfix/qmgr[4917]: 775FB4B46F: removed

and yes, mailscan is disabled.

this is the .procmailrc for this user:

MAILDIR=$HOME/Maildir/
DEFAULT=$MAILDIR
ORGMAIL=$MAILDIR

INCLUDERC=/var/kunden/web11/user/office1/.mailsize.rc
## INCLUDERC=/var/kunden/web11/user/office1/.quota.rc
INCLUDERC=/var/kunden/web11/user/office1/.antivirus.rc
## INCLUDERC=/var/kunden/web11/user/office1/.local-rules.rc
## INCLUDERC=/var/kunden/web11/user/office1/.html-trap.rc
INCLUDERC=/var/kunden/web11/user/office1/.spamassassin.rc
## INCLUDERC=/var/kunden/web11/user/office1/.autoresponder.rc
# ***SPAM*** -> SPAM Ordner
:H
* Subject:.*\*\*\*SPAM\*\*\*.*
$MAILDIR.SPAM/


hmmm, the users already get confused,
how can they be sure that they recieve all emails?

falko
28th March 2008, 14:14
I see that you've disabled the user prefixes (e.g. web1_...). Maybe this is the problem?