PDA

View Full Version : suse 92 and apache for ispconfig


mrh
15th August 2005, 21:10
i fallow the suse 9.2 perfect setup for isp config but i had this error when i want to start my apache..


linux:/etc/postfix/ssl # /etc/init.d/apache2 start
Starting httpd2 (prefork) Syntax error on line 11 of /etc/apache2/mod_log_config.conf:
Invalid command 'LogFormat', perhaps mis-spelled or defined by a module not included in the server configuration

The command line was:
/usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -DSSL failed


and this error in starting proftpd:


vserver1:~ # /etc/init.d/proftpd start
/etc/init.d/proftpd: line 1: nit.d/proftpd: No such file or directory
Starting ProFTPD Server: - getaddrinfo 'server1.example.com' error: Name or service not known
- warning: unable to determine IP address of 'server1.example.com'
- error: no valid servers configured
- Fatal: error processing configuration file '/etc/proftpd.conf'
startproc: exit status of parent of /usr/local/sbin/proftpd: 1
failed



can any one help me?

falko
15th August 2005, 21:30
You should have a look at /etc/apache2/mod_log_config.conf (line 11). There's a syntax error, or your Apache is missing some module. But you can also disable mod_log_config.conf in your main Apache configuration.

vserver1:~ # /etc/init.d/proftpd start
/etc/init.d/proftpd: line 1: nit.d/proftpd: No such file or directory
Starting ProFTPD Server: - getaddrinfo 'server1.example.com' error: Name or service not known
- warning: unable to determine IP address of 'server1.example.com'
- error: no valid servers configured
- Fatal: error processing configuration file '/etc/proftpd.conf'
startproc: exit status of parent of /usr/local/sbin/proftpd: 1
failed

How did you save /etc/init.d/proftpd when you copied it from the howto? Did you use Unix line breaks or Windows line breaks? You should use Unix line breaks.
Also, server1.example.com was meant as an example in the howto, it doesn't exist in the "real" world. You should have replaced it with your own hostname.

mrh
15th August 2005, 22:25
i go to the /etc/apache2/mod_log_config.conf and put a # for all of lines start with LogFormat....
i saw a error for other files the where about "log"
how can i reinstall apache module for "log"ing??????