PDA

View Full Version : Postfix Problem / Question


ccix
25th February 2006, 23:54
I keep seeing this error in auth.log I've read the other threads about this issue and didn't see a way to solve it. I've double checked all my config files from the debian 3.1 how to.

Here's what it shows over and over again every few minutes. Any ideas? Thanks

Eric


Feb 25 14:21:10 ns postfix/smtpd[7773]: sql_select option missing
Feb 25 14:21:10 ns postfix/smtpd[7773]: auxpropfunc error no mechanism available
Feb 25 14:21:10 ns postfix/smtpd[7773]: _sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: sql
Feb 25 14:24:10 ns postfix/smtpd[7789]: sql_select option missing
Feb 25 14:24:10 ns postfix/smtpd[7789]: auxpropfunc error no mechanism available
Feb 25 14:24:10 ns postfix/smtpd[7789]: _sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: sql
Feb 25 14:30:35 ns postfix/smtpd[7793]: sql_select option missing
Feb 25 14:30:35 ns postfix/smtpd[7793]: auxpropfunc error no mechanism available
Feb 25 14:30:35 ns postfix/smtpd[7793]: _sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: sql
Feb 25 14:30:53 ns postfix/smtpd[7808]: sql_select option missing
Feb 25 14:30:53 ns postfix/smtpd[7808]: auxpropfunc error no mechanism available
Feb 25 14:30:53 ns postfix/smtpd[7808]: _sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: sql
Feb 25 14:33:44 ns postfix/smtpd[7814]: sql_select option missing
Feb 25 14:33:44 ns postfix/smtpd[7814]: auxpropfunc error no mechanism available
Feb 25 14:33:44 ns postfix/smtpd[7814]: _sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: sql
Feb 25 14:35:45 ns postfix/smtpd[7820]: sql_select option missing
Feb 25 14:35:45 ns postfix/smtpd[7820]: auxpropfunc error no mechanism available
Feb 25 14:35:45 ns postfix/smtpd[7820]: _sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: sql
Feb 25 14:35:49 ns postfix/smtpd[7831]: sql_select option missing
Feb 25 14:35:49 ns postfix/smtpd[7831]: auxpropfunc error no mechanism available
Feb 25 14:35:49 ns postfix/smtpd[7831]: _sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: sql

falko
26th February 2006, 17:53
Which tutorial are you referring to (URL)?

Did you have a look at this thread? http://www.howtoforge.com/forums/showthread.php?t=861

ccix
26th February 2006, 23:36
I took a look at everything in that thread and made a few changes. One was linking the directory for the .pid file which made restarting sasl work fine. I also checked the other file listed at the end of the thread, tried it both ways listed and still received this.


Feb 26 14:33:53 ns saslauthd[17727]: server_exit : master exited: 17727
Feb 26 14:33:54 ns saslauthd[17933]: detach_tty : master pid is: 17933
Feb 26 14:33:54 ns saslauthd[17933]: ipc_init : listening on socket: /var/spool/postfix/var/run/saslauthd/mux
Feb 26 14:34:08 ns postfix/smtpd[17939]: sql_select option missing
Feb 26 14:34:08 ns postfix/smtpd[17939]: auxpropfunc error no mechanism available
Feb 26 14:34:08 ns postfix/smtpd[17939]: _sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: sql


Sasl starts fine but still gets that error in the log file. Any other ideas?

falko
27th February 2006, 01:07
What's in your /etc/pam.d/smtp?

ccix
27th February 2006, 07:50
ns:~# cat /etc/pam.d/smtp
auth required pam_mysql.so user=mail_admin passwd=abcd1234 host=127.0.0.1 db=mail table=users usercolumn=email passwdcolumn=password crypt=1
account sufficient pam_mysql.so user=mail_admin passwd=abcd1234 host=127.0.0.1 db=mail table=users usercolumn=email passwdcolumn=password crypt=1


I'm going to recheck step by step on the how to's ...do i need to do the Debian sarge (all 5 pages?) and then use all the mysql-postfix-etc setup also? Sorry i didn't use exact names, only have a second to reply before i nee to leave. Let me know about the above.

Eric

falko
27th February 2006, 10:30
do i need to do the Debian sarge (all 5 pages?) and then use all the mysql-postfix-etc setup also?
No, just the basic Debian installation (the first two pages of the "Perfect Setup" for Debian Sarge).

ccix
27th February 2006, 12:23
Another note, i'm NOT using ISPConfig. I'll compare my settings again but when i looked earlier i couldn't find anything offset.

Thanks

If you have any other ideas...let me know.

Peter Murfy
1st April 2010, 19:03
Removing libsql from the /usr/lib/sasl2 directory solved my problem.

Peter

Found it here:
http://marc.info/?l=postfix-users&m=118062660123427

King Sami
3rd April 2010, 12:39
I'm sorry to post this in sendmail forum topic because i did't see such as postfix forum.

I'm a newbie with linux
I using Redhat 9.0 and postfix program.