PDA

View Full Version : ISPConfig 3.0.0.7 Beta released


till
21st September 2008, 20:15
ISPConfig 3.0.0.7 Beta is available for download. This release is
for testing only, it is not for production use.

ISPConfig 3 is a new Hosting Control Panel rewritten from scratch. ISPConfig 3
is not a direct update for ISPConfig 2. Do not install it on a ISPConfig 2 server.


Features of ISPConfig 3 compared to ISPConfig 2
-----------------------------------------------------

- Support for virtual mail users
- Support for virtual FTP Users
- Support for multiple Servers
- Support for splitting of services to multiple servers
(Database, web, FTP and DNS can be on different servers).


Download
-----------------------------------------------------

The software itself can be downloaded here:

http://www.ispconfig.org/downloads/ISPConfig-3.0.0.7-beta.tar.gz

ISPConfig 3.0.0.7 Beta is also available as ready to run VMWare virtual
machine based on Ubuntu 8.04 (Jeos).

Download of the VMWare image:

http://www.ispconfig.org/downloads/ISPConfig_3.0.0.7_ubuntu_jeos_804.zip (approx. 600 MB)

When you run the vmware image the first time you will be asked to keep
or create a MAC address. Select "keep", otherwise the networking wont work.

The root password of the VM is set to "ispconfig", the IP address is
192.168.0.105 and has to be reconfigured in /etc/network/interfaces
to meet your network requirements. The ISPconfig Interface login is:

http://192.168.0.105:8080/

User = admin
Password = admin.


Changes:
--------------------------------------

- Added support for openSUSE 11.0
- Added support for Fedora 9
- Added support for CentOS 5.2
- Added russian translation.
- Updated Dutch language files. Many thanks to Hans for the translation.
- Addad a function to disable poip3 and imap per user account.
- Disabled spam and virus notifications for the admin user. Can be overridden by the policies in mysql.
- Added a keepalive script to keep the session alive as long as the browser window is open.
- Added a tools module.
- Added a form to change the language and password of the current user.
- Added translation functions for the tabs of forms.
- Network Configuration through the ISPConfig interface for debian and compatible linux distributions.
- Disabled suphp_UserGroup directive by default to make the setup compatible with the suphp compile options from most linux distributions. If you want some extra security, enable this directive again and recompile mod_suphp with the the option --with-setid-mode=paranoid
- Users can reset their login password now. The password is sent by email to the email address listed in the client account settings.


- Many bugs were fixed, see bugtracker:

http://bugtracker.ispconfig.org/index.php?string=&project=3&due[]=12&status[]=closed&do=index


For a detailed changelog, please have a look at the SVN history with a SVN client of your choice:

svn://svn.ispconfig.org/ispconfig3/trunk/


Known Issues:
--------------------------------------

Please have a look at the bugtracker:

http://bugtracker.ispconfig.org


BUG Reporting
--------------------------------------

This is a Beta release and we invite everone to report bugs. Bugs can be either reported
in the ispconfig forum (preferaböe to this forum thread) or you sign up for a account
in the ISPConfig bugtracking system and sent a email to dev[at]ispconfig[dot]org with your
bugtracker username and and the request to activate your user. Due to massive SPAM problems
we had to dectivate the automatic activation of bugtracker accounts.


Supported Linux Distributions
-----------------------------
- Debian 4.0 (Etch).
- Ubuntu 7.10
- Ubuntu 8.04
- OpenSuSE 11 (experimental)
- CentOS 5.2 (experimental)
- Fedora 9 (experimental)


Installation
--------------------

The installation instructions for ISPConfig can be found in the text files (named INSTALL_*.txt)
which are inside the ISPConfig-3.0.0.7-beta.tar.gz file.


Update
--------------------

To update existing ISPConfig 3 installations, run these commands on the shell:

cd /tmp
wget http://www.ispconfig.org/downloads/ISPConfig-3.0.0.7-beta.tar.gz
tar xvfz ISPConfig-3.0.0.7-beta.tar.gz
cd ispconfig3_install/install
php -q update.php
rm -rf /tmp/ispconfig3_install
rm -f ISPConfig-3.0.0.7-beta.tar.gz

Snowman
21st September 2008, 22:06
ISPConfig 3.0.0.7 Beta is available for download.
lol, all tickets are closed ?
Can i ask you what else will be included in the ISPC3 ?

Hans
21st September 2008, 23:32
Thanks for the new release and update instructions.
I will try to update from 3.0.0.6 beta to 3.0.0.7 beta later on this week.

till
22nd September 2008, 00:58
lol, all tickets are closed ?

And sure the tickets are closed on finished finished tasks ;)

Can i ask you what else will be included in the ISPC3 ?

Go to the bugtracker and click on the roadmap :)

Snowman
22nd September 2008, 01:33
And sure the tickets are closed on finished finished tasks
Go to the bugtracker and click on the roadmap :)

thanks :) nice work at all.
But I still the idea of that mysql on ispc3 should use ssl to communicate between nodes. By default.

NIXin
22nd September 2008, 02:02
The VMWare image is using a non-standard keyboard layout (german), is there a quick way to switch it back to US standard?

Best regards,
NIXin

till
22nd September 2008, 10:59
The VMWare image is using a non-standard keyboard layout (german)

I wont call it "non-standard", for germans this is the standard keyboard layout :) But of course for other countries, change the keyboard as described here:

http://www.howtoforge.com/changing-language-and-keyboard-layout-on-various-linux-distributions

NIXin
22nd September 2008, 14:47
I wont call it "non-standard", for germans this is the standard keyboard layout :) But of course for other countries, change the keyboard as described here:

http://www.howtoforge.com/changing-language-and-keyboard-layout-on-various-linux-distributions
Yup, but this is english speaking community, so the vmware image should be english by default too ;)

Fortunately I figured out where the dash "-" sign is.

But I can't seem to be able to change the keyboard layout - when I try "dpkg-reconfigure console-data" get an error saying "console-data" is not installed.
I can't install console-data either, cause network isn't configured. And there is no nano or mcedit, and since I have no idea how the german layout looks I couldn't possibly use vi. So I'm stuck - with no internet access, not default keyboard layout that I can't change w/o internet and unable to edit /etc/network/interfaces... :(

EDIT:
I managed to get internet connectivity, by using the windows on-screen keyboard to type: cat > /etc/network/interfaces and change the default interface to DHCP.
So I installed console-data, configured it to qwerty/English. It didn't change a thing. I even added another user to see if the changes may reflect only new users. Nope. Both root and my user still use the German layout.

EDIT2:
dpkg-reconfigure console-setup (the step described for Ubuntu) worked. It actually had to recreate the initrd image. o_O

till
22nd September 2008, 15:06
Yup, but this is english speaking community, so the vmware image should be english by default too

No Problem. I will release the VM in future only for the german community and you can build the vm for the english community yourself :)

And there is no nano or mcedit, and since I have no idea how the german layout looks I couldn't possibly use vi.

Google search: German keyboard Layout

http://carbon.cudenver.edu/~tphillip/german-keyboard-a.jpg

snoke
22nd September 2008, 16:02
I was testing the new version of ispconfig 3 and liked a lot, the system seems very fast, has not yet had an opportunity to test load. However I think it might be improved in terms of design. I'am a Web Designer and I am willing to work on this project. I can develop a template for the ispconfig with improvements in usability of the entire control panel and improments in look and feel.

I trust and i like ISPCONFIG! :)

till
22nd September 2008, 16:07
I new theme would be great indeed :)

All Theme related files are in /usr/local/ispconfig/interface/web/themes/

Make a copy of the default folder and name it e.g. newtheme and then edit the files within this folder. The current theme is just a "developer" version based on old style tables and not div / css and should be replaced until the final version.

If you have any questions, either post them in the devlopment forum or send me a pm.

NIXin
22nd September 2008, 17:49
No Problem. I will release the VM in future only for the german community and you can build the vm for the english community yourself :)
If you think so ;)

Google search: German keyboard Layout

http://carbon.cudenver.edu/~tphillip/german-keyboard-a.jpg
Well, it's not that I didn't google it - I did, and found exactly the same image as you. The thing is, that I don't know it and, also, I don't have one key that was needed. That's the ">" key, next to Left Shift. That's why I had to use the On-Screen Keyboard.

Cheers,
NIXin

PS
I'm currently translating the ISPConfig 3 to Polish. :)

FallenDevil
22nd September 2008, 20:20
I have downloaded the Ubuntu VM for ISP 3, but am unable to use the networking!! i have set my keymap to my local, but according to the download page for the VM, it says on initial boot the VM should ask to change or keep the MAC address of the network - mine has not asked this. :eek: and the networking says no valid networks found. Even if i set it to DHCP in networking.

Any pointers appreciated.

till
23rd September 2008, 00:20
I have downloaded the Ubuntu VM for ISP 3, but am unable to use the networking!! i have set my keymap to my local, but according to the download page for the VM, it says on initial boot the VM should ask to change or keep the MAC address of the network - mine has not asked this. :eek: and the networking says no valid networks found. Even if i set it to DHCP in networking.

Any pointers appreciated.

Two solutions:

1) Look into the documentation of the vmware softeware taht you use and make disable the automatic assignment of new MAC addresses on the first boot. Then delete the vm folder, unpack ita agin and start it.

2) Or try this in the VM:

http://episteme.arstechnica.com/eve/forums/a/tpc/f/96509133/m/720008741831?r=388009302831#388009302831

till
23rd September 2008, 00:46
Additional note to solution 2), to fix the problem with the changed network card, you can try this:

rm -f /etc/udev/rules.d/70-persistent-net.rules
/etc/init.d/udev restart

mphayesuk
23rd September 2008, 14:45
Hi all, I know this is a pretty stupid question and should be met with a response of "how long is a piece of string" but roughly when will there be a full production release of v3. I am going to be moving all my customers to a dedicated server in a datacentre and would prefer to wait until v3 is out so that I am only changeing my customers data once.

Thanks everyone for the hardwork on v2 and v3.

Martin

FallenDevil
23rd September 2008, 17:35
Additional note to solution 2), to fix the problem with the changed network card, you can try this:

rm -f /etc/udev/rules.d/70-persistent-net.rules
/etc/init.d/udev restart

Thanks for the reply Till, I could not use the link to the other site as i do not have /etc/iftab on my system.
However after running the above command and editing the persistant-net.riles to change the eth back to eth0 from eth1 - then rebooted and my adapter now has the pre defined 192.168.0.105 although i am unable to browse the site from my local machine.

Wojtek1
23rd September 2008, 18:00
Hi !
All websites in /var/clients is in client0 directory, no matter which client of 'client list' from panel own it ... is this normal behavior?
Second question: my panel don't create symlinks domain_name -> web[x] in /var/clients/client0/ , any sugestion ?
Future Request: perhaps client could use different location of web directory ?
Structure like this: /var/clients/client_name/all_of_its_websites{domanin1, domain2 ...}/
This feature will foster searching particular client if webserver will be used for hosting business.

Best regards!

pgedeon
24th September 2008, 04:38
that didint work for me,

to change the keybord layout i did this

####
sudo dpkg-reconfigure console-setup
####

had a bit of a problem with the network config, ubuntu renamed my network interface to eth1 from eth0 so to fix it all i had to do was
edit /etc/network/interfaces to look something like this

####
auto eth1
iface eth1 inet dhcp
####
**make sure you are on vmwares bridged networking other wise it will not be able to connect to outside networks**

then i decided to install a desktop so i can play.


####
sudo apt-get update && sudo apt-get install xorg

sudo aptitude update && sudo aptitude install kubuntu-desktop
####


Two solutions:

1) Look into the documentation of the vmware softeware taht you use and make disable the automatic assignment of new MAC addresses on the first boot. Then delete the vm folder, unpack ita agin and start it.

2) Or try this in the VM:

http://episteme.arstechnica.com/eve/forums/a/tpc/f/96509133/m/720008741831?r=388009302831#388009302831

till
24th September 2008, 09:35
Hi !
All websites in /var/clients is in client0 directory, no matter which client of 'client list' from panel own it ... is this normal behavior?

No, thats not normal.

Second question: my panel don't create symlinks domain_name -> web[x] in /var/clients/client0/ , any sugestion ?

No. You may post it to the bugtracker and I will have a look at it in the next days http://bugtracker.ispconfig.org

Future Request: perhaps client could use different location of web directory ?

He can do that already.

Structure like this: /var/clients/client_name/all_of_its_websites{domanin1, domain2 ...}/
This feature will foster searching particular client if webserver will be used for hosting business.

We will not implement it like this because renaming of a client would change thte path. We create symlinks for the websites and maybe we add a symlink for the client name too.

Best regards!

Wojtek1
24th September 2008, 11:37
No, thats not normal.
No. You may post it to the bugtracker and I will have a look at it in the next days http://bugtracker.ispconfig.org


I can't ... don't heave rights to add new task :(

He can do that already.

Maybe this is stupid question, but how ?

soho
30th September 2008, 05:57
Following the recommendations of the file INSTALL_UBUNTU_8.04.TXT is requested:

First we have to make sure that the capability module is loaded in the kernel

modprobe capability
echo 'capability' >> /etc/modules"

But setting on my server (clean (fresh) Ubuntu Server 8.04LTS) the message is:

FATAL: Module capability not found.

How to solve this?

Best regards,

till
30th September 2008, 10:12
You can ignore this if there is no capability module.

mlz
8th October 2008, 03:14
Has anyone else had problems getting the named virtuals working under Ubuntu 8.04? I've installed twice thinking I missed a step and each time one site comes up, but not any of the rest (everything shows the same site)

till
8th October 2008, 08:25
What do you mean with named virtuals? ISPCOnfig 3 supports only mydns and mydns-ng as dns server.

mlz
8th October 2008, 14:41
I'm referring to apache. The only site that shows up is the default Ubuntu site, the NameVirtuals do not come up with the domain name. I have set up 2 sites. If I remove the ubuntu default site, then one vitual comes up, but not the other.

till
8th October 2008, 15:07
Please try to select '*' in the IP field of the site.

Hans
8th October 2008, 18:30
Hi Till,

Sorry for my late reply, but i want you to know that the update from the previous beta version to this one went fine.

Today, i've updated the Dutch language fileset for ISPConfig 3.0.0.7 Beta.
The Dutch language fileset is an exact translation of the English language file set an can be imported into ISPConfig 3 by using the Import language funcion within the Language editor.

The new Dutch language fileset is available here (http://ispconfig.bb-hosting.org/uk/downloads.htm). :)

Kind regards,

mlz
9th October 2008, 20:59
Please try to select '*' in the IP field of the site.

That's the only selection available, since I didn't add an IP. However I lost the power supply on that machine last night, so it'll be a week or so before I can work on it again, have to wait for a new PS to come in :(

zoltan
15th October 2008, 15:14
Hello Till,

is it possible to get mailman into 3.0.0.7?

thanks
Zoltan

till
15th October 2008, 15:17
ISPConfig 3.0.0.7 does not support mailman and it is currently not planned to support mailman in the final version. Mailman support might be added in a later version.

zoltan
15th October 2008, 18:04
Ok, thanks.
Does that mean you will not integrate a mailing list management in general?

till
15th October 2008, 18:08
Does that mean you will not integrate a mailing list management in general?

It is not planned to integrate a mailing list manager at the moment. Feel free to do it if you need this feature :)

Explizite
21st October 2008, 10:31
I've been following the installation guideline on Ubuntu8.04 when I've got into a problem that I can't connect to the MySQL database. I've tried to install all of the services from the start, but the same result was there - can't connect to the database using the mysql root password provided during the installation. Any help on this one please?

falko
22nd October 2008, 13:52
What's the exact error message?
What's the output of netstat -tap?

Eagle
23rd October 2008, 22:41
Hello.
Does ISPconfig 3.x support for Mandriva 2009 x86_64?

stanman
27th October 2008, 00:56
What if i wanted to go an run 3.n.n., but i already have sites on a 2.n.n. ispconfig box? How difficult will it be to 'upgrade'?

(have just finished a ispconfig 2 migration from a physical server into an openvz container)

till
27th October 2008, 09:08
ISPConfig 2 and 3 are completely different software packages. It is not possible to do an upgrade. We might offer a migration script later, but this will require always a complete reinstallation of the server.

stanman
27th October 2008, 09:45
ok, i'll keep on running 2 for the time being.

AlArenal
28th October 2008, 21:13
Got a question for those who already tried out ISPC3.

I just rented a new server (dual quadcore, 8 gigs RAM, ...) and now I'm thinking about whether or not I should stick with ISPC2 or give ISPC3 a go.

The server is going to host only a handful of sites which are meant to be busy. Customers would not want to configure something by themselves, so I will be the only one to use ISPC.

I KNOW it is still beta and some stuff is missing, but would you from your experience say I can do it without running myself into real trouble?

Thanks for sharing your thoughts.


Regards,
al

quentusrex
30th October 2008, 00:58
I currently need the features that ISPConfig 3 is offering. How do I get involved to help speed up the release?

quentusrex
31st October 2008, 06:58
Alarenal, while I have to make the disclaimer that ISPConfig3 is still in beta, and is not meant to be on a production server yet.

I would say that if you use the SVN install method, and you get a bugtracker account to submit bugs and feature requests, and you update your installation often(daily hopefully, weekly would work too); then I think it could be done. I'm running a few sites on it right now. There are limitations, but they are being fixed.

The more active you are involved, the easier it will be to run the beta software as production.

Got a question for those who already tried out ISPC3.

I just rented a new server (dual quadcore, 8 gigs RAM, ...) and now I'm thinking about whether or not I should stick with ISPC2 or give ISPC3 a go.

The server is going to host only a handful of sites which are meant to be busy. Customers would not want to configure something by themselves, so I will be the only one to use ISPC.

I KNOW it is still beta and some stuff is missing, but would you from your experience say I can do it without running myself into real trouble?

Thanks for sharing your thoughts.


Regards,
al

almas
3rd November 2008, 06:34
Hello,
Firstly I'm sorry for my English is not good. :(

I'm using ispconfig 3 beta now. I love it :)
I have problem with add new MySQL database. Adding MySQL database completed ok in ISPConfig control panel. But trying to connect to database with new database user login is cannot complete to phpMyadmin. (#1045 - Access denied for user 'reklam'@'localhost' (using password: YES))

Question 1. How could I solve this problem?

Question 2. Can I add one ore more Databases to one mysql database user?

:rolleyes: Thank you!

astewart
3rd November 2008, 16:44
Hello,
Firstly I'm sorry for my English is not good. :(

I'm using ispconfig 3 beta now. I love it :)
I have problem with add new MySQL database. Adding MySQL database completed ok in ISPConfig control panel. But trying to connect to database with new database user login is cannot complete to phpMyadmin. (#1045 - Access denied for user 'reklam'@'localhost' (using password: YES))

Question 1. How could I solve this problem?

Question 2. Can I add one ore more Databases to one mysql database user?

:rolleyes: Thank you!

I had the same problem. Log in as Root into phpmyadmin and click on "Privileges". You will see the created DB user here, change the 'Host' from '%' to Localhost. You should be able to login with that account after that.

almas
3rd November 2008, 17:01
There is no user created :( ? Maybe its my system problem... It was ok... ???
Do ISPConfig update automatically?

till
3rd November 2008, 17:15
I had the same problem. Log in as Root into phpmyadmin and click on "Privileges". You will see the created DB user here, change the 'Host' from '%' to Localhost. You should be able to login with that account after that.

Why do you do this in phpmyadmin? There is a checkbox for that in the database settings in ISPConfig 3.

till
3rd November 2008, 17:15
There is no user created :( ? Maybe its my system problem... It was ok... ???
Do ISPConfig update automatically?

ISPConfig is not updating itself automatically.

almas
3rd November 2008, 17:36
Thank you for your reply. :D OK I think that its my system problem. I can't create database users. I created database in ISPConfig. database is created ok. But database users didn't created. There was no error reported in ISPConfig. Can you help me.

till
3rd November 2008, 17:42
Did you change the mysql root passowrt or any permissions of the mysql root user?

almas
3rd November 2008, 17:50
No I didn't change anything. root user has ALL PRIVILEGES and its old password.

quentusrex
3rd November 2008, 17:58
I've seen an issue with this before. Log into phpmyadmin with root, then check in the privledges area. Does the new user have two entries? one for all hosts, and the other for localhost?

almas
3rd November 2008, 18:53
No. new user have one entry with all hosts (%).

quentusrex
3rd November 2008, 18:55
Alright, change that to local host. Then see if that fixes it.

almas
3rd November 2008, 19:03
ok. thank you. Now it can login. But remote access is disabled :( I want to create that by ISPConfig... I think that I must reinstall mysql and ISPConfig... ?

quentusrex
3rd November 2008, 19:22
No, you don't need to reinstall. This is a bug with ISPConfig3 I think. Mysql needs two rows, one for local, and one for non local. The % any host doesn't include local access.

till
3rd November 2008, 20:18
There is no additional record needed. Please take a look at the closed bug in the bugtracker, mysql describes that also in their manual.

http://bugtracker.ispconfig.org/index.php?do=details&task_id=235&string=mysql&project=3

almas
4th November 2008, 03:04
Thank you very much :D

make-fun
6th November 2008, 08:26
Hi there,
I've just been testing ISPConfig 3, mainly I was interested in whether we could be using SFTP with WinSCP without clients being able to roam around too much. It seems like I was able to roam through every dir on the server, no matter what settings I used for a Shell User.
Is there any way to prevent this?

Cheers

make-fun
6th November 2008, 08:35
Hi Folks,
it seems like you can create Maill Loops by forwarding an email address to itself, like test@test.org -> test@test.org. Maybe worth fixing this just in case you have some user doing these foolish things ;-)

Like very much what I see, BTW

Cheers

Ben
6th November 2008, 09:15
Hi there,
I've just been testing ISPConfig 3, mainly I was interested in whether we could be using SFTP with WinSCP without clients being able to roam around too much. It seems like I was able to roam through every dir on the server, no matter what settings I used for a Shell User.
Is there any way to prevent this?

Cheers

Well SCP or SFTP belong mainly to the same, ssh (instead of ftpS). So roaming around is no wonder, as you may do the same as when connecting via ssh directly. Afair there is not default shell in most distros that locks a user in several dirs or the user's homedir. I gave scponly a try but it was more or less like a mess or let's say for the things I expected it was not straight forward enough as to use it for more users.

make-fun
6th November 2008, 09:28
Thanks Ben,
yes I'm aware of this — I was just wondering whether there was something on the rise maybe, as I saw the several settings like chroot, jail etc.
There is a commercial product which has implemented this "feature" somehow — so it's like an ftp user who does not get out of his ftp dir.
Anyway the goal would be to close port 21 and only allow ssl connections in oder to upload files…

AlArenal
7th November 2008, 00:21
The Apache Directives Field should be a text area instead of a text field in order to support multiple lines in the vhost file, like it does in ISPC2.

Otherwise you won't be able e.g. to put a Directory directive with AllowOverride All in it.

ispconfig07
7th November 2008, 14:29
I've download the ISPConfig 3.0.0.7 virtual maschine, it work fine but when I access
http://192.168.0.105:8080
Can't login with
Username admin
Password admin

kalua
7th November 2008, 17:21
The Apache Directives Field should be a text area instead of a text field in order to support multiple lines in the vhost file, like it does in ISPC2.

Otherwise you won't be able e.g. to put a Directory directive with AllowOverride All in it.

You could use an INCLUDE /path/to/include-file

In this file you can put your directory directive. Apache parse this file at startup, so you need to restart (or would be an reload enough?) apache.
If you don't have permission to restart apache, simply change an config entry in ISPConfig. After this the ISPConfig script triggers an restart.

karailiev
19th November 2008, 17:05
Hello all
I don't know if this is clamav related problem or ISPConfig, but I'm posting here, because I think it's important to ISPConfig too.
I've installed http://www.ispconfig.org/downloads/ISPConfig-3.0.0.7-beta.tar.gz and here is what I noticed.
The first screenshot is made 1 minute after starting the machine, then you can watch the clock in the corner.
The machine has CPU Celeron 300Mhz and 256MB RAM.
You can see there clamd is using 5.1% of the memory and the CPU usage is 99.7%.
1.5 hours later the CPU usage is still 99.7%, the memory used by clamd is now 12.6% and all the CPU's time is used by it.
Another 1.5 hours later - the CPU usage is 0.7%, the memory used by clamd is 21.7% and the used CPU time is 3 hours.

So my conclusion is: clamd is doing a lot of calculations using a lot of memory (about 50MB) and this continues about 3 hours.
Is this behavior normal?

Edit: I've noticed amavisd-new is also using a lot of memory - about 128MB.

http://home.karailiev.net/ispc/ispc_clamd_01.jpeg

http://home.karailiev.net/ispc/ispc_clamd_02.jpeg

http://home.karailiev.net/ispc/ispc_clamd_03.jpeg

till
19th November 2008, 17:13
This has nothing to do with ISPConfig as clamav is from the linux distribution. You should install all available updates from the linux distribution.

davestyle
20th November 2008, 16:32
Any idea when version 3 will be out of beta? And will there be a update from the beta to the stable release version?

ruede
28th November 2008, 11:22
why do i have to add a domain for being able to store stuff under a subdomain?

when i create a subdomain with the help of the subdomain menu entry, i cannot add a folder.
what is the point of a subdomain considering that i cannot do anything with that subdomain?

zenny
3rd December 2008, 16:49
I installed ISPConfig3 Beta7 in a Debian Container under OpenVZ. But I could not find the admin and user manual for the version 3, did I miss something at ispconfig site? I am a bit confused as the interface is much faster and simple but I could hardly follow. :-( Dull me!!! Any pointers?

Thanks!

grungy
8th December 2008, 11:59
This is great piece of software, good work guys. Just downloaded the latest trunk, ISPConfig 3.0.0.8 and I must say I am switching to ISPConfig!


I love the DNS template feature!

Will run it, test it and let you know if I find any problems...

Hail!

grungy
8th December 2008, 12:43
IS there a way to make hosting plans so I don't have to enter limits manually every time I add a client?

till
8th December 2008, 14:00
Hosting plans are not available yet but they are on the todo list.

dvazart
12th December 2008, 17:02
GREAT WORK !!!

Really nice, better than Plesk or Cpanel !

Keep doing the good work and keep it FREE "as in freedom"

Thanks !

grungy
22nd December 2008, 19:33
Is there a document on the multiserver feature? What technology is used for it? Do you have to specify during the installation that the server will be used in multiserver environment or can it be set later on?

grungy
22nd December 2008, 19:35
Hosting plans are not available yet but they are on the todo list.

Tested the latest trunk, and now ispconfig has client templates, great!

And I like the new look.

Ben
23rd December 2008, 09:56
Tested the latest trunk, and now ispconfig has client templates, great!

And I like the new look.

Is there a way to download the newest one without having svn installed?

till
23rd December 2008, 11:06
Is there a way to download the newest one without having svn installed?

No. The latest version is only available from SVN. If you have ISPConfig 3.0.0.7 installed, then run:

ispconfig_update_from_svn.sh to keep your installation up to date. But you will have to install the subversion package from your linux disribution first.

grungy
23rd December 2008, 11:09
Is there a way to download the newest one without having svn installed?

Here is a link that I made http://87.230.77.98/ispconfig308/trunk.tar.gz

djoey
24th December 2008, 12:47
Hi,

I have an issue with installing pure-ftpd on Cent-OS 5.2, it install just fine but i cannot start the program from /etc/init.d/ it fails on stopping / starting.

I have also tried to start it this way /usr/sbin/pure-ftpd &

But it dies then. Best of all I can't find any logfiles to see what is going wrong.

And i think it is absolutely necessary to install ispconfig 3
Do you guys have suggestions?

Here is some more information:


bash -x /etc/init.d/pure-ftpd start
+ . /etc/init.d/functions
++ TEXTDOMAIN=initscripts
++ umask 022
++ PATH=/sbin:/usr/sbin:/bin:/usr/bin
++ export PATH
++ '[' -z '' ']'
++ COLUMNS=80
++ '[' -z '' ']'
+++ /sbin/consoletype
++ CONSOLETYPE=pty
++ '[' -f /etc/sysconfig/i18n -a -z '' ']'
++ . /etc/profile.d/lang.sh
+++ sourced=0
+++ for langfile in /etc/sysconfig/i18n '$HOME/.i18n'
+++ '[' -f /etc/sysconfig/i18n ']'
+++ . /etc/sysconfig/i18n
++++ LANG=en_US.UTF-8
++++ SYSFONT=latarcyrheb-sun16
+++ sourced=1
+++ for langfile in /etc/sysconfig/i18n '$HOME/.i18n'
+++ '[' -f /root/.i18n ']'
+++ '[' -n '' ']'
+++ '[' 1 = 1 ']'
+++ '[' -n en_US.UTF-8 ']'
+++ export LANG
+++ '[' -n '' ']'
+++ unset LC_ADDRESS
+++ '[' -n '' ']'
+++ unset LC_CTYPE
+++ '[' -n '' ']'
+++ unset LC_COLLATE
+++ '[' -n '' ']'
+++ unset LC_IDENTIFICATION
+++ '[' -n '' ']'
+++ unset LC_MEASUREMENT
+++ '[' -n '' ']'
+++ unset LC_MESSAGES
+++ '[' -n '' ']'
+++ unset LC_MONETARY
+++ '[' -n '' ']'
+++ unset LC_NAME
+++ '[' -n '' ']'
+++ unset LC_NUMERIC
+++ '[' -n '' ']'
+++ unset LC_PAPER
+++ '[' -n '' ']'
+++ unset LC_TELEPHONE
+++ '[' -n '' ']'
+++ unset LC_TIME
+++ '[' -n '' ']'
+++ unset LC_ALL
+++ '[' -n '' ']'
+++ unset LANGUAGE
+++ '[' -n '' ']'
+++ unset LINGUAS
+++ '[' -n '' ']'
+++ unset _XKB_CHARSET
++++ /sbin/consoletype
+++ consoletype=pty
+++ '[' -n '' ']'
+++ '[' -n '' ']'
+++ '[' -n en_US.UTF-8 ']'
+++ case $LANG in
+++ '[' xterm = linux ']'
+++ unset SYSFONTACM SYSFONT
+++ unset sourced
+++ unset langfile
++ '[' -z '' ']'
++ '[' -f /etc/sysconfig/init ']'
++ . /etc/sysconfig/init
+++ BOOTUP=color
+++ GRAPHICAL=yes
+++ RES_COL=60
+++ MOVE_TO_COL='echo -en \033[60G'
+++ SETCOLOR_SUCCESS='echo -en \033[0;32m'
+++ SETCOLOR_FAILURE='echo -en \033[0;31m'
+++ SETCOLOR_WARNING='echo -en \033[0;33m'
+++ SETCOLOR_NORMAL='echo -en \033[0;39m'
+++ LOGLEVEL=3
+++ PROMPT=no
+++ AUTOSWAP=no
++ '[' pty = serial ']'
++ '[' color '!=' verbose ']'
++ INITLOG_ARGS=-q
++ __sed_discard_ignored_files='/\(~\|\.bak\|\.orig\|\.rpmnew\|\.rpmorig\|\.rpms ave\)$/d'
+ . /etc/sysconfig/network
++ NETWORKING=yes
++ GATEWAY=192.168.1.1
++ HOSTNAME=blaat.local
+ '[' yes = no ']'
+ RETVAL=0
+ prog=pure-ftpd
+ fullpath=/usr/sbin/pure-ftpd
+ pureftpwho=/usr/sbin/pure-ftpwho
+ pure_config=/etc/pure-ftpd/pure-ftpd.conf
+ pure_launch_script=/usr/sbin/pure-config.pl
+ case "$1" in
+ start
+ echo -n 'Starting pure-ftpd: '
Starting pure-ftpd: + daemon '/usr/sbin/pure-config.pl /etc/pure-ftpd/pure-ftpd. conf --daemonize > /dev/null'
+ local gotbase= force= nicelevel corelimit
+ local pid base= user= nice= bg= pid_file=
+ nicelevel=0
+ '[' '/usr/sbin/pure-config.pl /etc/pure-ftpd/pure-ftpd.conf --daemonize > /dev /null' '!=' '/usr/sbin/pure-config.pl /etc/pure-ftpd/pure-ftpd.conf --daemonize > /dev/null' ']'
+ '[' -z '' ']'
+ base=null
+ __pids_var_run null ''
+ local base=null
+ local pid_file=/var/run/null.pid
+ pid=
+ '[' -f /var/run/null.pid ']'
+ return 3
+ '[' -n '' -a -z '' ']'
+ corelimit='ulimit -S -c 0'
+ '[' -n '' ']'
+ '[' color = verbose -a -z '' ']'
+ '[' -z '' ']'
+ /bin/bash -c 'ulimit -S -c 0 >/dev/null 2>&1 ; /usr/sbin/pure-config.pl /etc/p ure-ftpd/pure-ftpd.conf --daemonize > /dev/null'
+ '[' 252 -eq 0 ']'
+ failure 'null startup'
+ local rc=1
+ '[' color '!=' verbose -a -z '' ']'
+ echo_failure
+ '[' color = color ']'
+ echo -en '\033[60G'
+ echo -n '['
[+ '[' color = color ']'
+ echo -en '\033[0;31m'
+ echo -n FAILED
FAILED+ '[' color = color ']'
+ echo -en '\033[0;39m'
+ echo -n ']'
]+ echo -ne '\r'
+ return 1
+ '[' -x /usr/bin/rhgb-client ']'
+ return 1
+ RETVAL=1
+ '[' 1 = 0 ']'
+ echo

+ exit 1