PDA

View Full Version : POP3 login error /Suse perfect set up 9.3


gimhan90
6th February 2006, 15:03
Hi folks,

Please have a look at this error.This was happend when i did the following thing ?

# telnet cosmoforge.com pop3
Trying 66.240.aaa.xxx...
Connected to cosmoforge.com.
Escape character is '^]'.
+OK Hello there.
user web3_lasitha
+OK Password required.
pass lcg123
-ERR Maildir: No such file or directory
Connection closed by foreign host.

Thx,
gim

[

till
6th February 2006, 15:08
You have to send an email to the account before you can fetch emails with pop3. The maildir is created when the first email arrives.

Dont forget to check the maildir checkbox in ISPConfig under management > server > settings on the mail tab.

gimhan90
6th February 2006, 15:34
Sorry i can't send the mail

Feb 5 22:28:13 linux postfix/smtpd[18625]: NOQUEUE: reject: RCPT from unknown[220.247.234.159]: 554 <unknown[220.247.234.159]>: Client host rejected: Access denied; from=<lasitha@cosmoforge.com> to=<lasitha@codegen.net> proto=SMTP helo=<shyamal>

This is the error given by outlook.Result is same for telnet.

till
6th February 2006, 17:04
Have you created awebsite www.codegen.net in ISPConfig with a co-domain codegen.net (host field of the co-domain is empty) and created an email user with the email address: lasitha@codegen.net ?

gimhan90
7th February 2006, 11:41
Have you created awebsite www.codegen.net in ISPConfig with a co-domain codegen.net (host field of the co-domain is empty) and created an email user with the email address: lasitha@codegen.net ?

I tried to send a mail to lasitha@cosmoforge.com from my gmail account (gimhan@gmail.com)

(Cretaed user through ISP - lasitha@cosmoforge.com
www.cosmoforge.com - registered domin through DNS service provider .)

This is an automatically generated Delivery Status Notification
Delivery to the following recipient failed permanently:

Here is the Result
Technical details of permanent failure:
PERM_FAILURE: SMTP Error (state 9): 554 <xproxy.gmail.com[66.249.82.201]>: Client host rejected: Access denied
----- Original message -----

Received: by 10.70.18.12 with SMTP id 12mr6837401wxr;
Mon, 06 Feb 2006 19:58:51 -0800 (PST)
Received: by 10.70.130.18 with HTTP; Mon, 6 Feb 2006 19:58:51 -0800 (PST)
Message-ID: <4b237c5b0602061958j2f62f90fw8e0a89cc0a9c8d81@mail. gmail.com>
Date: Tue, 7 Feb 2006 09:58:51 +0600
From: G i m h a n <gimhan@gmail.com>
To: lasitha@cosmoforge.com
Subject: test
MIME-Version: 1.0
Content-Type: text/plain; charset=WINDOWS-1252
Content-Transfer-Encoding: base64
Content-Disposition: inline

LS0KCiAgLS0tLS0tLS0tbzAwby0tKF8pLS1vMDBvLS0tLS0tLS 0tLS0tLS0tLS0KICAgR2ltaGFu
IFByaXlhbnRoYS9UZWFtIFZpcnR1c2GZCi0tLS0tLW9vbzAtLS 0tLS0tLS0tLS0tLS0tLS0tLS0t
LS0tLS0tLS0tCiAgICAoICAgKSAgICAgMG9vbwogICAgIFwgKC AgICAgICggICApCiAgICAgIFxf
KSAgICAgICkgLwogICAgICAgICAgICAgIChfLwo=

falko
7th February 2006, 12:58
You have an MX record for cosmoforge.com, but the MX record has no A record:

~# dig mx cosmoforge.com

; <<>> DiG 9.2.1 <<>> mx cosmoforge.com
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 12794
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 1

;; QUESTION SECTION:
;cosmoforge.com. IN MX

;; ANSWER SECTION:
cosmoforge.com. 600 IN MX 10 q0.cosmoforge.com.

;; AUTHORITY SECTION:
cosmoforge.com. 600 IN NS ns2.netfirms.com.
cosmoforge.com. 600 IN NS ns1.netfirms.com.

;; ADDITIONAL SECTION:
ns1.netfirms.com. 85551 IN A 64.34.74.221

;; Query time: 253 msec
;; SERVER: 81.169.163.104#53(81.169.163.104)
;; WHEN: Tue Feb 7 11:56:39 2006
;; MSG SIZE rcvd: 112

mh1:~# dig q0.cosmoforge.com

; <<>> DiG 9.2.1 <<>> q0.cosmoforge.com
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 26855
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;q0.cosmoforge.com. IN A

;; AUTHORITY SECTION:
cosmoforge.com. 2560 IN SOA ns1.netfirms.com. hostmaster.cosmoforge.com. 1139305407 16384 2048 1048576 2560

;; Query time: 137 msec
;; SERVER: 81.169.163.104#53(81.169.163.104)
;; WHEN: Tue Feb 7 11:57:05 2006
;; MSG SIZE rcvd: 95

Mail for cosmoforge.com goes to q0.cosmoforge.com, but q0.cosmoforge.com doesn't exist. It has no A record which means mails can't be delivered!

gimhan90
7th February 2006, 13:56
HI falko
Thanks.I'l fix it and give you a feedback

gimhan90
8th February 2006, 14:03
You have an MX record for cosmoforge.com, but the MX record has no A record:

~# dig mx cosmoforge.com

; <<>> DiG 9.2.1 <<>> mx cosmoforge.com
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 12794
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 1

;; QUESTION SECTION:
;cosmoforge.com. IN MX

;; ANSWER SECTION:
cosmoforge.com. 600 IN MX 10 q0.cosmoforge.com.

;; AUTHORITY SECTION:
cosmoforge.com. 600 IN NS ns2.netfirms.com.
cosmoforge.com. 600 IN NS ns1.netfirms.com.

;; ADDITIONAL SECTION:
ns1.netfirms.com. 85551 IN A 64.34.74.221

;; Query time: 253 msec
;; SERVER: 81.169.163.104#53(81.169.163.104)
;; WHEN: Tue Feb 7 11:56:39 2006
;; MSG SIZE rcvd: 112

mh1:~# dig q0.cosmoforge.com

; <<>> DiG 9.2.1 <<>> q0.cosmoforge.com
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 26855
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;q0.cosmoforge.com. IN A

;; AUTHORITY SECTION:
cosmoforge.com. 2560 IN SOA ns1.netfirms.com. hostmaster.cosmoforge.com. 1139305407 16384 2048 1048576 2560

;; Query time: 137 msec
;; SERVER: 81.169.163.104#53(81.169.163.104)
;; WHEN: Tue Feb 7 11:57:05 2006
;; MSG SIZE rcvd: 95

Mail for cosmoforge.com goes to q0.cosmoforge.com, but q0.cosmoforge.com doesn't exist. It has no A record which means mails can't be delivered!




I replaced the q0.cosmoforge.com with A recoed . Still can't send a mail to lasitha@cosmoforge.com . same error ....

gimhan90
8th February 2006, 14:39
HI...
I tried to send an email to the account.Here i got from postmaster

Failed address: lasitha@cosmoforge.com

--- Session Transcript ---
Wed 2006-02-08 12:28:28: Parsing Message <xxxxxxxxxxxxxxxxxx\pd50001261254.msg>
Wed 2006-02-08 12:28:28: From: lasitha@codegen.net
Wed 2006-02-08 12:28:28: To: lasitha@cosmoforge.com
Wed 2006-02-08 12:28:28: Subject: TEST
Wed 2006-02-08 12:28:28: Message-ID: <op.s4nmabx5hhhxqy@shyamal>
Wed 2006-02-08 12:28:28: MX-record resolution of [cosmoforge.com] in progress (DNS Server:
161.76.9.1)...
Wed 2006-02-08 12:28:28: * P=010 D=cosmoforge.com TTL=(0) MX=[mail.cosmoforge.com]
{66.240.254.144}
Wed 2006-02-08 12:28:28: Attempting MX: P=010 D=cosmoforge.com TTL=(0) MX=[mail.cosmoforge.com]
{66.240.254.144}
Wed 2006-02-08 12:28:28: Attempting SMTP connection to [66.240.254.144 : 25]
Wed 2006-02-08 12:28:28: Waiting for socket connection...
Wed 2006-02-08 12:28:28: Socket connection established (161.76.28.49 : 3720 -> 66.240.254.144 :
25)
Wed 2006-02-08 12:28:28: Waiting for protocol initiation...
Wed 2006-02-08 12:28:29: <-- 220 ****************************
Wed 2006-02-08 12:28:29: --> EHLO mail.codegen.it
Wed 2006-02-08 12:28:29: <-- 250-cosmoforge.com
Wed 2006-02-08 12:28:29: <-- 250-PIPELINING
Wed 2006-02-08 12:28:29: <-- 250-SIZE 10240000
Wed 2006-02-08 12:28:29: <-- 250-VRFY
Wed 2006-02-08 12:28:29: <-- 250-ETRN
Wed 2006-02-08 12:28:29: <-- 250-XXXXXXXA
Wed 2006-02-08 12:28:29: <-- 250-AUTH PLAIN LOGIN
Wed 2006-02-08 12:28:29: <-- 250 8BITMIME
Wed 2006-02-08 12:28:29: --> MAIL From:<lasitha@codegen.net> SIZE=1544
Wed 2006-02-08 12:28:30: <-- 250 Ok
Wed 2006-02-08 12:28:30: --> RCPT To:<lasitha@cosmoforge.com>
Wed 2006-02-08 12:28:30: <-- 554 <mail.codegen.it[161.76.28.49]>: Client host rejected: Access
denied

What is happening here?

falko
8th February 2006, 17:27
What's in /etc/postfix/main.cf?

gimhan90
9th February 2006, 08:26
What's in /etc/postfix/main.cf?




# SOFT BOUNCE
#

#
#soft_bounce = no

# LOCAL PATHNAME INFORMATION
#

# The command_directory parameter specifies the location of all
# postXXX commands.
#
command_directory = /usr/sbin

# The daemon_directory parameter specifies the location of all Postfix

#
daemon_directory = /usr/lib/postfix

# QUEUE AND PROCESS OWNERSHIP
.

#default_privs = nobody

# INTERNET HOST AND DOMAIN NAMES
#

#
myhostname =$mydomain
#myhostname = virtual.domain.tld


#
mydomain =cosmoforge.com

# SENDING MAIL
#

#
myorigin = $myhostname
#myorigin = mail.cosmoforge.com

# RECEIVING MAIL


inet_interfaces = all
#inet_interfaces = $myhostname, localhost

# The proxy_interfaces parameter specifies the network interface

#
#proxy_interfaces =
#proxy_interfaces = 1.2.3.4

# The #mydestination parameter specifies the list of domains that this


# See also below, section "REJECTING MAIL FOR UNKNOWN LOCAL USERS".
#
#mydestination = /etc/postfix/local-host-names
##mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain
##mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain,
# mail.$mydomain, www.$mydomain, ftp.$mydomain

# REJECTING MAIL FOR UNKNOWN LOCAL USERS
#

#
# The right-hand side of the lookup tables is conveniently ignored.
# In the left-hand side, specify a bare username, an @domain.tld
# wild-card, or specify a user@domain.tld address.
#
local_recipient_maps = unix:passwd.byname $alias_maps
#local_recipient_maps = proxy:unix:passwd.byname $alias_maps
#local_recipient_maps =


# local_recipient_maps settings are OK.
#
unknown_local_recipient_reject_code = 550

# TRUST AND RELAY CONTROL


#

mynetworks_style = class
#mynetworks_style = subnet
#mynetworks_style = host

# Alternatively, you can specify the mynetworks list by hand, in
#
mynetworks = 168.100.189.0/28, 127.0.0.0/8
#mynetworks = $config_directory/mynetworks
#mynetworks = hash:/etc/postfix/network_table

# The relay_domains parameter restricts what destinations this system will

# Specify a list of hosts or domains, /file/name patterns or type:name
# lookup tables, separated by commas and/or whitespace. Continue
# long lines by starting the next line with whitespace. A file name
# is replaced by its contents; a type:name table is matched when a
# (parent) domain appears as lookup key.
#
#
#
relay_domains = $mydestination
# NOTE: Postfix will not automatically forward mail for domains that
# list this system as their primary or backup MX host. See the
# permit_mx_backup restriction description in postconf(5).
#

# INTERNET OR INTRANET


#relayhost = $mydomain
#relayhost = [cosmoforge.com]:25
#relayhost = [mailserver.isp.tld]
#relayhost = uucphost
#relayhost = [an.ip.add.ress]

# REJECTING UNKNOWN RELAY USERS
#

#relay_recipient_maps = hash:/etc/postfix/relay_recipients

# INPUT RATE CONTROL
#
#
# Specify 0 to disable the feature. Valid delays are 0..10.
#
#in_flow_delay = 1s

# ADDRESS REWRITING
#
# The ADDRESS_REWRITING_README document gives information about
# address masquerading or other forms of address rewriting including
# username->Firstname.Lastname mapping.

# ADDRESS REDIRECTION (VIRTUAL DOMAIN)
#
# The VIRTUAL_README document gives information about the many forms
# of domain hosting that Postfix supports.

# "USER HAS MOVED" BOUNCE MESSAGES
#
# See the discussion in the ADDRESS_REWRITING_README document.

# TRANSPORT MAP
#
# See the discussion in the ADDRESS_REWRITING_README document.

# ALIAS DATABASE
#
#
#alias_maps = dbm:/etc/aliases
alias_maps = hash:/etc/aliases
#alias_maps = hash:/etc/aliases, nis:mail.aliases
#alias_maps = netinfo:/aliases


#alias_database = dbm:/etc/aliases
#alias_database = dbm:/etc/mail/aliases
alias_database = hash:/etc/aliases
#alias_database = hash:/etc/aliases, hash:/opt/majordomo/aliases

# ADDRESS EXTENSIONS (e.g., user+foo)
#recipient_delimiter = +

# DELIVERY TO MAILBOX
#

#
#home_mailbox = /var/mail
home_mailbox = Maildir/

# The mail_spool_directory parameter specifies the directory where
# UNIX-style mailboxes are kept. The default setting depends on the
# system type.
#
#mail_spool_directory = /var/mail
mail_spool_directory = /var/spool/mail


mailbox_command =
#mailbox_command = /some/where/procmail -a "$EXTENSION"


#
#mailbox_transport = lmtp:unix:/file/name
#mailbox_transport = cyrus

# The fallback_transport specifies the optional transport in master.cf
# to use for recipients that are not found in the UNIX passwd database.
# This parameter has precedence over the luser_relay parameter.
#
# Specify a string of the form transport:nexthop, where transport is
# the name of a mail delivery transport defined in master.cf. The
# :nexthop part is optional. For more details see the samp

virtual_alias_domains = hash:/etc/postfix/virtual
#virtual_alias_maps = hash:/etc/postfix/virtual
transport_maps = hash:/etc/postfix/transport
smtpd_sasl_local_domain =$myhostname
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous


#
setgid_group = mail
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_ relay_domains
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

virtual_maps = hash:/etc/postfix/virtusertable
mydestination = /etc/postfix/local-host-names

gimhan90
10th February 2006, 05:33
# SOFT BOUNCE
#

#
#soft_bounce = no

# LOCAL PATHNAME INFORMATION
#

# The command_directory parameter specifies the location of all
# postXXX commands.
#
command_directory = /usr/sbin

# The daemon_directory parameter specifies the location of all Postfix

#
daemon_directory = /usr/lib/postfix

# QUEUE AND PROCESS OWNERSHIP
.

#default_privs = nobody

# INTERNET HOST AND DOMAIN NAMES
#

#
myhostname =$mydomain
#myhostname = virtual.domain.tld


#
mydomain =cosmoforge.com

# SENDING MAIL
#

#
myorigin = $myhostname
#myorigin = mail.cosmoforge.com

# RECEIVING MAIL


inet_interfaces = all
#inet_interfaces = $myhostname, localhost

# The proxy_interfaces parameter specifies the network interface

#
#proxy_interfaces =
#proxy_interfaces = 1.2.3.4

# The #mydestination parameter specifies the list of domains that this


# See also below, section "REJECTING MAIL FOR UNKNOWN LOCAL USERS".
#
#mydestination = /etc/postfix/local-host-names
##mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain
##mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain,
# mail.$mydomain, www.$mydomain, ftp.$mydomain

# REJECTING MAIL FOR UNKNOWN LOCAL USERS
#

#
# The right-hand side of the lookup tables is conveniently ignored.
# In the left-hand side, specify a bare username, an @domain.tld
# wild-card, or specify a user@domain.tld address.
#
local_recipient_maps = unix:passwd.byname $alias_maps
#local_recipient_maps = proxy:unix:passwd.byname $alias_maps
#local_recipient_maps =


# local_recipient_maps settings are OK.
#
unknown_local_recipient_reject_code = 550

# TRUST AND RELAY CONTROL


#

mynetworks_style = class
#mynetworks_style = subnet
#mynetworks_style = host

# Alternatively, you can specify the mynetworks list by hand, in
#
mynetworks = 168.100.189.0/28, 127.0.0.0/8
#mynetworks = $config_directory/mynetworks
#mynetworks = hash:/etc/postfix/network_table

# The relay_domains parameter restricts what destinations this system will

# Specify a list of hosts or domains, /file/name patterns or type:name
# lookup tables, separated by commas and/or whitespace. Continue
# long lines by starting the next line with whitespace. A file name
# is replaced by its contents; a type:name table is matched when a
# (parent) domain appears as lookup key.
#
#
#
relay_domains = $mydestination
# NOTE: Postfix will not automatically forward mail for domains that
# list this system as their primary or backup MX host. See the
# permit_mx_backup restriction description in postconf(5).
#

# INTERNET OR INTRANET


#relayhost = $mydomain
#relayhost = [cosmoforge.com]:25
#relayhost = [mailserver.isp.tld]
#relayhost = uucphost
#relayhost = [an.ip.add.ress]

# REJECTING UNKNOWN RELAY USERS
#

#relay_recipient_maps = hash:/etc/postfix/relay_recipients

# INPUT RATE CONTROL
#
#
# Specify 0 to disable the feature. Valid delays are 0..10.
#
#in_flow_delay = 1s

# ADDRESS REWRITING
#
# The ADDRESS_REWRITING_README document gives information about
# address masquerading or other forms of address rewriting including
# username->Firstname.Lastname mapping.

# ADDRESS REDIRECTION (VIRTUAL DOMAIN)
#
# The VIRTUAL_README document gives information about the many forms
# of domain hosting that Postfix supports.

# "USER HAS MOVED" BOUNCE MESSAGES
#
# See the discussion in the ADDRESS_REWRITING_README document.

# TRANSPORT MAP
#
# See the discussion in the ADDRESS_REWRITING_README document.

# ALIAS DATABASE
#
#
#alias_maps = dbm:/etc/aliases
alias_maps = hash:/etc/aliases
#alias_maps = hash:/etc/aliases, nis:mail.aliases
#alias_maps = netinfo:/aliases


#alias_database = dbm:/etc/aliases
#alias_database = dbm:/etc/mail/aliases
alias_database = hash:/etc/aliases
#alias_database = hash:/etc/aliases, hash:/opt/majordomo/aliases

# ADDRESS EXTENSIONS (e.g., user+foo)
#recipient_delimiter = +

# DELIVERY TO MAILBOX
#

#
#home_mailbox = /var/mail
home_mailbox = Maildir/

# The mail_spool_directory parameter specifies the directory where
# UNIX-style mailboxes are kept. The default setting depends on the
# system type.
#
#mail_spool_directory = /var/mail
mail_spool_directory = /var/spool/mail


mailbox_command =
#mailbox_command = /some/where/procmail -a "$EXTENSION"


#
#mailbox_transport = lmtp:unix:/file/name
#mailbox_transport = cyrus

# The fallback_transport specifies the optional transport in master.cf
# to use for recipients that are not found in the UNIX passwd database.
# This parameter has precedence over the luser_relay parameter.
#
# Specify a string of the form transport:nexthop, where transport is
# the name of a mail delivery transport defined in master.cf. The
# :nexthop part is optional. For more details see the samp

virtual_alias_domains = hash:/etc/postfix/virtual
#virtual_alias_maps = hash:/etc/postfix/virtual
transport_maps = hash:/etc/postfix/transport
smtpd_sasl_local_domain =$myhostname
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous


#
setgid_group = mail
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_ relay_domains
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

virtual_maps = hash:/etc/postfix/virtusertable
mydestination = /etc/postfix/local-host-names


above i have attched the main.cf .

gimhan90
13th February 2006, 08:12
above i have attched the main.cf .



Herewith i have attched the main.cf . Please look at this and help me to solve the problem .
thx

falko
13th February 2006, 10:19
Hm, I can't find anything wrong in it. You can try to comment out this line:

virtual_alias_domains = hash:/etc/postfix/virtual

and restart Postfix.

gimhan90
13th February 2006, 13:35
Hm, I can't find anything wrong in it. You can try to comment out this line:

virtual_alias_domains = hash:/etc/postfix/virtual

and restart Postfix.


additionaly ,

mynetworks = 168.100.189.0/28, 127.0.0.0/8
do i need to put the ip of postfix server runs here ?

falko
13th February 2006, 18:08
additionaly ,

mynetworks = 168.100.189.0/28, 127.0.0.0/8
do i need to put the ip of postfix server runs here ?
No, it's already in there (127.0.0.0/8).

gimhan90
14th February 2006, 06:33
Hm, I can't find anything wrong in it. You can try to comment out this line:

virtual_alias_domains = hash:/etc/postfix/virtual

and restart Postfix.


I tried as u mentioned above , But got the same error again, :( .Any hints to resolve the issue sir?

Delivery to the following recipient failed permanently:

lasitha@cosmoforge.com

Technical details of permanent failure:
PERM_FAILURE: SMTP Error (state 9): 554 <xproxy.gmail.com[66.249.82.205]>: Client host rejected: Access denied

----- Original message -----

Received: by 10.70.8.11 with SMTP id 11mr3198198wxh;
Mon, 13 Feb 2006 20:30:23 -0800 (PST)
Received: by 10.70.130.18 with HTTP; Mon, 13 Feb 2006 20:30:23 -0800 (PST)
Message-ID: <4b237c5b0602132030j68768155i2c9b0f5facd685e3@mail. gmail.com>
Date: Tue, 14 Feb 2006 10:30:23 +0600
From: G i m h a n <gimhan@gmail.com>
To: lasitha@cosmoforge.com
Subject: test
MIME-Version: 1.0
Content-Type: text/plain; charset=WINDOWS-1252
Content-Transfer-Encoding: base64
Content-Disposition: inline

LS0KCiAgLS0tLS0tLS0tbzAwby0tKF8pLS1vMDBvLS0tLS0tLS 0tLS0tLS0tLS0KICAgR2ltaGFu
IFByaXlhbnRoYS9UZWFtIFZpcnR1c2GZCi0tLS0tLW9vbzAtLS 0tLS0tLS0tLS0tLS0tLS0tLS0t
LS0tLS0tLS0tCiAgICAoICAgKSAgICAgMG9vbwogICAgIFwgKC AgICAgICggICApCiAgICAgIFxf
KSAgICAgICkgLwogICAgICAgICAgICAgIChfLwo=

falko
14th February 2006, 22:08
I've just done a telnet:

~# telnet mail.cosmoforge.com 25
Trying 66.240.254.144...
Connected to su93254144.aspadmin.net.
Escape character is '^]'.
220 su93254144.cosmoforge.com ESMTP Postfix
ehlo localhost
250-su93254144.cosmoforge.com
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH PLAIN LOGIN
250 8BITMIME
quit
221 Bye
Connection closed by foreign host.

The problem might be that su93254144.aspadmin.net doesn't exist in DNS:

~# dig su93254144.aspadmin.net

; <<>> DiG 9.2.4 <<>> su93254144.aspadmin.net
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 61140
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;su93254144.aspadmin.net. IN A

;; AUTHORITY SECTION:
aspadmin.net. 3600 IN SOA ns1.aspadmin.com. domain_control.aspadmin.net. 1138989342 43200 7200 1209600 43200

;; Query time: 153 msec
;; SERVER: 145.253.2.75#53(145.253.2.75)
;; WHEN: Tue Feb 14 19:49:29 2006
;; MSG SIZE rcvd: 108

gimhan90
15th February 2006, 08:06
I've just done a telnet:

~# telnet mail.cosmoforge.com 25
Trying 66.240.254.144...
Connected to su93254144.aspadmin.net.
Escape character is '^]'.
220 su93254144.cosmoforge.com ESMTP Postfix
ehlo localhost
250-su93254144.cosmoforge.com
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH PLAIN LOGIN
250 8BITMIME
quit
221 Bye
Connection closed by foreign host.

The problem might be that su93254144.aspadmin.net doesn't exist in DNS:

~# dig su93254144.aspadmin.net

; <<>> DiG 9.2.4 <<>> su93254144.aspadmin.net
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 61140
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;su93254144.aspadmin.net. IN A

;; AUTHORITY SECTION:
aspadmin.net. 3600 IN SOA ns1.aspadmin.com. domain_control.aspadmin.net. 1138989342 43200 7200 1209600 43200

;; Query time: 153 msec
;; SERVER: 145.253.2.75#53(145.253.2.75)
;; WHEN: Tue Feb 14 19:49:29 2006
;; MSG SIZE rcvd: 108





su93254144:/etc/postfix # telnet mail.cosmoforge.com 25
Trying 66.240.254.14
Connected to mail.cosmoforge.com.
Escape character is '^]'.
220 cosmoforge.com ESMTP Postfix
ehlo localhost
250-cosmoforge.com
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH PLAIN LOGIN
250 8BITMIME
quit
221 Bye
Connection closed by foreign host.



In my main.cf i put like below,

myhostname = su93254144.$mydomain
mydomain =cosmoforge.com

su93254144 is the machine name that they provided.

( Last login: Mon Feb 13 22:15:20 2006 from 220.247.234.159
Have a lot of fun...
su93254144:~ #
)

Are those configurations wrong or ..? ( mydomain & myhostname)
or is it enough to put $mydoian for myhostname ( i.e myhostname = $mydomain
I am getting dns service from a DNS service provider .

falko
15th February 2006, 10:08
Now I'm seeing this:

~# telnet mail.cosmoforge.com 25
Trying 66.240.254.144...
Connected to su93254144.aspadmin.net.
Escape character is '^]'.
220 Server2.local ESMTP Postfix
ehlo localhost
250-Server2.local
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-AUTH PLAIN LOGIN
250 8BITMIME
quit
221 Bye
Connection closed by foreign host.
which can't be correct.

Please run

postconf -e 'myhostname = mail.$mydomain'
postconf -e 'mydomain =cosmoforge.com'
and restart Postfix.

gimhan90
16th February 2006, 15:51
Hi falko ,

Please see my postfix related configurations.


In my "/etc/hosts" looks like

# IP-Address Full-Qualified-Hostname Short-Hostname
#
127.0.0.1 localhost
# special IPv6 addresses
::1 localhost ipv6-localhost ipv6-loopback
fe00::0 ipv6-localnet
ff00::0 ipv6-mcastprefix
ff02::1 ipv6-allnodes
ff02::2 ipv6-allrouters
ff02::3 ipv6-allhosts
66.240.254.144 su93254144.aspadmin.net su93254144

In my host "/etc/hostname" looks like
su93254144.cosmoforge.com

In my host "/etc/HOSTNAME" looks like
su93254144.aspadmin.net
this "su93254144.aspadmin.net" comes as default server configuration.

Are those configurations Ok or do i need to alter ?
what is the differnce between "/etc/hostname" and "/etc/HOSTNAME" ?
& Are these OK or ....

su93254144:~ # hostname
su93254144.cosmoforge.com

su93254144:~ # hostname -f
su93254144.cosmoforge.com


FURTHER,
I create a new MX record name as "su93254144.cosmoforge.com" .Then change the main.cf as follows.
It will take some time to set up the new MX record, so still i didn't chk this new configuration by sending a mail .
Are these configurations Ok ?

main.cf

inet_protocols = all
biff = no
mail_spool_directory = /var/mail
canonical_maps = hash:/etc/postfix/canonical
#virtual_maps = hash:/etc/postfix/virtual
relocated_maps = hash:/etc/postfix/relocated
transport_maps = hash:/etc/postfix/transport
sender_canonical_maps = hash:/etc/postfix/sender_canonical
masquerade_exceptions = root
masquerade_classes = envelope_sender, header_sender, header_recipient
program_directory = /usr/lib/postfix
mynetworks = 192.168.0.0/24,66.240.0.0/24, 127.0.0.0/8
masquerade_domains =
#mydestination = $myhostname, localhost.$mydomain
defer_transports =
disable_dns_lookups = no
#relay_domains = mai.cosmoforge.com
mailbox_command =
mailbox_transport =
home_mailbox = Maildir/
smtpd_sender_restrictions = hash:/etc/postfix/access
smtpd_client_restrictions =
smtpd_helo_required = no
smtpd_helo_restrictions =
strict_rfc821_envelopes = no
smtpd_recipient_restrictions = permit_mynetworks,reject_unauth_destination
smtp_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_sasl_auth_enable = yes
smtpd_use_tls = no
smtp_use_tls = no
alias_maps = hash:/etc/aliases
mailbox_size_limit = 0
message_size_limit = 10240000
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd

virtual_maps = hash:/etc/postfix/virtusertable

mydestination = /etc/postfix/local-host-names
mydomain = cosmoforge.com
myhostname = su93254144.$mydomain

Thx
gimhan

falko
16th February 2006, 19:55
Hi falko ,

Please see my postfix related configurations.


In my "/etc/hosts" looks like

# IP-Address Full-Qualified-Hostname Short-Hostname
#
127.0.0.1 localhost
# special IPv6 addresses
::1 localhost ipv6-localhost ipv6-loopback
fe00::0 ipv6-localnet
ff00::0 ipv6-mcastprefix
ff02::1 ipv6-allnodes
ff02::2 ipv6-allrouters
ff02::3 ipv6-allhosts
66.240.254.144 su93254144.aspadmin.net su93254144

Please change it to
# IP-Address Full-Qualified-Hostname Short-Hostname
#
127.0.0.1 localhost.localdomain localhost
# special IPv6 addresses
::1 localhost ipv6-localhost ipv6-loopback
fe00::0 ipv6-localnet
ff00::0 ipv6-mcastprefix
ff02::1 ipv6-allnodes
ff02::2 ipv6-allrouters
ff02::3 ipv6-allhosts
66.240.254.144 su93254144.aspadmin.net su93254144


In my host "/etc/hostname" looks like
su93254144.cosmoforge.com

In my host "/etc/HOSTNAME" looks like
su93254144.aspadmin.net
this "su93254144.aspadmin.net" comes as default server configuration.

Are those configurations Ok or do i need to alter ?
what is the differnce between "/etc/hostname" and "/etc/HOSTNAME" ?
& Are these OK or ....
Delete /etc/HOSTNAME.



FURTHER,
I create a new MX record name as "su93254144.cosmoforge.com"
Make sure you also create an A record for su93254144.cosmoforge.com.
(BTW, wouldn't it have been easier to change your main.cf to mail.cosmoforge.com instead of su93254144.cosmoforge.com?)


Are these configurations Ok ?

main.cf

inet_protocols = all
biff = no
mail_spool_directory = /var/mail
canonical_maps = hash:/etc/postfix/canonical
#virtual_maps = hash:/etc/postfix/virtual
relocated_maps = hash:/etc/postfix/relocated
transport_maps = hash:/etc/postfix/transport
sender_canonical_maps = hash:/etc/postfix/sender_canonical
masquerade_exceptions = root
masquerade_classes = envelope_sender, header_sender, header_recipient
program_directory = /usr/lib/postfix
mynetworks = 192.168.0.0/24,66.240.0.0/24, 127.0.0.0/8
masquerade_domains =
#mydestination = $myhostname, localhost.$mydomain
defer_transports =
disable_dns_lookups = no
#relay_domains = mai.cosmoforge.com
mailbox_command =
mailbox_transport =
home_mailbox = Maildir/
smtpd_sender_restrictions = hash:/etc/postfix/access
smtpd_client_restrictions =
smtpd_helo_required = no
smtpd_helo_restrictions =
strict_rfc821_envelopes = no
smtpd_recipient_restrictions = permit_mynetworks,reject_unauth_destination
smtp_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_sasl_auth_enable = yes
smtpd_use_tls = no
smtp_use_tls = no
alias_maps = hash:/etc/aliases
mailbox_size_limit = 0
message_size_limit = 10240000
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd

virtual_maps = hash:/etc/postfix/virtusertable

mydestination = /etc/postfix/local-host-names
mydomain = cosmoforge.com
myhostname = su93254144.$mydomain

It must be inet_interfaces = all

gimhan90
17th February 2006, 07:56
Please change it to
# IP-Address Full-Qualified-Hostname Short-Hostname
#
127.0.0.1 localhost.localdomain localhost
# special IPv6 addresses
::1 localhost ipv6-localhost ipv6-loopback
fe00::0 ipv6-localnet
ff00::0 ipv6-mcastprefix
ff02::1 ipv6-allnodes
ff02::2 ipv6-allrouters
ff02::3 ipv6-allhosts
66.240.254.144 su93254144.aspadmin.net su93254144


Delete /etc/HOSTNAME.




Make sure you also create an A record for su93254144.cosmoforge.com.
(BTW, wouldn't it have been easier to change your main.cf to mail.cosmoforge.com instead of su93254144.cosmoforge.com?)


It must be inet_interfaces = all



I chnaged files/directories as u said ,

.
# Syntax:
#
# IP-Address Full-Qualified-Hostname Short-Hostname
#
127.0.0.1 localhost.localdomain localhost
# special IPv6 addresses
::1 localhost ipv6-localhost ipv6-loopback
fe00::0 ipv6-localnet
ff00::0 ipv6-mcastprefix
ff02::1 ipv6-allnodes
ff02::2 ipv6-allrouters
ff02::3 ipv6-allhosts
66.240.254.144 su93254144.aspadmin.net su93254144
Do i need to change the above "66.240.254.144 su93254144.aspadmin.net su93254144 " entry ?


renamed the /etc/HOSTNAME. to /etc/HOSTNAME.org

su93254144:~ # hostname
su93254144.cosmoforge.com

su93254144:~ # hostname -f
su93254144.cosmoforge.com


su93254144:~ # telnet su93254144.cosmoforge.com 25
Trying 66.240.254.144...
Connected to su93254144.cosmoforge.com.
Escape character is '^]'.
220 su93254144.cosmoforge.com ESMTP Postfix
ehlo localhost
250-su93254144.cosmoforge.com
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-AUTH PLAIN LOGIN
250-AUTH=PLAIN LOGIN
250 8BITMIME
quit
221 Bye
Connection closed by foreign host.

Now my main.cf as follows,

debug_peer_level = 2
#debug_peer_list = 127.0.0.1
#debug_peer_list = some.domain
debugger_command =
PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
xxgdb $daemon_directory/$process_name $process_id & sleep 5

sendmail_path = /usr/sbin/sendmail

newaliases_path = /usr/bin/newaliases
mailq_path = /usr/bin/mailq


setgid_group = maildrop
html_directory = /usr/share/doc/packages/postfix/html

manpage_directory = /usr/share/man
sample_directory = /usr/share/doc/packages/postfix/samples

readme_directory = /usr/share/doc/packages/postfix/README_FILES
#inet_protocols = all
inet_interfaces = all
biff = no
mail_spool_directory = /var/mail
canonical_maps = hash:/etc/postfix/canonical
#virtual_maps = hash:/etc/postfix/virtual
relocated_maps = hash:/etc/postfix/relocated
transport_maps = hash:/etc/postfix/transport
sender_canonical_maps = hash:/etc/postfix/sender_canonical
masquerade_exceptions = root
masquerade_classes = envelope_sender, header_sender, header_recipient
program_directory = /usr/lib/postfix
mynetworks = 192.168.0.0/24,66.240.0.0/24, 127.0.0.0/8
masquerade_domains =
#mydestination = $myhostname, localhost.$mydomain
defer_transports =
disable_dns_lookups = no
#relay_domains = mai.cosmoforge.com
mailbox_command =
mailbox_transport =
home_mailbox = Maildir/
smtpd_sender_restrictions = hash:/etc/postfix/access
smtpd_client_restrictions =
smtpd_helo_required = no
smtpd_helo_restrictions =
strict_rfc821_envelopes = no
smtpd_recipient_restrictions = permit_mynetworks,reject_unauth_destination
smtp_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_sasl_auth_enable = yes
smtpd_use_tls = no
smtp_use_tls = no
alias_maps = hash:/etc/aliases
mailbox_size_limit = 0
message_size_limit = 10240000
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd

virtual_maps = hash:/etc/postfix/virtusertable

mydestination = /etc/postfix/local-host-names
mydomain = cosmoforge.com
myhostname = su93254144.$mydomain


Then i tried to send a mail to lasitha@cosmoforge.com

but i was unable to send it and here i attched the result.

Mail Delivery Subsystem
<mailer-daemon@gmail.com>to me
Hide options 11:48 am (0 minutes ago)
From: Mail Delivery Subsystem <mailer-daemon@gmail.com>
To: gimhan@gmail.com
Date: Feb 17, 2006 11:48 AM
Subject: Delivery Status Notification (Failure)
Reply | Reply to all | Forward | Print | Add sender to Contacts list | Delete this message | Report phishing | Show original | Message text garbled?
This is an automatically generated Delivery Status Notification

Delivery to the following recipient failed permanently:

lasitha@cosmoforge.com

Technical details of permanent failure:
PERM_FAILURE: SMTP Error (state 9): 554 <xproxy.gmail.com[66.249.82.197]>: Client host rejected: Access denied

----- Original message -----

Received: by 10.70.37.17 with SMTP id k17mr601508wxk;
Thu, 16 Feb 2006 21:48:35 -0800 (PST)
Received: by 10.70.130.18 with HTTP; Thu, 16 Feb 2006 21:48:35 -0800 (PST)
Message-ID: <4b237c5b0602162148y373db0fbp76b19e55e596baeb@mail. gmail.com>
Date: Fri, 17 Feb 2006 11:48:35 +0600
From: G i m h a n <gimhan@gmail.com>
To: lasitha@cosmoforge.com
Subject: Fwd: be clever.....GOOD ONE
In-Reply-To: <OF180EF8AC.FC3BBCB2-ON46257118.0012C5EA@COMBANK.NET>
MIME-Version: 1.0
Content-Type: text/plain; charset=WINDOWS-1252
Content-Transfer-Encoding: base64
Content-Disposition: inline
References: <OF180EF8AC.FC3BBCB2-ON46257118.0012C5EA@COMBANK.NET>

LS0tLS0tLS0tLSBGb3J3YXJkZWQgbWVzc2FnZSAtLS0tLS0tLS 0tCkZyb206IEFzYW5rYV9TYW5q
ZWV3YUBjb21iYW5rLm5ldCA8QXNhbmthX1NhbmplZXdhQGNvbW JhbmsubmV0PgpEYXRlOiBGZWIg
MTcsIDIwMDYgOToyNSBBTQpTdWJqZWN0OiBiZSBjbGV2ZXIuLi 4uLkdPT0QgT05FClRvOiBQcmFz
YW5uYV9GZXJkaW5hbmRvQGNvbWJhbmsubmV0LCBTdWRoYXJzaG FuYV9NYWtld2l0YUBjb21iYW5r
Lm5ldCwKQXNoYV9NZW5kaXNAY29tYmFuay5uZXQsIGVyYW5kYS Btb2hvdHRhbGEgPGVyYW5kYTc4
QHlhaG9vLmNvbT4sIE1hbm9qClByaXlhbmdhIDxwcml5YW5nYW 1AeWFob28uY29tPiwgRyBpIG0g
aCBhIG4gPGdpbWhhbkBnbWFpbC5jb20+LAoiUmFqaXRoYSBXYX JuYWt1bGEgKFRHSykgPHJhaml0
aGFAdm9ndWV0ZXguY29tPiIKPFJhaml0aGFAdm9ndWV0ZXguY2 9tPiwgTW9oYW5fU2VyYXNpbmdo
YUBjb21iYW5rLm5ldAoKCgoKIEpvaG5ueSB3YW50ZWQgdG8gc2 NyZXcgYSBnaXJsIGluIGhpcyBv
ZmZpY2UuLi4uLmJ1dCBzaGUgYmVsb25nZWQgdG8KPj4gc29tZW 9uZSBlbHNlLi4uCj4+IE9uZSBk

falko
17th February 2006, 10:47
Please contact the Gmail suppport and ask them why it is failing. Maybe your server is on a blacklist or something like that. Because technically I don't see any reason why it should fail.

gimhan90
17th February 2006, 11:05
Please contact the Gmail suppport and ask them why it is failing. Maybe your server is on a blacklist or something like that. Because technically I don't see any reason why it should fail.


I chnaged files/directories as u said ,

.
# Syntax:
#
# IP-Address Full-Qualified-Hostname Short-Hostname
#
127.0.0.1 localhost.localdomain localhost
# special IPv6 addresses
::1 localhost ipv6-localhost ipv6-loopback
fe00::0 ipv6-localnet
ff00::0 ipv6-mcastprefix
ff02::1 ipv6-allnodes
ff02::2 ipv6-allrouters
ff02::3 ipv6-allhosts
66.240.254.144 su93254144.aspadmin.net su93254144
Do i need to change the above "66.240.254.144 su93254144.aspadmin.net su93254144 " entry ?

gimhan90
17th February 2006, 11:26
here is my "/etc/postfix/local-host-names"
which refers the
"mydestination = /etc/postfix/local-host-names" in my main.cf


###################################
#
# ISPConfig local-host-names Configuration File
# Version 1.0
#
###################################
localhost
su93254144.cosmoforge.com
localhost.su93254144.cosmoforge.com
localhost.cosmoforge.com
www.admin.gallelink.com
www.gallelink.com
www.cosmoforge.com
#admin
#testsite
#cosmoforge
#gallelink
gallelink.com
admin.gallelink.com
cosmoforge.com
#### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
Is this Ok ?

################################################


I tried to send a mail through my yahoo account. here is the result

Date: 17 Feb 2006 09:09:28 -0000
From: MAILER-DAEMON@yahoo.com Add to Address BookAdd to Address Book
Yahoo! DomainKeys has confirmed that this message was sent by yahoo.com. Learn more
To: gimhan90@yahoo.com
Subject: failure notice

Hi. This is the qmail-send program at yahoo.com.
I'm afraid I wasn't able to deliver your message to the following
addresses.
This is a permanent error; I've given up. Sorry it didn't work out.

<lasitha@cosmoforge.com>:
66.240.254.144 does not like recipient.
Remote host said: 554 <web31506.mail.mud.yahoo.com[68.142.198.135]>:
Client host rejected: Access denied
Giving up on 66.240.254.144.

--- Below this line is a copy of the message.

Return-Path: <gimhan90@yahoo.com>
Received: (qmail 78594 invoked by uid 60001); 17 Feb 2006 09:09:27
-0000
DomainKey-Signature: a=rsa-sha1; q=dns; c=nofws;
s=s1024; d=yahoo.com;

h=Message-ID:Received:Date:From:Subject:To:MIME-Version:Content-Type:Content-Transfer-Encoding;

b=E1G42Lnwt6r09oGFq00nV8IYAfsy+0FhkoFnUpTDxYZI4wmQ B8gJkx82lQpQ3VJlxbHOWaMJMfFGLSY5QWRPU3DZpppguqHVnW PinDobu8px5lmqN8H4VWHgle9HMJZWpvZilOjSaDoacJIjyqkE M/GkQm9CUu68uvYbUyojCr8=
;
Message-ID: <20060217090927.78592.qmail@web31506.mail.mud.yahoo .com>
Received: from [222.165.157.2] by web31506.mail.mud.yahoo.com via HTTP;
Fri, 17 Feb 2006 09:09:27 GMT
Date: Fri, 17 Feb 2006 09:09:27 +0000 (GMT)
From: =?iso-8859-1?q?G=20i=20m=20h=20a=20n=20=99?= <gimhan90@yahoo.com>
Subject: test
To: lasitha@cosmoforge.com
MIME-Version: 1.0
Content-Type: multipart/alternative;
boundary="0-1176672144-1140167367=:78094"
Content-Transfer-Encoding: 8bit

--0-1176672144-1140167367=:78094
Content-Type: text/plain; charset=iso-8859-1
Content-Transfer-Encoding: 8bit

falko
17th February 2006, 11:32
Do i need to change the above "66.240.254.144 su93254144.aspadmin.net su93254144 " entry ?
No.

I tried to send a mail through my yahoo account. here is the result
If you're on a blacklist and Yahoo uses the same blacklist a Gmail, then it's clear. Please contact Gmail and Yahoo.

gimhan90
17th February 2006, 12:39
No.


If you're on a blacklist and Yahoo uses the same blacklist a Gmail, then it's clear. Please contact Gmail and Yahoo.

I send a quary to Gmail support team.

i sent a mail from my office mail to lasitha@cosmoforge.com

resullts

Display all headersDate: Thu, 16 Feb 2006 07:04:02 +0000
From: postmaster@mail.codegen.it
Reply-To: BadMsgQ@mail.codegen.it
Subject: Permanent Delivery Failure
To: lasitha@codegen.net

The attached message had PERMANENT fatal delivery errors!

After one or more unsuccessful delivery attempts the attached message has
been removed from the mail queue on this server. The number and frequency
of delivery attempts are determined by local configuration parameters.

YOUR MESSAGE WAS NOT DELIVERED TO ANY OF IT'S RECIPIENTS!

Failed address: lasitha@cosmoforge.com

--- Session Transcript ---
Thu 2006-02-16 07:03:59: Parsing Message
<xxxxxxxxxxxxxxxxxx\pd50001298225.msg>
Thu 2006-02-16 07:03:59: From: lasitha@codegen.net
Thu 2006-02-16 07:03:59: To: lasitha@cosmoforge.com
Thu 2006-02-16 07:03:59: Subject: TEST
Thu 2006-02-16 07:03:59: Message-ID: <op.s41ze8xahhhxqy@lasitha>
Thu 2006-02-16 07:03:59: MX-record resolution of [cosmoforge.com] in
progress (DNS Server:
161.76.9.1)...
Thu 2006-02-16 07:03:59: * P=010 D=cosmoforge.com TTL=(10)
MX=[mail.cosmoforge.com]
Thu 2006-02-16 07:03:59: Attempting MX: P=010 D=cosmoforge.com TTL=(10)
MX=[mail.cosmoforge.com]
Thu 2006-02-16 07:03:59: Attempting SMTP connection to
[mail.cosmoforge.com : 25]
Thu 2006-02-16 07:03:59: A-record resolution of [mail.cosmoforge.com] in
progress (DNS Server:
161.76.9.1)...
Thu 2006-02-16 07:03:59: D=mail.cosmoforge.com TTL=(10) A=[66.240.254.144]
Thu 2006-02-16 07:03:59: Attempting SMTP connection to [66.240.254.144 :
25]
Thu 2006-02-16 07:03:59: Waiting for socket connection...
Thu 2006-02-16 07:03:59: Socket connection established (161.76.28.49 :
3225 -> 66.240.254.144 :
25)
Thu 2006-02-16 07:03:59: Waiting for protocol initiation...
Thu 2006-02-16 07:04:00: <-- 220 ***************************************
Thu 2006-02-16 07:04:00: --> EHLO mail.codegen.it
Thu 2006-02-16 07:04:00: <-- 250-su93254144.cosmoforge.com
Thu 2006-02-16 07:04:00: <-- 250-PIPELINING
Thu 2006-02-16 07:04:00: <-- 250-SIZE 10240000
Thu 2006-02-16 07:04:00: <-- 250-VRFY
Thu 2006-02-16 07:04:00: <-- 250-ETRN
Thu 2006-02-16 07:04:00: <-- 250-AUTH PLAIN LOGIN
Thu 2006-02-16 07:04:00: <-- 250-AUTH=PLAIN LOGIN
Thu 2006-02-16 07:04:00: <-- 250 8BITMIME
Thu 2006-02-16 07:04:00: --> MAIL From:<lasitha@codegen.net> SIZE=1552
Thu 2006-02-16 07:04:00: <-- 250 Ok
Thu 2006-02-16 07:04:00: --> RCPT To:<lasitha@cosmoforge.com>
Thu 2006-02-16 07:04:00: <-- 554 <mail.codegen.it[161.76.28.49]>: Client
host rejected: Access
denied
--- End Transcript ---
: Message contains [1] file attachments

gimhan90
18th February 2006, 11:30
Now I can send mails :) , after had small modification in master.cf as follows.
I commented the below mnetioned line , niw i can send and receive mail.

Shold it be a security issuue?

#
# Postfix master process configuration file. For details on the format
# of the file, see the Postfix master(5) manual page.
#
# ================================================== ========================
# service type private unpriv chroot wakeup maxproc command + args
# (yes) (yes) (yes) (never) (100)
# ================================================== ========================
smtp inet n - n - - smtpd
#submission inet n - n - - smtpd
# -o smtpd_etrn_restrictions=reject
# -o smtpd_client_restrictions=permit_sasl_authenticate d,reject
#smtps inet n - n - - smtpd -o smtpd_tls_wrappermode=yes
# -o smtpd_tls_wrappermode=yes -o smtpd_sasl_auth_enable=yes
#submission inet n - n - - smtpd
# -o smtpd_etrn_restrictions=reject
# -o smtpd_enforce_tls=yes -o smtpd_sasl_auth_enable=yes
#628 inet n - n - - qmqpd
pickup fifo n - n 60 1 pickup
cleanup unix n - n - 0 cleanup
qmgr fifo n - n 300 1 qmgr
#qmgr fifo n - n 300 1 oqmgr
#tlsmgr unix - - n 1000? 1 tlsmgr
rewrite unix - - n - - trivial-rewrite
bounce unix - - n - 0 bounce
defer unix - - n - 0 bounce
trace unix - - n - 0 bounce
verify unix - - n - 1 verify
flush unix n - n 1000? 0 flush
proxymap unix - - n - - proxymap
smtp unix - - n - - smtp
# When relaying mail as backup MX, disable fallback_relay to avoid MX loops
relay unix - - n - - smtp
-o fallback_relay=
# -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
showq unix n - n - - showq
error unix - - n - - error
discard unix - - n - - discard
local unix - n n - - local
virtual unix - n n - - virtual
lmtp unix - - n - - lmtp
anvil unix - - n - 1 anvil
#localhost:10025 inet n - n - - smtpd -o content_filter=
scache unix - - n - 1 scache
#
# ================================================== ==================
# Interfaces to non-Postfix software. Be sure to examine the manual
# pages of the non-Postfix software to find out what options it wants.
#
# Many of the following services use the Postfix pipe(8) delivery
# agent. See the pipe(8) man page for information about ${recipient}
# and other message envelope options.
# ================================================== ==================
#
# maildrop. See the Postfix MAILDROP_README file for details.
# Also specify in main.cf: maildrop_destination_recipient_limit=1
#
maildrop unix - n n - - pipe
flags=DRhu user=vmail argv=/usr/local/bin/maildrop -d ${recipient}
cyrus unix - n n - - pipe
user=cyrus argv=/usr/lib/cyrus/bin/deliver -e -r ${sender} -m ${extension} ${user}
uucp unix - n n - - pipe
flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
ifmail unix - n n - - pipe
flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
bsmtp unix - n n - - pipe
flags=Fq. user=foo argv=/usr/local/sbin/bsmtp -f $sender $nexthop $recipient
procmail unix - n n - - pipe
flags=R user=nobody argv=/usr/bin/procmail -t -m /etc/procmailrc ${sender} ${recipient}
#tlsmgr unix - - n 1000? 1 tlsmgr
#tlsmgr unix - - n 1000? 1 tlsmgr

falko
18th February 2006, 12:33
Shold it be a security issuue?

No, it's not a security issue. :)