PDA

View Full Version : Qouta check problem :)


Nejko
13th January 2006, 14:47
Here's my fstab:

# This file is edited by fstab-sync - see 'man fstab-sync' for details
LABEL=/ / ext3 defaults,usrquota,grpquota 1 1
/dev/VolGroup00/LogVol00 / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
/dev/devpts /dev/pts devpts gid=5,mode=620 0 0
/dev/shm /dev/shm tmpfs defaults 0 0
/dev/proc /proc proc defaults 0 0
/dev/sys /sys sysfs defaults 0 0
/dev/VolGroup00/LogVol01 swap swap defaults 0 0
/dev/hdc /media/cdrom auto pamconsole,exec,noauto,managed 0 0


What did i wrong? Couse i get that error:


[root@localhost ~]# quotacheck -avugm
quotacheck: Error checking device name: LABEL=/
quotacheck: Can't get device name for LABEL=/
quotacheck: Can't find filesystem to check or filesystem not mounted with quota option.
[root@localhost ~]#


Thanx for all answers!

till
13th January 2006, 15:23
I'am not very familar with LVM + Quota, but have you tried this:

LABEL=/ / ext3 defaults 1 1
/dev/VolGroup00/LogVol00 / ext3 defaults,usrquota,grpquota 1 1

falko
13th January 2006, 15:24
Here's my fstab:

# This file is edited by fstab-sync - see 'man fstab-sync' for details
LABEL=/ / ext3 defaults,usrquota,grpquota 1 1
/dev/VolGroup00/LogVol00 / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
/dev/devpts /dev/pts devpts gid=5,mode=620 0 0
/dev/shm /dev/shm tmpfs defaults 0 0
/dev/proc /proc proc defaults 0 0
/dev/sys /sys sysfs defaults 0 0
/dev/VolGroup00/LogVol01 swap swap defaults 0 0
/dev/hdc /media/cdrom auto pamconsole,exec,noauto,managed 0 0



/etc/fstab seems to be messed up. Try this one:
/dev/VolGroup00/LogVol00 / ext3 defaults,usrquota,grpquota 1 1
LABEL=/boot /boot ext3 defaults 1 2
/dev/devpts /dev/pts devpts gid=5,mode=620 0 0
/dev/shm /dev/shm tmpfs defaults 0 0
/dev/proc /proc proc defaults 0 0
/dev/sys /sys sysfs defaults 0 0
/dev/VolGroup00/LogVol01 swap swap defaults 0 0
/dev/hdc /media/cdrom auto pamconsole,exec,noauto,managed 0 0
and then run this:

touch /aquota.user /aquota.group
chmod 600 /aquota.*
mount -o remount /
quotacheck -avugm
quotaon -avug

Nejko
13th January 2006, 15:39
i deleted mine, and replaced with yours, but still same error...:confused:

edit: i didn't restart :D

now i get:


[root@localhost ~]# quotacheck -avugm
quotacheck: WARNING - Quotafile //aquota.user was probably truncated. Can't sav e quota settings...
quotacheck: WARNING - Quotafile //aquota.group was probably truncated. Can't sa ve quota settings...
quotacheck: Scanning /dev/mapper/VolGroup00-LogVol00 [/] done
quotacheck: Checked 13840 directories and 140582 files
[root@localhost ~]#

Nejko
13th January 2006, 22:28
ok, got 'em workin' wia webadmin :=)

falko
13th January 2006, 23:11
now i get:


[root@localhost ~]# quotacheck -avugm
quotacheck: WARNING - Quotafile //aquota.user was probably truncated. Can't sav e quota settings...
quotacheck: WARNING - Quotafile //aquota.group was probably truncated. Can't sa ve quota settings...
quotacheck: Scanning /dev/mapper/VolGroup00-LogVol00 [/] done
quotacheck: Checked 13840 directories and 140582 files
[root@localhost ~]#
That's the normal behaviour if you run quotacheck -avugm for the first time. You should have run quotaon -avug afterwards, then you wouldn't have needed Webmin. ;)