PDA

View Full Version : Mysql error (2005)


zalo
2nd January 2006, 21:47
Hello

I`m getting this error every time i try to run the install script. Does anybody know what is causing this error or how to fix it??


Mandriva 2006
--------------------------------------------------------------------------
for d in uudeview.1 uuenview.1 xdeview.1 ; do \
./install-sh -c -m 644 ./man/$d /home/admispconfig/ispconfig/tools/uudeview/man/man1/$d ; \
done
All prerequisites are fulfilled.
Here we go...
Please enter your MySQL server:localhost
Please enter your MySQL user:ispconfig
Please enter your MySQL password:
ERROR 2005 (HY000): Unknown MySQL server host ' localhost' (2)
ERROR: The provided MySQL password is wrong! The installation routine stops here!
[root@webserver install_ispconfig]#
--------------------------------------------------------------------------

till
2nd January 2006, 22:28
This means that either your mysql server is not installed, not running or not listening on localhost. If your mysql server is running, you maybe have the "skip-networking" option in you mysql my.cnf config file.

zalo
2nd January 2006, 22:40
Mysql is installed and running:
-mysqld (pid 2033) is running...

I have removed --skip-networking from the file:
/etc/sysconfig/mysqld

I dident find any --skip-networking in the my.cnf file

How do i make mysql listen to "localhost"

falko
2nd January 2006, 23:10
Please restart MySQL. Then post the output of netstat -tap here as well as the content of /etc/hosts.

zalo
2nd January 2006, 23:37
[root@webserver salomon]# /etc/init.d/mysqld restart
Stopping MySQL: [ OK ]
Starting MySQL: [ OK ]
[root@webserver salomon]# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:imaps *:* LISTEN 3760/xinetd
tcp 0 0 *:pop3s *:* LISTEN 3760/xinetd
tcp 0 0 *:mysql *:* LISTEN 20206/mysqld
tcp 0 0 server1.zalo.net:10026 *:* LISTEN 3906/master
tcp 0 0 *:pop3 *:* LISTEN 3760/xinetd
tcp 0 0 *:imap *:* LISTEN 3760/xinetd
tcp 0 0 *:sunrpc *:* LISTEN 2098/portmap
tcp 0 0 *:http *:* LISTEN 4113/httpd
tcp 0 0 *:10000 *:* LISTEN 3962/perl
tcp 0 0 *:ftp *:* LISTEN 3930/proftpd: (acce
tcp 0 0 *:smtp *:* LISTEN 3906/master
tcp 0 0 *:https *:* LISTEN 4113/httpd
tcp 0 0 *:ssh *:* LISTEN 3717/sshd
tcp 0 0 ::ffff:192.168.2.31:ssh ::ffff:192.168.2.51:3431 ESTABLISHED 30403/sshd: salomon
tcp 0 0 ::ffff:192.168.2.31:ssh ::ffff:192.168.2.51:3333 ESTABLISHED 9661/sshd: salomon
[root@webserver salomon]#
--------------------------------------------------------------------------
etc/hosts

127.0.0.1 server1.zalo.net server1 localhost

--------------------------------------------------------------------------
Do i need to write anything in \etc\hosts.allow???

falko
2nd January 2006, 23:48
Looks ok. Can you connect to MySQL when you run
mysql -h localhost -u root -p on the shell?


All prerequisites are fulfilled.
Here we go...
Please enter your MySQL server:localhost
Please enter your MySQL user:ispconfig
Please enter your MySQL password:
ERROR 2005 (HY000): Unknown MySQL server host ' localhost' (2)
ERROR: The provided MySQL password is wrong! The installation routine stops here!
[root@webserver install_ispconfig]#

When you install ISPConfig you should enter root as MySQL user instead of ispconfig!

zalo
2nd January 2006, 23:53
Looks ok. Can you connect to MySQL when you run
mysql -h localhost -u root -p on the shell?


Yes,that worked fine


When you install ISPConfig you should enter root as MySQL user instead of ispconfig!

I have tried whih user "ispconfig" and "root", but i get the same error same error

falko
3rd January 2006, 01:35
I have tried whih user "ispconfig" and "root", but i get the same error same error
Have you tried to install ISPConfig again now that you have started MySQL?

zalo
3rd January 2006, 15:53
I fixed it, i had to comment out the line in /etc/sysconfig/mysqld
like this:

# (oe) Remove --skip-networking to enable network access from
# non local clients. Access from localhost will still work.
#MYSQLD_OPTIONS=""

I had only removed the --skip-networking text not the hole line

I also added
#Mysql
mysqld 127.0.0.1
in hosts.allow
--------------------------------------------------------------------------

But it dindent last long at the next step i got a new error, can somebody help me?? :confused: (almost there)

done
All prerequisites are fulfilled.
Here we go...
Please enter your MySQL server:localhost
Please enter your MySQL user:root
Please enter your MySQL password:
OK
Please enter a name for the ISPConfig database (e.g. db_ispconfig):ispconfigdb
Please enter the IP address of the ISPConfig web (e.g. 192.168.0.1):192.168.2.31
ERROR: The IP address you provided is not reachable! The installation routine stops here!
[root@webserver install_ispconfig]#

falko
3rd January 2006, 18:28
Make sure that this IP address can be pinged. Might be your firewall that's blocking pings.
http://www.howtoforge.com/forums/showthread.php?t=839