PDA

View Full Version : Perl error message


namit
1st January 2006, 16:05
Hey can anyone help me


/etc/cron.weekly/man-db:
mandb: can't set the locale; make sure $LC_* and $LANG are correct
/etc/cron.weekly/sysklogd:
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "en_IE:en_US:en_GB:en",
LC_ALL = "<locale>",
LANG = "en_IE@euro"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").


Can anyone help

O keep getting this email every day

falko
1st January 2006, 16:47
Which distribution do you use? On Debian you can install the missing locales by running dpkg-reconfigure locales

namit
1st January 2006, 17:09
Ok did that but when ran it agina i got this message

Generating locales...
en_IE.ISO-8859-15@euro... done
en_IE.ISO-8859-1... done
Generation complete.
mailman:/# dpkg-reconfigure locales
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "en_IE:en_US:en_GB:en",
LC_ALL = "<locale>",
LANG = "en_IE@euro"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_CTYPE to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_MESSAGES to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_ALL to default locale: No such file or directory


Verstion
This is perl, v5.8.4 built for i386-linux-thread-multi

yes am using debian

I did loose all my users so this may because of this

till
1st January 2006, 18:49
Have you run "dpkg-reconfigure locales" as root user?

namit
1st January 2006, 19:07
yes i have

falko
1st January 2006, 19:21
This seems to be the same error I describe in my Xen tutorial: http://www.howtoforge.com/perfect_xen_setup_debian_ubuntu_p4:

Now we set up our locales. If we do not do this now, we will see some ugly warnings during base-config like these:

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "en_DE:en_US:en_GB:en",
LC_ALL = (unset),
LANG = "en_US"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory

They are not serious, but ugly... So we run

apt-get install localeconf

Select locales to install (e.g. en_US ISO-8859-1) and select the standard locale (e.g. en_US).

You will be asked a few questions:

Manage locale configuration files with debconf? <-- Yes
Environment settings that should override the default locale: <-- do not select anything
Replace existing locale configuration files? <-- Yes
Default system locale: <-- e.g. en_US ISO-8859-1

So I guess running apt-get install localeconf might be a good idea.

namit
1st January 2006, 19:30
na that did not work still same old same old

just says
"and lot lot more errors"
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory

Its not that its not ugly its just that i keep getting this email from cron saying the error message see above

namit
4th January 2006, 03:56
went into /etc/envirement and set all values to ""

just types in
LC_CTYPE = ""

etc etc etc

Thanks

hammeraus001
10th February 2006, 03:26
I just hasd the same issue and have found an easy solution. It's all in the error message, especially the line:

LANGUAGE = "en_DE:en_US:en_GB:en",

When you either "apt-get install locales" or "dpkg-reconfigure locales", you are asked to select the required locales from a large list.

I went through and selected the ones that I needed. The error still appeared. I then redid it and made sure that the languages listed were the ones I selected, which would be "en_DE", "en_US" and "en_GB" in your case. Once I did that the errors vanished.

charles_elwood
18th April 2007, 08:28
It's also useful to check you have language-pack-?? installed, as that provides the actual locales. English speakers will most likely want language-pack-en.

wwwalker
21st April 2007, 18:44
I found how to fix the Perl problem in FreeBSD:

http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/using-localization.html

Set the environment variables LANG and MM_CHARSET in /etc/csh.login. (There are other places to do this but I used this - it worked!)

The list of locales are in:

/usr/share/locale

Make sure you spell the locale exactly. If you get the spelling wrong (mix up - and _) it will not work.

Colin Dean
7th August 2007, 22:40
It's also useful to check you have language-pack-?? installed, as that provides the actual locales. English speakers will most likely want language-pack-en.

This was the problem in my case. language-pack-en-base was not installed.
apt-get install language-pack-en-base fixed it.

the_g_bomb
11th October 2007, 14:40
I found that a mixture of these cleared up this problem for me...

apt-get install locales localeconf

Select locales to be generated.

en_GB ISO-8859-1
en_GB.ISO-8859-15 ISO-8859-15
en_GB.UTF-8 UTF-8
<-- Ok

Which locale should be the default in the system environment?<-- en_GB

Manage locale configuration files with debconf? <-- Yes
If you do not wish to use the default system locale… <-- Ok
Environment settings that should override the default locale: <-- Blank
Replace existing locale configuration files? <-- Yes
If you are not sure … always supported. <-- Ok
Default system locale: <-- en_GB.UTF-8 UTF-8

Obviously you will have to choose your own countries locales, but installing the locales and localeconf is the way the way to go.