PDA

View Full Version : Webalizer tab files


matheron
9th December 2005, 13:54
Hello!!

I would like to use the "webalizer" tab files to use the results generated by this software in my own system. Can anybody explain me what should I do to get the webalizer results in tab files? I've tried the sample.conf config file file provided by people from webalizer but it doesn't provide me the tab files.

Thank you!

falko
9th December 2005, 17:50
What are tab files?

matheron
9th December 2005, 20:47
Sorry. Tab files = tabulatted files easy to parse

falko
10th December 2005, 14:54
On http://www.phy.duke.edu/~rgb/webalize/webalizer.conf I found this:

# The Dump* keywords allow the dumping of Sites, URL's, Referrers
# User Agents, Usernames and Search strings to seperate tab delimited
# text files, suitable for import into most database or spreadsheet
# programs.

# DumpPath specifies the path to dump the files. If not specified,
# it will default to the current output directory. Do not use a
# trailing slash ('/').

#DumpPath /var/lib/httpd/logs

# The DumpHeader keyword specifies if a header record should be
# written to the file. A header record is the first record of the
# file, and contains the labels for each field written. Normally,
# files that are intended to be imported into a database system
# will not need a header record, while spreadsheets usually do.
# Value can be either 'yes' or 'no', with 'no' being the default.

#DumpHeader no

# DumpExtension allow you to specify the dump filename extension
# to use. The default is "tab", but some programs are pickey about
# the filenames they use, so you may change it here (for example,
# some people may prefer to use "csv").

#DumpExtension tab

# These control the dumping of each individual table. The value
# can be either 'yes' or 'no'.. the default is 'no'.

#DumpSites no
#DumpURLs no
#DumpReferrers no
#DumpAgents no
#DumpUsers no
#DumpSearchStr no

# End of configuration file... Have a nice day!

So you'll have to play around with these settings a little bit... :)

matheron
11th December 2005, 14:26
Thank you Falko. I've already tried to change this parameteres but it didn't work. Now, don't understand why, it works, so thank you!!!