PDA

View Full Version : Users can not log in to webmail or ftp


sambo
29th July 2005, 00:00
Hi,

- followed the tut for Debian 3.1 - great!!
- installed ISPconfig - great!!
- managed to create clients and sites
- added emsil to domains

Users can not log in!!!

Can someone imagine what is wrong??

Regards,
Sammi

falko
29th July 2005, 00:59
Are your FTP and your POP3 server running? Did you activate FTP for the web site?

till
29th July 2005, 09:34
Users can not log in!!!

Can someone imagine what is wrong??


Can not login where?

If you mean that they can not login into the controlpanel webinterface,
the login is:

https:// YOURDOMAIN.COM:81/mailuser/

If you want that a client can login to manage his site, you have
to enter the login details (username and password) in the client
form on the tab "login data".

The login for clients is: https:// YOURDOMAIN.COM:81/

If you want that a reseller can login to manage his sites and clients,
you have to enter the login details (username and password) in the
reseller form on the tab "login data".

The login for resellers is: https:// YOURDOMAIN.COM:81/

sambo
29th July 2005, 11:36
Thank you for quick response.

They can log into the control panel. They can not log into:

- webmail (i installed UebiMiau!)
- pop3 with outlook
- ftp

It looks like the user that the control panel creates gets a bad password.

Sammi

sambo
29th July 2005, 11:37
Falko:

Yes they are at least reported as online in the Control panel and I have enabled FTP for the site.

Sammi

falko
29th July 2005, 11:45
Thank you for quick response.

They can log into the control panel. They can not log into:

- webmail (i installed UebiMiau!)
- pop3 with outlook
- ftp

It looks like the user that the control panel creates gets a bad password.

Sammi

When you installed Debian, are you sure you chose shadow passwords instead of md5 passwords? Because ISPConfig uses shadow passwords, but if your system relies on md5 passwords then it can't work...

But it could also be a problem with your firewall blocking access to FTP and POP3.
As for webmail: did you install the ISPConfig webmail package, or did you install Uebimiau yourself?

sambo
31st July 2005, 16:29
Hi,

I used this guide (http://www.howtoforge.com/perfect_setup_debian_sarge) to install debian for ipsconfig as I am not an experienced linux user. The guide mentioned nothing about using shadow password so I don't think I did that.

Can that be set after I have finished the installation or do I have to install again?

Sammi

morphinex
3rd August 2005, 10:06
I have the same problem. I followed the Perfect-guide, and after a few hiccups now everything seems to work perfectly :) - except mail.

* UebiMail fails (bad username or password)
* POP access does the same
* SMTP seems to allow anyone to send without specifying a password

The users I've created in ispconfig exist in /etc/passwd and /etc/shadow...

Any help is greatly appreciated!

till
3rd August 2005, 10:41
I have the same problem. I followed the Perfect-guide, and after a few hiccups now everything seems to work perfectly :) - except mail.

* UebiMail fails (bad username or password)
* POP access does the same

The users I've created in ispconfig exist in /etc/passwd and /etc/shadow...

Any help is greatly appreciated!

did you get any errors in your mail.log?

(on DEBIAN):

/var/log/mail.log

* SMTP seems to allow anyone to send without specifying a password

Have you tried to send email to addresses that are not configured on the same server? Any mailserver must accept email for local addresses without password, otherwise you wont get any mail.

morphinex
3rd August 2005, 12:33
This is all I get in mail.log:

Aug 3 12:28:32 localhost ipop3d[6185]: pop3 service init from 193.214.121.102
Aug 3 12:28:32 localhost ipop3d[6185]: Logout user=??? host=[193.214.121.102]

Debugging info from UebiMiau (via POP):

<- +OK POP3 localhost.localdomain v2003.83 server ready
-> USER opplev.no_even
<- -ERR Unknown AUTHORIZATION state command

And, yeah - I've tried sending to users outside the system. The email is delivered successfully nontheless...

falko
3rd August 2005, 13:02
This is all I get in mail.log:

Aug 3 12:28:32 localhost ipop3d[6185]: pop3 service init from 193.214.121.102
Aug 3 12:28:32 localhost ipop3d[6185]: Logout user=??? host=[193.214.121.102]

Debugging info from UebiMiau (via POP):

<- +OK POP3 localhost.localdomain v2003.83 server ready
-> USER opplev.no_even
<- -ERR Unknown AUTHORIZATION state command

And, yeah - I've tried sending to users outside the system. The email is delivered successfully nontheless...

Can you try and send yourself an email? My guess is that the mailbox hasn't been created yet, and I think it will be created when the first email arrives.

morphinex
3rd August 2005, 13:43
I searched around a bit and found something about Sarge final not accepting plain logins in pop... Added a line in /etc/c-client.cf and boom! it worked like a charm...


Now all that remains is the smtp problem... I've tried both without authenticating and with authenticating with the wrong credentials. Both works - also with external recipients...

Any clues?

falko
3rd August 2005, 14:02
I searched around a bit and found something about Sarge final not accepting plain logins in pop... Added a line in /etc/c-client.cf and boom! it worked like a charm...


Now all that remains is the smtp problem... I've tried both without authenticating and with authenticating with the wrong credentials. Both works - also with external recipients...

Any clues?

Can you run
telnet localhost 25 and then type ehlo localhost (to leave the prompt type quit)? Can you post the output here?

morphinex
3rd August 2005, 14:46
Trying 127.0.0.1...
Connected to localhost.localdomain.
Escape character is '^]'.
220 localhost ESMTP Postfix (Debian/GNU)
ehlo localhost
250-localhost
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250 8BITMIME

I tried to go a bit further, by using AUTH PLAIN encryptedpass with a password from perl -MMIME::Base64 -e 'print encode_base64(.....);' and it can successfully authenticate only if the password matches.

So it seems I haven't disabled unauthenticated logins? In that case - how can I fix it?

falko
3rd August 2005, 15:10
So SMTP-AUTH is working. One question: when you tried to send emails over that server, were the recipient addresses on the same server, or are that external email addresses?

morphinex
3rd August 2005, 15:13
I've tried both sending to users on my machine, and mailadresses on other computers (without any connection to my system). Both works...

BTW: Here's my postfix config:

See /usr/share/postfix/main.cf.dist for a commented, more complete version

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

myhostname = localhost
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
relayhost =
mynetworks = 127.0.0.0/8
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
smtpd_sasl_local_domain = $myhostname
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_ relay_domains
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

virtual_maps = hash:/etc/postfix/virtusertable

mydestination = /etc/postfix/local-host-names

falko
3rd August 2005, 16:04
And you're sure that the domains of the external email addresses are not in /etc/postfix/local-host-names?

morphinex
3rd August 2005, 19:07
Heh... Dunno what's changed - but now it seems to work :)

Thanks so much for the great suggestions - and for making such a beauuutiful guide to installing the system...


Keep up the good work!

fastcooler
21st October 2005, 01:35
Dear Staff,

I also have same problem as Morphinex...I can't access webmail (installed through Tools), because I get user name or pw wrong (I created a user, with email, ftp, webspace, etc).

This is Telnet test:


Trying 127.0.0.1...
Connected to x-174-30-41.vps.virtuo.it.
Escape character is '^]'.
220 x-174-30-41.vps.virtuo.it ESMTP Postfix (Debian/GNU)
ehlo localhost
250-x-174-30-41.vps.virtuo.it
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250 8BITMIME
quit
221 Bye


I also tried to send and email from an external link to new address.

PS: FTP works fine!

Thanks
Mark

fastcooler
21st October 2005, 02:33
Solved!

I haven't selected this option:

Server>Settings>email:

Maildir

Now it works fine!

Mark