PDA

View Full Version : The Inperfect Setup for me - Fedora Core 4.


dstme
13th November 2005, 14:32
Hi I'm dead new to Linux, so sorry if I ask stupid questions. I did look through the forum before posting.

I tried to rpm -ivh http://ftp.freshrpms.net/pub/fedora/linux/extras/4/i386/apt-0.5.15cnc7-6.fc4.i386.rpm

But I got error message:
[root@chick ~]# rpm -ivh http://ftp.freshrpms.net/pub/fedora/linux/extras/4/i386/apt-0.5.15cnc7-6.fc4.i386.rpm
Retrieving http://ftp.freshrpms.net/pub/fedora/linux/extras/4/i386/apt-0.5.15cnc7-6.fc4.i386.rpm
error: /var/tmp/rpm-xfer.Xz4sXE: headerRead failed: hdr blob(42126): BAD, read returned 7736
error: /var/tmp/rpm-xfer.Xz4sXE cannot be installed

Any help will much appreciated!:rolleyes:

till
13th November 2005, 15:02
Hi I'm dead new to Linux, so sorry if I ask stupid questions. I did look through the forum before posting.

I tried to rpm -ivh http://ftp.freshrpms.net/pub/fedora/linux/extras/4/i386/apt-0.5.15cnc7-6.fc4.i386.rpm

But I got error message:
[root@chick ~]# rpm -ivh http://ftp.freshrpms.net/pub/fedora/linux/extras/4/i386/apt-0.5.15cnc7-6.fc4.i386.rpm
Retrieving http://ftp.freshrpms.net/pub/fedora/linux/extras/4/i386/apt-0.5.15cnc7-6.fc4.i386.rpm
error: /var/tmp/rpm-xfer.Xz4sXE: headerRead failed: hdr blob(42126): BAD, read returned 7736
error: /var/tmp/rpm-xfer.Xz4sXE cannot be installed

Any help will much appreciated!:rolleyes:


For me it looks like the rpm package was corrupted during download. Have you executed the command as root user?

You can try to download the package first and the install it:

wget http://ftp.freshrpms.net/pub/fedora/linux/extras/4/i386/apt-0.5.15cnc7-6.fc4.i386.rpm
rpm -ivh apt-0.5.15cnc7-6.fc4.i386.rpm

dstme
13th November 2005, 15:14
For me it looks like the rpm package was corrupted during download. Have you executed the command as root user?

You can try to download the package first and the install it:

wget http://ftp.freshrpms.net/pub/fedora/linux/extras/4/i386/apt-0.5.15cnc7-6.fc4.i386.rpm
rpm -ivh apt-0.5.15cnc7-6.fc4.i386.rpm

Thanks for quick reply. Ya, I execute the command as root user.
Where do I download to and how then to install it (how and where?), please.

till
13th November 2005, 15:16
Thanks for quick reply. Ya, I execute the command as root user.
Where do I download to and how then to install it (how and where?), please.

I posted it already in my post:

wget http://ftp.freshrpms.net/pub/fedora/linux/extras/4/i386/apt-0.5.15cnc7-6.fc4.i386.rpm
rpm -ivh apt-0.5.15cnc7-6.fc4.i386.rpm

The wget command will download the package to your disk and the rpm command installs it.

dstme
13th November 2005, 15:40
Thanks. I have started but it has stuck in 2% for almost 15mins. Does it takes long time to download. I'm using 512k broadband.

[root@chick ~]# wget http://ftp.freshrpms.net/pub/fedora/linux/extras/4/i386/apt-0.5.15cnc7-6.fc4.i386.rpm
--21:29:59-- http://ftp.freshrpms.net/pub/fedora/linux/extras/4/i386/apt-0.5.15cnc7-6.fc4.i386.rpm
=> `apt-0.5.15cnc7-6.fc4.i386.rpm'
Resolving ftp.freshrpms.net... 193.1.193.67
Connecting to ftp.freshrpms.net[193.1.193.67]:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 919,895 [application/x-redhat-package-manager]

2% [> ] 21,724 696.71B/s ETA 26:40

dstme
13th November 2005, 15:43
Sorry, I think it is slow only, now 9%

dstme
13th November 2005, 17:52
Hi, if I may, I have another question. Right now I have restart my MySql, then as the tutorial said run mysqladmin -u root password yourrootsqlpassword.

I not sure if you mean to replace "password" for my root password and "yourrootsqlpassword" for mysql password. Is this correct?:o

falko
13th November 2005, 18:32
Hi, if I may, I have another question. Right now I have restart my MySql, then as the tutorial said run mysqladmin -u root password yourrootsqlpassword.

I not sure if you mean to replace "password" for my root password and "yourrootsqlpassword" for mysql password. Is this correct?:o
No, only replace yourrootsqlpassword. If your password is secret, then the command would be mysqladmin -u root password secret

dstme
13th November 2005, 18:52
Thanks falko, I have error: Can you help, please.
[root@chick named]# apt-get install cyrus-sasl cyrus-sasl-devel cyrus-sasl-gssapi
Reading Package Lists... Done
Building Dependency Tree... Done
cyrus-sasl is already the newest version.
cyrus-sasl-devel is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
cyrus-sasl-gssapi: Depends: cyrus-sasl (= 2.1.15-6) but 2.1.20-5 is to be installed
E: Broken packages


PLease ignore above. Just found the solution when searching your forum thread. Thnks!

dstme
13th November 2005, 20:07
OK...almost done until hit with problem. I have follow every steps but when I try to telnet localhost 25, get closed. Help please....

[root@chick ssl]# telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
220 chick.roystan.com ESMTP Postfix
421 chick.roystan.com Error: timeout exceeded
Connection closed by foreign host.

falko
13th November 2005, 22:57
OK...almost done until hit with problem. I have follow every steps but when I try to telnet localhost 25, get closed. Help please....
When you see the line
220 chick.roystan.com ESMTP Postfix
type ehlo localhost and afterwards quit instead of waiting.

dstme
14th November 2005, 05:10
I should have read more carefully. Thanks. Bare with me. I'm still newbie in Linux.
Another problem: I get alot of connection errors when installing Apache with PHP5. Any other way?:o

[root@chick ssl]# apt-get install php php-devel php-gd php-imap php-ldap php-mysql php-odbc php-pear php-xmlrpc curl curl-devel perl-libwww-perl ImageMagick
Reading Package Lists... Done
Building Dependency Tree... Done
curl is already the newest version.
curl-devel is already the newest version.
perl-libwww-perl is already the newest version.
The following extra packages will be installed:
libc-client (2002e-9)
The following packages will be upgraded
ImageMagick (6.2.2.0-2 => 6.2.2.0-3.fc4.0)
php (5.0.4-10 => 5.0.5-2.1)
php-ldap (5.0.4-10 => 5.0.5-2.1)
php-pear (5.0.4-10 => 5.0.5-2.1)
The following NEW packages will be installed:
libc-client (2002e-9)
php-devel (5.0.5-2.1)
php-gd (5.0.5-2.1)
php-imap (5.0.5-2.1)
php-mysql (5.0.5-2.1)
php-odbc (5.0.5-2.1)
php-xmlrpc (5.0.5-2.1)
4 upgraded, 7 newly installed, 0 removed and 252 not upgraded.
Need to get 6866kB of archives.
After unpacking 3412kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://ayo.freshrpms.net fedora/linux/4/i386/updates ImageMagick 6.2.2.0-3.fc4.0 [2803kB]
Err http://ayo.freshrpms.net fedora/linux/4/i386/updates ImageMagick 6.2.2.0-3.fc4.0
Error reading from server Remote end closed connection
Get:2 http://ayo.freshrpms.net fedora/linux/4/i386/core libc-client 2002e-9 [479kB]
Err http://ayo.freshrpms.net fedora/linux/4/i386/core libc-client 2002e-9
Error reading from server Remote end closed connection
Get:3 http://ayo.freshrpms.net fedora/linux/4/i386/tupdates php-pear 5.0.5-2.1 [383kB]
Err http://ayo.freshrpms.net fedora/linux/4/i386/tupdates php-pear 5.0.5-2.1
Error reading from server Remote end closed connection
Get:4 http://ayo.freshrpms.net fedora/linux/4/i386/tupdates php-ldap 5.0.5-2.1 [28.7kB]
Get:5 http://ayo.freshrpms.net fedora/linux/4/i386/tupdates php 5.0.5-2.1 [2473kB]
Err http://ayo.freshrpms.net fedora/linux/4/i386/tupdates php 5.0.5-2.1
Error reading from server Remote end closed connection
Get:6 http://ayo.freshrpms.net fedora/linux/4/i386/tupdates php-devel 5.0.5-2.1 [406kB]
Err http://ayo.freshrpms.net fedora/linux/4/i386/tupdates php-devel 5.0.5-2.1
Error reading from server Remote end closed connection
Get:7 http://ayo.freshrpms.net fedora/linux/4/i386/tupdates php-gd 5.0.5-2.1 [103kB]
Get:8 http://ayo.freshrpms.net fedora/linux/4/i386/tupdates php-imap 5.0.5-2.1 [44.4kB]
Get:9 http://ayo.freshrpms.net fedora/linux/4/i386/tupdates php-mysql 5.0.5-2.1 [61.3kB]
Err http://ayo.freshrpms.net fedora/linux/4/i386/tupdates php-mysql 5.0.5-2.1
Connection timed out
Get:10 http://ayo.freshrpms.net fedora/linux/4/i386/tupdates php-odbc 5.0.5-2.1 [36.2kB]
Get:11 http://ayo.freshrpms.net fedora/linux/4/i386/tupdates php-xmlrpc 5.0.5-2.1 [48.6kB]
Err http://ayo.freshrpms.net fedora/linux/4/i386/tupdates php-xmlrpc 5.0.5-2.1
Error reading from server Remote end closed connection
Fetched 213kB in 19m48s (179B/s)
Failed to fetch http://ayo.freshrpms.net/fedora/linux/4/i386/RPMS.updates/ImageMagick-6.2.2.0-3.fc4.0.i386.rpm Error reading from server Remote end closed connection
Failed to fetch http://ayo.freshrpms.net/fedora/linux/4/i386/RPMS.core/libc-client-2002e-9.i386.rpm Error reading from server Remote end closed connection
Failed to fetch http://ayo.freshrpms.net/fedora/linux/4/i386/RPMS.tupdates/php-pear-5.0.5-2.1.i386.rpm Error reading from server Remote end closed connection
Failed to fetch http://ayo.freshrpms.net/fedora/linux/4/i386/RPMS.tupdates/php-5.0.5-2.1.i386.rpm Error reading from server Remote end closed connection
Failed to fetch http://ayo.freshrpms.net/fedora/linux/4/i386/RPMS.tupdates/php-devel-5.0.5-2.1.i386.rpm Error reading from server Remote end closed connection
Failed to fetch http://ayo.freshrpms.net/fedora/linux/4/i386/RPMS.tupdates/php-mysql-5.0.5-2.1.i386.rpm Connection timed outFailed to fetch http://ayo.freshrpms.net/fedora/linux/4/i386/RPMS.tupdates/php-xmlrpc-5.0.5-2.1.i386.rpm Error reading from server Remote end closed connection
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?


I run again twice, and still get the same error messages.

Before I forget. I like to use my local time for my server. Do I have to run:
rdate -s 128.2.136.71 or rdate -s 127.0.0.1 ?

till
14th November 2005, 11:01
The problem is that the connections to ayo.freshrpms.net timed out during package installation.

Rdate: you cannot run rdate -s 127.0.0.1 succesfully without having a timeserver installed locally. If you do not want to use time synchronization, dont use rdate at all.

Remark: Please do not post unrelated topics to an existing thread. Please make a new thread for every new topic, its easier to read and poeple searching the forums dont get confused :)

dstme
14th November 2005, 11:32
Apologies if I have put in wrong thread.:o I'm trying to install Fedora C4 and all errors encounted while following Perfect setup fedora core 4, so I put all questions in same thread. :(

If I may put in the same thread, so far, I have tried many time to apt -get install Apache with PHP5 (according to page 4 - perfect_setup_fedora_core_4_p4), all time-out. Basically I'm have been trying apt -get for the whole day and everytime it timed out. Is there another command to install or other sites to install?

till
14th November 2005, 12:12
The question is, is your internet connection so slow? I Can reach ayo.freshrpms.net very good and the connection is really fast (> 100 KB /sec).

Maybe you will have to look for a mirror server that is better connected to your internet service provider.

falko
14th November 2005, 12:20
If I may put in the same thread, so far, I have tried many time to apt -get install Apache with PHP5 (according to page 4 - perfect_setup_fedora_core_4_p4), all time-out. Basically I'm have been trying apt -get for the whole day and everytime it timed out. Is there another command to install or other sites to install?
Might also be a firewall issue...

dstme
14th November 2005, 12:25
Ok, can you suggest any mirror sites closer to Singapore? and command should I use and do I edit /etc/apt/sources.list.?

till
14th November 2005, 12:59
Ok, can you suggest any mirror sites closer to Singapore? and command should I use and do I edit /etc/apt/sources.list.?

I never needed a mirror, so i do not have tested this:

http://ayo.mirrorservice.org/

There are some full mirrors at the end of the page. Please try them even if they are not nearer to you, but maybe your ISP has a better connection to them.

1) Make a backup copy of /etc/apt/sources.list
2) Edit /etc/apt/sources.list, and replace all occurrences of ayo.freshrpms.net with e.g. ayo.ie.freshrpms.net
3) run apt-get update
4) Try again to install the rpm packages.

dstme
14th November 2005, 14:01
Hi Falko, Till , I have disable my Firewall on my router and still not looking good. I'm runnuing apt-get update and seems only fews are able to update. Do I just retry again or better change again to another mirror sites? And if I'm lucky able to update, what is the next steps? Do I just run "apt-get install php php-devel php-gd php-imap php-ldap php-mysql php-odbc php-pear php-xmlrpc curl curl-devel perl-libwww-perl ImageMagick":confused:

[root@chick ssl]# apt-get update
Get:1 http://ayo.ie.freshrpms.net fedora/linux/4/i386 release [1834B]
Err http://ayo.ie.freshrpms.net fedora/linux/4/i386 release
Connection timed out
Get:2 http://ayo.ie.freshrpms.net fedora/linux/1/i386 release [1807B]
Fetched 1807B in 4m10s (7B/s)
Get:1 http://ayo.ie.freshrpms.net fedora/linux/4/i386/core pkglist [1768kB]
Err http://ayo.ie.freshrpms.net fedora/linux/4/i386/core pkglist
Error reading from server Remote end closed connection
Get:2 http://ayo.ie.freshrpms.net fedora/linux/4/i386/core release [151B]
Get:3 http://ayo.ie.freshrpms.net fedora/linux/4/i386/updates pkglist [1233kB]
Err http://ayo.ie.freshrpms.net fedora/linux/4/i386/updates pkglist
Connection timed out
Err http://ayo.ie.freshrpms.net fedora/linux/4/i386/updates release
Connection failed
Get:4 http://ayo.ie.freshrpms.net fedora/linux/4/i386/freshrpms pkglist [68.4kB]
Err http://ayo.ie.freshrpms.net fedora/linux/4/i386/freshrpms pkglist
Connection timed out
Get:5 http://ayo.ie.freshrpms.net fedora/linux/4/i386/freshrpms release [161B]
Get:6 http://ayo.ie.freshrpms.net fedora/linux/4/i386/tupdates pkglist [51.9kB]
Err http://ayo.ie.freshrpms.net fedora/linux/4/i386/tupdates pkglist
Connection timed out
Get:7 http://ayo.ie.freshrpms.net fedora/linux/4/i386/tupdates release [166B]
Get:8 http://ayo.ie.freshrpms.net fedora/linux/1/i386/core pkglist [1447kB]
Err http://ayo.ie.freshrpms.net fedora/linux/1/i386/core pkglist
Connection timed out
Get:9 http://ayo.ie.freshrpms.net fedora/linux/1/i386/core release [151B]
Get:10 http://ayo.ie.freshrpms.net fedora/linux/1/i386/updates pkglist [455kB]
Err http://ayo.ie.freshrpms.net fedora/linux/1/i386/updates pkglist
Connection timed out
Get:11 http://ayo.ie.freshrpms.net fedora/linux/1/i386/updates release [157B]
Get:12 http://ayo.ie.freshrpms.net fedora/linux/1/i386/freshrpms pkglist [184kB]
Err http://ayo.ie.freshrpms.net fedora/linux/1/i386/freshrpms pkglist
Connection timed out
Get:13 http://ayo.ie.freshrpms.net fedora/linux/1/i386/freshrpms release [161B]
Fetched 947B in 25m58s (1B/s)
Failed to fetch http://ayo.ie.freshrpms.net/fedora/linux/4/i386/base/release Connection timed out
Failed to fetch http://ayo.ie.freshrpms.net/fedora/linux/4/i386/base/pkglist.core Error reading from server Remote end closed connection
Failed to fetch http://ayo.ie.freshrpms.net/fedora/linux/4/i386/base/pkglist.updates Connection timed out
Failed to fetch http://ayo.ie.freshrpms.net/fedora/linux/4/i386/base/release.updates Connection failed
Failed to fetch http://ayo.ie.freshrpms.net/fedora/linux/4/i386/base/pkglist.freshrpms Connection timed out
Failed to fetch http://ayo.ie.freshrpms.net/fedora/linux/4/i386/base/pkglist.tupdates Connection timed out
Failed to fetch http://ayo.ie.freshrpms.net/fedora/linux/1/i386/base/pkglist.core Connection timed out
Failed to fetch http://ayo.ie.freshrpms.net/fedora/linux/1/i386/base/pkglist.updates Connection timed out
Failed to fetch http://ayo.ie.freshrpms.net/fedora/linux/1/i386/base/pkglist.freshrpms Connection timed out
Reading Package Lists... Done
Building Dependency Tree... Done
W: Release files for some repositories could not be retrieved or authenticated. Such repositories are being ignored.
W: You may want to run apt-get update to correct these problems
E: Some index files failed to download, they have been ignored, or old ones used instead.

till
14th November 2005, 14:49
Hi Falko, Till , I have disable my Firewall on my router and still not looking good. I'm runnuing apt-get update and seems only fews are able to update. Do I just retry again or better change again to another mirror sites? And if I'm lucky able to update, what is the next steps? Do I just run "apt-get install php php-devel php-gd php-imap php-ldap php-mysql php-odbc php-pear php-xmlrpc curl curl-devel perl-libwww-perl ImageMagick":confused:

If the packge lists cannot be updated, you will have to chose another mirror. If the package lists have been updated correctly you can install the packeages with apt-get install .....

But I think you have general problem with your internet connection because the ayo.... sites are really fast and you shall not get timeouts at all.

dstme
14th November 2005, 15:44
Thanks Till :rolleyes:
I finally got it after trying few mirror. uk3 was fast. So no problem until the last page.
I follow the steps:
install HTML::Parser
install DB_File
install Net::DNS (when prompted to enable tests, choose no)
install Digest::SHA1
q (to leave the Perl shell)

but I got the following:
t/09-tkey.t 255 65280 7 13 185.71% 1-7
t/10-recurse.t 2 512 ?? ?? % ??
t/11-escapedchars.t 2 512 ?? ?? % ??
t/11-inet6.t 1 256 6 1 16.67% 1
2 tests and 12 subtests skipped.
Failed 20/23 test scripts, 13.04% okay. 707/768 subtests failed, 7.94% okay.
make: *** [test_dynamic] Error 1
/usr/bin/make test -- NOT OK
Running make install
make test had returned bad status, won't install without force

cpan> install Digest::SHA1
Digest::SHA1 is up to date.

cpan> q
No history written (no histfile specified).
Lockfile removed.


I did not see HTML::Parser is up to date.

Do I have to run the command: /usr/bin/make install ?
This is my last bit before finish...:cool:

till
14th November 2005, 15:51
Please run the steps to install the perl modules again and make shure you chose no when you are prompted if tests for the Net module shall be enabled.

dstme
14th November 2005, 16:00
ok Done it 3 times and when prompt, I put "n" and result is:

Test returned status 1 (wstat 256, 0x100)
DIED. FAILED test 1
Failed 1/6 tests, 83.33% okay (less 5 skipped tests: 0 okay, 0.00%)
Failed Test Stat Wstat Total Fail Failed List of Failed
-------------------------------------------------------------------------------
t/00-load.t 72 18432 75 143 190.67% 1 5-75
t/01-resolver-env.t 255 65280 13 25 192.31% 1-13
t/01-resolver-file.t 1 256 8 1 12.50% 1
t/01-resolver-opt.t 255 65280 60 119 198.33% 1-60
t/01-resolver.t 255 65280 44 87 197.73% 1-44
t/02-header.t 255 65280 18 35 194.44% 1-18
t/03-question.t 255 65280 11 21 190.91% 1-11
t/04-packet-unique-push.t 255 65280 75 149 198.67% 1-75
t/04-packet.t 255 65280 39 77 197.44% 1-39
t/05-rr-opt.t 255 65280 7 13 185.71% 1-7
t/05-rr-sshfp.t 2 512 ?? ?? % ??
t/05-rr-txt.t 255 65280 28 55 196.43% 1-28
t/05-rr-unknown.t 255 65280 18 35 194.44% 1-18
t/05-rr.t 255 65280 219 437 199.54% 1-219
t/06-update.t 255 65280 72 143 198.61% 1-72
t/07-misc.t 255 65280 22 42 190.91% 1-22
t/09-tkey.t 255 65280 7 13 185.71% 1-7
t/10-recurse.t 2 512 ?? ?? % ??
t/11-escapedchars.t 2 512 ?? ?? % ??
t/11-inet6.t 1 256 6 1 16.67% 1
2 tests and 12 subtests skipped.
Failed 20/23 test scripts, 13.04% okay. 707/768 subtests failed, 7.94% okay.
make: *** [test_dynamic] Error 1
/usr/bin/make test -- NOT OK
Running make install
make test had returned bad status, won't install without force

cpan> install Digest::SHA1
Digest::SHA1 is up to date.

cpan> q
No history written (no histfile specified).
Lockfile removed.


Anywhere that I miss?:mad:

falko
14th November 2005, 16:27
make test will always be performed. The "enable tests" question refers to something different.
The Net::DNS module is not necessary so if you can't install it it's no problem. You can install ISPConfig nevertheless.:)

dstme
14th November 2005, 16:34
Thanks Falko.:)
However I did not see the following:
Successful installation of a module looks like this:

/usr/bin/make install -- OK

Any problem?

falko
14th November 2005, 17:11
Thanks Falko.:)
However I did not see the following:


Any problem?
That's because make test failed. As I've said before, you don't need the Net::DNS module.

dstme
14th November 2005, 18:52
Thanks guys! You are great. Complete installing. Now time for ISPConfig..:rolleyes: