PDA

View Full Version : not working correctly


davidg
17th July 2005, 12:50
Installed ISPconfig on SUSE 9.2 box, configured with your how-to's and everything installed great. I can log in but the management menu on the left side of the web page does not work, the error is HTTP 404 - File not found
Internet Explorer . I am using https://xxx.xxx.xxx:81 to log in. Should I uninstall, then re-install and use http instead of https? Thank you for your help.

till
17th July 2005, 14:39
Installed ISPconfig on SUSE 9.2 box, configured with your how-to's and everything installed great. I can log in but the management menu on the left side of the web page does not work, the error is HTTP 404 - File not found
Internet Explorer . I am using https://xxx.xxx.xxx:81 to log in. Should I uninstall, then re-install and use http instead of https? Thank you for your help.

The left page is rendered with Javascript, check in your browser settings
if javascript is enabled or try to add your server to the thrusted sites.

If this does not help, try to reinstall ISPConfig:

1) run this command as root user on the shell
to uninstall ISPConfig:

/root/ispconfig/uninstall

2) Then install it again. It should work with https as well as with http


Till

davidg
17th July 2005, 22:24
Thank you for the very fast response.

I made corrections as you stated and the menu is still not working. I know thats a problem with Microsoft Internet Explorer, because it works on my Macintosh.

I uninstalled and reinstalled and everything is working except the proftpd.

Message log states:
unable to create ipbind 'xxx.xxx.x.51:21 already bound to 'ProFTPD Default Installation'

I have three ip's xxx.xxx.x.50, 51, 52 the errors only show up on the ip's 51 and 52 and the service won't start. ISPConfig shows offline and will not restart.

The other question I have is everytime I make change on the management screen I have to re-login.

Other question should I make a contribution or do you prefer the purchase of your commercial product. You guys need to be paid for all this!!

Thank you.

admin
18th July 2005, 12:00
Thank you for the very fast response.

I made corrections as you stated and the menu is still not working. I know thats a problem with Microsoft Internet Explorer, because it works on my Macintosh.

I uninstalled and reinstalled and everything is working except the proftpd.

Message log states:
unable to create ipbind 'xxx.xxx.x.51:21 already bound to 'ProFTPD Default Installation'

I have three ip's xxx.xxx.x.50, 51, 52 the errors only show up on the ip's 51 and 52 and the service won't start. ISPConfig shows offline and will not restart.

This looks if there proftpd already has an active default configuration.
Here is a minimal proftpd.conf that works well with ISPConfig.

##### BEGIN proftpd.conf ################

ServerName "FTPServer"
ServerType standalone
DeferWelcome off

ShowSymlinks on
MultilineRFC2228 on
DefaultServer on
ShowSymlinks on
AllowOverwrite on

TimeoutNoTransfer 600
TimeoutStalled 600
TimeoutIdle 1200

DisplayLogin welcome.msg
DisplayFirstChdir .message
LsDefaultOptions "-l"

MaxInstances 30

<Directory /*>
Umask 022 022
AllowOverwrite on
</Directory>

DefaultRoot ~
IdentLookups off
UseReverseDNS off
ServerIdent on "FTP Server ready."

Include /etc/proftpd_ispconfig.conf

##### END proftpd.conf ################



The other question I have is everytime I make change on the management screen I have to re-login.

Have you enabled cookies?

Is the URL in the variable: $go_info["server"]["server_url"] in the
ISPConfig configuration file correct for your server? The path of the
config file is: /home/admispconfig/ispconfig/lib/config.inc.php

Other question should I make a contribution or do you prefer the purchase of your commercial product. You guys need to be paid for all this!!

Thank you.

This project has no donation button yet. It will be kind if you could
tell other poeple about our project :)

Till

davidg
19th July 2005, 09:54
Still problems after uninstall and reinstall of ISPconfig

Proftpd does not start with the last line in the proftpd.conf:
Include /etc/proftpd_ispconfig.conf

If I comment out the line proftpd starts.
The error is:
notice: 'FTPServer' (192.168.0.50:21) already bound to 'FTPServer
bindings.c:880: notice: unable to create ipbind '192.168.0.50': Address already in use

notice: 'FTPServer' (192.168.0.51:21) already bound to 'FTPServer
bindings.c:880: notice: unable to create ipbind '192.168.0.51': Address already in use

notice: 'FTPServer' (192.168.0.52:21) already bound to 'FTPServer
bindings.c:880: notice: unable to create ipbind '192.168.0.52': Address already in use

Proftpd did start before the uninstall and reinstall
In ISPConfig status shows offline for ftp server.

Thanks for your help.

till
19th July 2005, 11:57
Still problems after uninstall and reinstall of ISPconfig

Proftpd does not start with the last line in the proftpd.conf:
Include /etc/proftpd_ispconfig.conf

If I comment out the line proftpd starts.
The error is:
notice: 'FTPServer' (192.168.0.50:21) already bound to 'FTPServer
bindings.c:880: notice: unable to create ipbind '192.168.0.50': Address already in use

notice: 'FTPServer' (192.168.0.51:21) already bound to 'FTPServer
bindings.c:880: notice: unable to create ipbind '192.168.0.51': Address already in use

notice: 'FTPServer' (192.168.0.52:21) already bound to 'FTPServer
bindings.c:880: notice: unable to create ipbind '192.168.0.52': Address already in use

Proftpd did start before the uninstall and reinstall
In ISPConfig status shows offline for ftp server.

Thanks for your help.


1) Have you stopped proftpd before changing the configuration?
You can try a "killall proftpd" before you start it.

2) Is the file /etc/proftpd_ispconfig.conf there and what is the
content of the file.

3) Are there any other FTP daemons running on your Server?

falko
19th July 2005, 12:00
2) Is the file /etc/proftpd_ispconfig.conf there and what is the
content of this file.

Yes, can you post your /etc/proftpd_ispconfig.conf here?

davidg
19th July 2005, 12:26
Commands entered
"killall proftpd"
proftpd: no process killed

server1:/ # /etc/init.d/proftpd start
Starting ProFTPD Server: - warning: "ProFTPD" address/port (192.168.0.50:21) already in use by "FTPServer"
failed

Yes, proftpd_ispconfig.conf is at /etc/proftpd_ispconfig.conf
Contents of proftpd_ispconfig.conf:
###################################
#
# ISPConfig proftpd Configuration File
# Version 1.0
#
###################################
<VirtualHost 192.168.0.50>
DefaultRoot ~
AllowOverwrite on
Umask 002
</VirtualHost>
<VirtualHost 192.168.0.51>
DefaultRoot ~
AllowOverwrite on
Umask 002
</VirtualHost>
<VirtualHost 192.168.0.52>
DefaultRoot ~
AllowOverwrite on
Umask 002
</VirtualHost>

no other ftp server is running, if I comment out the proftpd_ispconfig.conf line then the ftp service starts and I can ftp into the server.

Also remember this is on a re-install of ispconfig, I had no errors with ftp on the first install.

Thanks for all your help.

falko
19th July 2005, 12:38
Can you check if the line
Include /etc/proftpd_ispconfig.conf
is included more than once in /etc/proftpd.conf?

davidg
19th July 2005, 12:49
As far as I can see there is not 2 instances of the line in proftpd.conf.

Here is my proftpd.conf file. I commented out the original file created by ispconfig and copied over the post from earlier to test proftpd.conf. I had to comment out the line #LsDefaultOptions "-l" because there was an error when proftpd started.

# This is a basic ProFTPD configuration file (rename it to
# 'proftpd.conf' for actual use. It establishes a single server
# and a single anonymous login. It assumes that you have a user/group
# "nobody" and "ftp" for normal operation and anon.

#ServerName "Default FTP Server"
#ServerType standalone
#DefaultServer on

# Port 21 is the standard FTP port.
#Port 21

# Umask 022 is a good standard umask to prevent new dirs and files
# from being group and world writable.
#Umask 022

# To prevent DoS attacks, set the maximum number of child processes
# to 30. If you need to allow more than 30 concurrent connections
# at once, simply increase this value. Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd).
#MaxInstances 30

# Set the user and group under which the server will run.
#User nobody
#Group nogroup

# To cause every FTP user to be "jailed" (chrooted) into their home
# directory, uncomment this line.
#DefaultRoot ~
#IdentLookups off
#ServerIdent on "Default FTP Server Ready"

# Normally, we want files to be overwriteable.
#AllowOverwrite on

# Bar use of SITE CHMOD by default
#<Limit SITE_CHMOD>
# DenyAll
#</Limit>

# A basic anonymous configuration, no upload directories. If you do not
# want anonymous users, simply delete this entire <Anonymous> section.
#<Anonymous ~ftp>
# User ftp
# Group ftp

# We want clients to be able to login with "anonymous" as well as "ftp"
# UserAlias anonymous ftp

# Limit the maximum number of anonymous logins
# MaxClients 10

# We want 'welcome.msg' displayed at login, and '.message' displayed
# in each newly chdired directory.
# DisplayLogin welcome.msg
# DisplayFirstChdir .message

# Limit WRITE everywhere in the anonymous chroot
# <Limit WRITE>
# DenyAll
# </Limit>
#</Anonymous>




#Include /etc/proftpd_ispconfig.conf

#Copied from user post

ServerName "FTPServer"
ServerType standalone
DeferWelcome off

ShowSymlinks on
MultilineRFC2228 on
DefaultServer on
ShowSymlinks on
AllowOverwrite on

TimeoutNoTransfer 600
TimeoutStalled 600
TimeoutIdle 1200

DisplayLogin welcome.msg
DisplayFirstChdir .message
#LsDefaultOptions "-l"

MaxInstances 30

<Directory /*>
Umask 022 022
AllowOverwrite on
</Directory>

DefaultRoot ~
IdentLookups off
UseReverseDNS off
ServerIdent on "FTP Server ready."

Include /etc/proftpd_ispconfig.conf

falko
19th July 2005, 14:44
Did you try and reboot your server? Maybe your problems are gone then.

davidg
19th July 2005, 21:20
Yes I have rebooted the server 3 times.

Do you think there is anything in SuSEconfig that could cause problems?

Should I uninstall and reinstall ISPConfig again, if so should I do anything after I run the uninstall routine.

till
19th July 2005, 23:10
Yes I have rebooted the server 3 times.

Do you think there is anything in SuSEconfig that could cause problems?

yes, maybe. Are you shure vsftpd is not installed
beside proFTPD?

Should I uninstall and reinstall ISPConfig again, if so should I do anything after I run the uninstall routine.

No, that would not help. This is not a problem of the ISPConfig
setup. The problem is that there are other processes
running that are bound to the FTP ports.

You have to identify the programs that are bound to the ports
and stop them, before you can start the proftpd daemon.

If you want me or Falko login to your server and have a look at your
setup, please contact me via email: t.brehm [at] ispconfig [dot] org

davidg
20th July 2005, 04:52
Proftpd worked before I re-installed ISPConfig.

All I did was uninstall ISPConfig then reboot the server, then install ISPConfig with the same setup I had before. I chose the complete uninstall option. I used expert mode to use suexec for cgi as per the documentation.

ISPConfig worked before with proftpd then I reinstalled and everything works except proftpd.

Thanks for all your help.

till
20th July 2005, 13:16
The ProFTPD on SuSe needed the following additional directive
in the proftpd.conf cofiguration file:

SocketBindTight on

to start correctly with an virtual IP configuration.
We added this to the Tutorial on Howtoforge too.

Explanation from the proFTPD vHosting Howto:
http://www.castaglia.org/proftpd/doc/contrib/ProFTPD-mini-HOWTO-Vhost.html

....
There is one last configuration directive about which an administrator should know: SocketBindTight. By default, the proftpd daemon will listen on all addresses, port 21, for the connection requests of remote clients. Sometimes, the administrator may wish to have the proftpd daemon listen only on the IP addresses for which it has been configured, and not every address. To accomplish this, simply use the SocketBindTight configuration directive:

SocketBindTight on

This configures the daemon to "bind tightly" only to those IP addresses to which it has been configured to listen, rather than every address. By default, the proftpd daemon will listen to every address on the host machine.
....

Intersting thing: On e.g Debian or Mandrake this directive is not nescessary,
maybe its related to the newer ProFTPD version.


Till

jcartland
11th August 2005, 04:56
I had the same problem on SuSE 9.3, spent quite a while chasing it --
....
I uninstalled and reinstalled and everything is working except the proftpd.

Message log states:
unable to create ipbind 'xxx.xxx.x.51:21 already bound to 'ProFTPD Default Installation'
...
ISPConfig shows offline and will not restart.

What worked once was to kill both proftpd AND ispconfig, edit the proftpd.conf, and THEN run /etc/init.d/ispconfig start. Thought I had it solved, then had the same problem again. It's working now, problem seems to be that I'd installed proftpd to start at boot, then ispconfig was trying to start it again.

PS - Thanks for this project. Before I found it, I spent way too much time trying to configure a control panel project, written in perl, which has "gone professional". This is better code and better attitude.